Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: PLC-sim Laufzeitfehler bei FC40 und SFB4 aufruf (S7)

  1. #1
    Anonymous Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    mein Problem ist das mein programm nur ein Zyklus läuft.
    Programmbeschreibung: Zwei Zeitpunkte (MD doppelinteger) werden mit
    "TIme_Tck" aufgezeichnet, subtrahiert und dann an Funktion FC40(Tim_s5ti) oder an SFB4(TON) übergeben ). Bei jeder dieser Funktionen steigt mein Programm aus . Falls mir jemand weiterhelfen kann oder eine Alternatinvlösung hat wäre ich dankbar.
    Gruss Andi
    PS: Ich bin S7 Neuling
    Zitieren Zitieren Gelöst: PLC-sim Laufzeitfehler bei FC40 und SFB4 aufruf (S7)  

  2. "Hallo Andy,

    die Subtraktion verläuft korrekt? Beachte auch daß die Sytemzeit nach x Tagen überläuft und bei "0" neu anfängt zu zählen. Hast du den "alten Zeitwert" statisch gespeichert? Hast du den Instanz-DB geladen?

    Wenn die CPU anhält, sieh auch im Diagnosepuffer nach (im Simatic-Manager <Crt><D>) und poste uns ggf die Fehlermeldungen.


    Gruß, Onkel"


  3. #2
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Sorry,
    kann das so nicht nachstellen. Kannnst Du da mal posten?

    pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

  4. #3
    Registriert seit
    06.10.2003
    Beiträge
    3.411
    Danke
    451
    Erhielt 506 Danke für 408 Beiträge

    Standard

    Hallo Andy,

    die Subtraktion verläuft korrekt? Beachte auch daß die Sytemzeit nach x Tagen überläuft und bei "0" neu anfängt zu zählen. Hast du den "alten Zeitwert" statisch gespeichert? Hast du den Instanz-DB geladen?

    Wenn die CPU anhält, sieh auch im Diagnosepuffer nach (im Simatic-Manager <Crt><D>) und poste uns ggf die Fehlermeldungen.


    Gruß, Onkel

  5. #4
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Sorry,
    kann das so nicht nachstellen. Kannnst Du da mal posten?

    pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

  6. #5
    Anonymous Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Das ganze Problem hat sich heute morgen erledigt. Das selbe Programm lief nach Rechnerneustart. Kann mir das nicht erklären

    Gruss und Danke für die Mithilfe

Ähnliche Themen

  1. Multiinstanz mit SFB4
    Von Dabbes vorm Herrn im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 07.12.2017, 10:02
  2. Antworten: 9
    Letzter Beitrag: 10.02.2011, 10:46
  3. SFB4 (TON) in SCL
    Von Gerri im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 06.10.2009, 21:11
  4. S7-315 2dp und FC40 time->s5time
    Von robby im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 08.11.2008, 15:20
  5. SFB4 als Multiinstanz
    Von Anonymous im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 01.09.2008, 18:46

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •