Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 6 ErsteErste 12345 ... LetzteLetzte
Ergebnis 21 bis 30 von 57

Thema: Fehlersuche: Profibus Ausfall

  1. #21
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.263
    Danke
    537
    Erhielt 2.708 Danke für 1.957 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von olitheis Beitrag anzeigen
    Hallo,
    nochmal kurz die Frage:
    Wie kann ich denn jetzt die Memory Card auf der CPU beschreiben (ohne PG)?
    Ram nach Rom kopieren oder Auf Memory Card speichern (oder?)?
    Danke
    Oli
    Ich mach immer "RAM nach ROM kopieren", um die aktuellen Daten zu sichern.
    Aber auch das ist von der CPU abhängig.
    "Auf Memory Card speichern" ergibt bei mir die Meldung:
    "Die Projektdaten können nur auf eine Memory Card im PG für die S7 400 oder auf die Memory Card in einer S7 400 CPU gespeichert werden."
    Was wohl gleichzeitig besagt, daß die gesamten Projektdateien auf der Memory Card landen, wobei ich keine CPU 400 zur Verfügung hab.

    Sieh auch mal hier: http://www.sps-forum.de/showpost.php...6&postcount=15
    Geändert von Ralle (27.06.2007 um 09:23 Uhr)
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  2. #22
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Beitrag

    Hi,
    betr. Diskussion über Baudraten und Längen: die max Längen von
    Siemens beziehen sich auf opt. Bedingungen. Daher:
    die DB Baudrate runterfahren ist immer eine Probe wert, es bewirkt oft Wunder!
    Solche Fehler sicher zu lokalisieren: vergessene Sache. Teure SPS
    bzw. Bus Analysatoren, Langzeitaufzeichnungen usw.: wer
    macht das schon?

    Deshalb mein Vorschlag:
    1) Busleitungen/Stecker checken; evtl. neu verlegen(EMV Störungen?)
    2) Baudrate reduzieren
    3) Durch Diag. Bausteine versuchen, Fehler-Infos zu bekommen.

    Viel Erfolg: Vladi
    ______________________________________
    relax, take it easy
    Zitieren Zitieren DP Störungen  

  3. #23
    olitheis ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.07.2005
    Beiträge
    454
    Danke
    22
    Erhielt 1 Danke für 1 Beitrag

    Standard

    @vladi
    was meinst Du, wie Weit ich runtergehen kann?
    Also die CPU steht ja auf 187.5kbit/s (MPI)
    Die DP-Slaves auf 1.5Mbit/s (nächste Stufe wäre 500kbit/s).
    Ich denke Du redest nur von den Slaves, richtig? Und dann alle gleich?

    Danke
    Oli
    Press "Play" on Tape
    -------------------------------
    TwinCAT
    Step7
    Barber-Colman MacoDS
    Schneider Momentum SPS
    Wonderware 8.0
    Concept 2.2 SR2
    Vipa
    Allen-Bradley

  4. #24
    Registriert seit
    21.06.2007
    Beiträge
    45
    Danke
    0
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Zitat Zitat von olitheis Beitrag anzeigen
    @vladi
    was meinst Du, wie Weit ich runtergehen kann?
    Also die CPU steht ja auf 187.5kbit/s (MPI)
    Die DP-Slaves auf 1.5Mbit/s (nächste Stufe wäre 500kbit/s).
    Ich denke Du redest nur von den Slaves, richtig? Und dann alle gleich?

    Danke
    Oli
    Hi
    also ich check das grad nicht ganz....hast die CPU auf MPI mit 187,5 stehen und die Slaves hängen da dran mit 1,5?
    Also so geht das net falls das wirklich so ist, weil es müssen alle Teilnehmer die selben Busparameter haben. Und das haben sie auch wenn die am Mastersystem der CPU hängen. Lad doch nochmal deine Konfig hoch damit man sich das nochmal ansehen kann
    Schon mal schönen Feierabend

    Mfg dasding

  5. #25
    Registriert seit
    28.04.2005
    Beiträge
    206
    Danke
    22
    Erhielt 17 Danke für 14 Beiträge

    Standard

    Wie sieht es denn mit den Busabschlüssen in den Teilnehmern aus?

    Wir hatten mal ein ähnliches Problem, damals mit SEW Movidrive MD 60_A's. Die hatten auf den Profibus-Karten nochmal extra Abschlusswiderstände. Irgendwer, der es besonders gut gemeint hat, hat dann bei den Umrichtern die am Strangende waren die Abschlusswiderstände aufgeschaltet, aber nicht beachtet, dass der Bus schon im Stecker abgeschlossen wurde.

    Der Fehler trat wie in deinem Fall mal Tagelang nicht auf und plötzlich 5 mal hintereinander usw. (Geisterfehler).

    MFG

    Markus

  6. #26
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Ausrufezeichen

    Moooooment, so gehts nicht!

    Zitat Zitat von olitheis Beitrag anzeigen
    @vladi
    was meinst Du, wie Weit ich runtergehen kann?
    Also die CPU steht ja auf 187.5kbit/s (MPI)
    Die DP-Slaves auf 1.5Mbit/s (nächste Stufe wäre 500kbit/s).
    Ich denke Du redest nur von den Slaves, richtig? Und dann alle gleich?
    Oli
    MPI und DP sind zwei verschiedene Bus Systeme an der SPS. Die MPI Seite
    ist klar: da kann man VISU, OPs, andere SPSen ansprechen. Die Baudrate ist da immer 187.5, das ist Siemens speziall Bus. An MPI gibt es kein
    Master und Slaves in diesem Sinne.

    Die DP Seite ist Master-Slaves Aufbau, ALLE fahren mit der gleichen
    Baudrate(ob 1,5Mbit/s oder 93,75kbit/s, egal). Normalerweise wird bei
    moderne Slaves keine Busrate mehr eingetragen, nur die eindeutige DP
    Adresse(DIP Schalter, elektronisch). Der Master initialisiert alle beim
    Start, er sagt "Freunde, sie sind jetzt bei mir angemeldet, wir fahren schön jetzt mit 500 kbit/s, aufpassen und kein Sch..s bauen!". Und dann sprechen sie miteinander.
    Das bedeutet: die Baudrate im HW Konfig ändern, speichern, SPS laden, und dann wäre die Sache fertig! Der Master initialisiert dann sein Bus.
    Wenn als Slaves noch SPSen dran hängen, muss man entspr. die Konfig's
    ändern und auch alle neu laden, wegen der neuen Baudrate.

    Gruss: Vladi
    ______________________________________
    relax, take it easy
    Zitieren Zitieren Dp/mpi  

  7. #27
    olitheis ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.07.2005
    Beiträge
    454
    Danke
    22
    Erhielt 1 Danke für 1 Beitrag

    Standard

    @dasding
    bitte schau mal weiter vorne, da habe ich die HW konfig mal hochgeladen. Sag mir bescheid, wenn Du damit nichts anfangen kannst.

    @vladi
    Das bedeutet: die Baudrate im HW Konfig ändern, speichern, SPS laden, und dann wäre die Sache fertig! Der Master initialisiert dann sein Bus.
    ´
    Du meinst also, am besten alle Slaves auf durchweg auf 500kbit/s im HW Konfig. runterschrauben?

    Noch eine Frage, wie initialisiert denn der Master den Bus, wenn verschiedene baudraten bei den Slaves eingestellt wurden im HW Konfig?
    Vielen Dank
    Oli
    Press "Play" on Tape
    -------------------------------
    TwinCAT
    Step7
    Barber-Colman MacoDS
    Schneider Momentum SPS
    Wonderware 8.0
    Concept 2.2 SR2
    Vipa
    Allen-Bradley

  8. #28
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.263
    Danke
    537
    Erhielt 2.708 Danke für 1.957 Beiträge

    Standard

    Zitat Zitat von olitheis Beitrag anzeigen
    Noch eine Frage, wie initialisiert denn der Master den Bus, wenn verschiedene baudraten bei den Slaves eingestellt wurden im HW Konfig?
    Vielen Dank
    Oli
    Wo stellst du denn die unterschiedlichen Baudraten bei den Slaves ein? So wie ich das verstehe, gibt es Slavebaugruppen, denen man die Baudrate in einem Setup einstellen muß (etliche OP/TP) und es gibt Slavebaugruppen, die die Baudrate selbst ermitteln (Indramatservos mit Profibus, Festo-Ventilblöcke etc.). Die meißten Slavebaugruppen passen sich der Baudrate an, i.d.R. allerdings erst bei Zuschalten der Spannung, also Baudrate ändern in der CPU, Hardwareconfig übertragen und danach Spannung aus und wieder an.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  9. #29
    Registriert seit
    21.06.2007
    Beiträge
    45
    Danke
    0
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Zitat Zitat von olitheis Beitrag anzeigen
    @dasding
    bitte schau mal weiter vorne, da habe ich die HW konfig mal hochgeladen. Sag mir bescheid, wenn Du damit nichts anfangen kannst.
    Ja hab ich mir schon angeschaut... ist bloß doof das ich die GSD Dateien nicht habe, dadurch hab ich eventuell nicht alle parametriemöglichkeiten an den Slaves, aber wenn ich mir das ansehe was bei mir geht, dann steht dein Master (315-2DP) auf 1,5Mbits und deine Slaves hängen dort dran und haben auch 1,5 Mbits-> also so sieht alles in Ordnung aus.
    Wenn nun noch die Leitungen richtig verlegt sind und die Widerstände richtig eingeschalten sind, länge nicht überschritten wird und sonst nichts anderes bei den Slaves zu beachten ist(kenn die nicht) dann sollte es eigentlich laufen,aber wie gesagt eigentlich
    Was war das mit der Geschichte, das dein Kunde einige Slaves ausgetauscht hat? Sind diese Kompatibel zu den alten gewesen?

    Mfg dasding

  10. #30
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Beitrag


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi Oli,

    Zitat Zitat von olitheis Beitrag anzeigen
    @vladi
    Du meinst also, am besten alle Slaves auf durchweg auf 500kbit/s im HW Konfig. runterschrauben?
    Noch eine Frage, wie initialisiert denn der Master den Bus, wenn verschiedene baudraten bei den Slaves eingestellt wurden im HW Konfig?
    nochmals, kannst Du das nicht verstehen: Der DP Master initialisiert sein
    DP Bus selber. Wenn Du in HW Konfig eine Baudrate einstellst, gilt die für alle! So, und wie die Slaves die Baudrate wissen, da gibt es 2 Mögl.:
    1) pasive Slaves, die werden durch den Master eingestellt; man braucht da nur die DP Adresse manuell einstellen.(FUs, V-Inseln, IO Klemmen usw.)
    2) aktive Slaves, wie SPSen, OPs usw. Da muss man ausser die Adresse
    die Baudrate und evtl. andere Sachen einstellen, und diese neu laden.

    In deinem Fall sind die Slaves die 1) Sorte.

    Gruss: Vladi
    ______________________________________
    relax, take it easy
    Zitieren Zitieren DP nochmals!  

Ähnliche Themen

  1. Profibus CP 342-5 und Teilnehmer-Ausfall
    Von ssound1de im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 05.08.2011, 07:49
  2. Fehlersuche am Profibus
    Von jogger im Forum Feldbusse
    Antworten: 53
    Letzter Beitrag: 09.07.2008, 08:27
  3. Profibus ausfall
    Von vecoplaner im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 22.12.2007, 13:26
  4. Fehlersuche Profibus
    Von x108 im Forum Sonstige Steuerungen
    Antworten: 3
    Letzter Beitrag: 20.06.2007, 19:50
  5. Praxistip Fehlersuche Profibus-DP
    Von x108 im Forum Feldbusse
    Antworten: 4
    Letzter Beitrag: 25.10.2006, 03:10

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •