Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: CP340 - Fehlerstatus ??

  1. #1
    Registriert seit
    04.06.2007
    Beiträge
    16
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,


    habe meine CP340 mit Protokoll 3964R angesteuert, sende ein Protokoll mit Summenfehler und die CP340 sendet eine Antwort mit "NAK" (negatine Rückmeldung) -> soweit ja noch OK, sollte sie ja auch.

    Im FB-P_RCV soll angeblich nun ein Ausgang gsetzt sein mit "error" und im Ausgang "Status" des FB soll man den Fehlercode finden können. Leider sind hier keine Einträge, bzw es steht alles auf "0" (also kein Fehler).

    Meine CPU weiß also nicht, dass bei der Übertragung ein Fehler entstanden ist. Kennt da jemand einen Tip?

    gruß Mathias
    Zitieren Zitieren CP340 - Fehlerstatus ??  

  2. #2
    Registriert seit
    25.07.2005
    Ort
    Vogelsbergkreis
    Beiträge
    1.717
    Danke
    48
    Erhielt 68 Danke für 60 Beiträge

    Standard

    Kann es sein, dass der Fehler nur für einen Zyklus ansteht? Du musst also bei positiver Flanke am Fehlerbit den Statuscode umkopieren. (Ohne Gewähr)

  3. #3
    mathias007 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.06.2007
    Beiträge
    16
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo seeba,

    scheint wirklich so zu sein, dass da nur ein ganz kurzer Impuls ansteht - so kurz, dass noch nicht mal ein angeschlossenes birnchen leuchtet.


    Irgendwie klappt es aber nicht mit dem Sichern des fehlercodes.

    Bin hingegangen habe mit einem vergleicher gekuckt ob das Statuswort ungleich null ist und wollte es dann in einen Db kopieren, aber da steht trotzdem immer nur 00000000 drinn????

    Auszug:
    L MW30 /hier sollte der Fehlercode drinn stehen
    L 0 /fester wert: 0
    <>I / soll beide Werte vergleichen
    =M10.0 / Wenn Werte ungleich, dann Merker 10.0 setzen
    LMW30 /Soll MW30 geladne werden und
    T DB20.DBW40 / dann Wert in DB20 auf Wort40 kopieren

  4. #4
    Registriert seit
    25.07.2005
    Ort
    Vogelsbergkreis
    Beiträge
    1.717
    Danke
    48
    Erhielt 68 Danke für 60 Beiträge

    Standard

    Code:
          U #Impuls
          SPB M001
          SPA ENDE
    
    M001: L #Fehlercode
          T #Fehlercode_DB
    
    ENDE: NOP 0

  5. Folgender Benutzer sagt Danke zu seeba für den nützlichen Beitrag:

    mathias007 (26.06.2007)

  6. #5
    mathias007 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.06.2007
    Beiträge
    16
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Super, vielen dank

    hat funktioniert.

    Ich glaube ich hatte einen "Denkfehler" bei meinem konstrukt. egal ob der Merker 0 oder 1 hatte hat er den Befehl ausgeführt und somit wieder alles überschrieben.

    gruß Mathias

  7. #6
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Zitat Zitat von mathias007 Beitrag anzeigen
    Hallo seeba,


    Auszug:
    L MW30 /hier sollte der Fehlercode drinn stehen
    L 0 /fester wert: 0
    <>I / soll beide Werte vergleichen
    =M10.0 / Wenn Werte ungleich, dann Merker 10.0 setzen
    LMW30 /Soll MW30 geladne werden und
    T DB20.DBW40 / dann Wert in DB20 auf Wort40 kopieren
    Lade und Transferierbefehle sind nicht VKE abhängig, daran lag es wohl.
    Und, ist der eigentliche Fehler jetzt gefunden?

  8. #7
    mathias007 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.06.2007
    Beiträge
    16
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich vermute mal, da der FB bei jedem Zyklus aufgerufen wird, und der "Error-Status" bei erfolgreicher Übertragung =0 ist, hat sich der erzeugte "Testfehler" immer wieder mit der null überschrieben.


    Bin aber noch am Teste

    Gruß mathias

Ähnliche Themen

  1. CP340 Mit DALI
    Von DasAlphaTier im Forum Feldbusse
    Antworten: 21
    Letzter Beitrag: 19.11.2009, 08:47
  2. CP340 Beispiel
    Von Guste im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 12.10.2009, 20:11
  3. Suche S7 CP340
    Von Anonymous im Forum Suche - Biete
    Antworten: 2
    Letzter Beitrag: 22.07.2005, 09:15
  4. Kommunikation mit CP340
    Von capri-fan im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 30.05.2005, 09:40
  5. CP340
    Von mehdi im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 25.02.2005, 20:28

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •