Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: gestörte Analogwerte?

  1. #1
    Registriert seit
    21.09.2004
    Beiträge
    92
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich habe ein kleines Problem bei der Analogwert-Auswertung.
    Ich benutze eine 331-7FK01-0AB0 wie folgt:
    - 1. Kanal 4-20mA
    - 2. Kanal 4-20mA
    - 3 und 4 Kanal PT100
    - 5 und 6 Kanal PT100
    - 7. Kanal 0-10V
    - 8. Kanal Frei!

    Den freien Kanal habe ich auf Masse gelegt und die Mana auch mit GND verbunden.

    Problem bereitet der Kanal 1 und Kanal 7. Bei Messsignale laufen durch ein ca. 20 Meter ungeschirmtes Telefonkabel (bitte nicht schlagen).

    Kann es sein, dass durch die 0-10V von Kanal 7, das 4-20 mA Signal um bis zu 3 mA verfälscht wird. Das ein geschirmtes getrennes Kabel besser wäre ist mir klar, aber ich hätte nie gedacht, dass die Störung so groß sein könnte...

    Oder können auch andere Probleme die Ursache sein, evt. falsche Beschaltung? Macht es evt. einen unterschied wenn ich die PT100 Kanäle auf 5-8 lege und die 0-10V Messung auf Kanal 3 schalte?

    Gibt es die Möglichkeit die Störung zu filtern (Soft- oder Hardwaremäßig)?

    Ich bin sicher ihr könnt mir helfen!

    Vielen Dank vorab!

    MFG
    Küffel
    Zitieren Zitieren gestörte Analogwerte?  

  2. #2
    Registriert seit
    15.09.2006
    Ort
    Hessen
    Beiträge
    361
    Danke
    38
    Erhielt 36 Danke für 30 Beiträge

    Standard

    Also, wenn irgendwas anderes neben dem Telefonkabel liegt, würd' ich darauf tippen, dass es das Kabel ist...
    Hast du ein Oszi zur Verfügung?

    Gruß, Tobias
    Isn't simulating stimulating?

  3. #3
    Registriert seit
    21.09.2004
    Beiträge
    92
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hast recht, mit dem Oszi könnte ich mal schauen. Bringt die 50 Hz Entstörung, welche man in der Harware Konfig einstellen kann was?

  4. #4
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Also das ein 0-10V Signal das 4-20mA Signal um 3mA ändert dürfte nicht passieren, andersrum schom eher.
    Bei dem normalen IYST(Y) Telefonkabel, gibt es sehr schnell, durch quetschen der Adern eine Verbindung. Am besten wäre eine Messung mit einem Isolationsmessgerät. Wie sind denn die Leitungen verschaltet, sind es zwei Leiter oder vier-Leiter Sensoren ?
    Wenn Vier-Leiter(oder drei) sind die Masseleitungen mit auf einem Draht der 0-10V ?
    Mal ganz davon ab, könnte der M vom Sensor 1 an M von Eingang 7 hängen ? Nur mal so ins blaue geschossen

  5. #5
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.255
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Ich tippe auf ein GND- Problem!
    Die S7-Baugruppen brauchen bis auf die 7NF10 immer GND-ähnliches Potential.
    Wenn Du ein 4-20mA Signal einschleifst und dies zB über meinen Freund den Siemens Messwertrechner tust, dann ist wegen der Bürde bei 14mA Ebbe.

    Meine Frage daher: wie schaut der Loop genau aus?
    Was macht der Mana genau?
    3mA verschwinden nicht so!!

  6. #6
    Registriert seit
    21.09.2004
    Beiträge
    92
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zunächst vielen Dank für eure Antworten:

    Also ich lese heraus das ihr auch der Meinung seit, dass eine solch hohe Störung nicht alleine durch die Wechselwirkung der beiden Signale aufeinander hervorgerufen wird.

    Gut, dann gilt es den Fehler woanders zu suchen! Ich werde die Isolation untersuchen. Als erstes mal ein Sensor abklemmen und schauen was der andere macht.

    Ich werde mich mal auf die Suche machen, kann leider etwas dauern bis ich an die Analage komme!

    Danke nochmal

    Gruß
    Küffel

Ähnliche Themen

  1. Analogwerte
    Von siqo im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 07.07.2011, 01:30
  2. Analogwerte
    Von Alexandr im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 12.08.2010, 13:59
  3. Analogwerte speichern
    Von a.richter im Forum Elektronik
    Antworten: 8
    Letzter Beitrag: 01.06.2010, 08:23
  4. analogwerte
    Von Majus68 im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 31.08.2009, 14:41
  5. Analogwerte mit AS-i
    Von Johnathan im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 09.02.2006, 18:27

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •