Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: S7 414-2DP - Busfehler

  1. #1
    Registriert seit
    18.07.2007
    Beiträge
    15
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin Experten,
    es freut mich ein Forum gefunden zu haben, das meine Fragen beantworten
    könnte.
    Ich habe in der Vergangenheit S7 programmiert und mich mit Hardware nur beschäftigt, wenn es unbedingt notwendig war.
    Gestern war ich in einem Klärwerk, wo der Blitz eingeschlagen hat.
    Die SPS ist im RUN
    Externer Fehler: Dauerlicht rot
    Busfehler: Blinklicht rot
    Eine genaue Bustopologie gibt es nicht.
    Mein PG zeigte mir die gestörten Profibus- Busteilnehmer an.
    Es waren sechs (Stellantriebe und Durchflussmesser).
    Nach probeweisem Abziehen von Bussteckern reduzierte sich die Zahl der gestörten Teilnehmer auf 2.
    Nun meine Fragen:
    a) deutet das Blinken auf einen Hardwarefehler (Blitzwirkung) hin?
    b) gibt es eine Methode die Funktionsfähigkeit eines
    Busteilnehmers möglichst vor Ort zu überprüfen um einen Defekt
    sicher festzustellen?
    (Das sind klobige und teure Geräte)

    Es bedankt sich im voraus
    Dete
    Zitieren Zitieren S7 414-2DP - Busfehler  

  2. #2
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Beitrag

    Hi,
    BF LED blinkt, wenn der Master irgendein Slave am Bus nicht findet. Evtl. ist der Teilnehmer defekt, oder Buseinstellungen haben sich verändert(Adr. o.ä.).
    SF Fehler leuchtet, weil Adressbereiche nicht erreichbar sind: im Programm wird irgendwo auf die Adressen von dem fehlenden Slave geschrieben, und die sind halt weg. Oder: ein I/O Modul ist defekt.

    Die Geräte haben meistens irgendwie Diagnosestatus, kann man da nichts sehen?

    Vladi
    ______________________________________
    relax, take it easy
    Zitieren Zitieren Fehler  

  3. #3
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.620
    Danke
    777
    Erhielt 647 Danke für 493 Beiträge

    Standard

    Zitat Zitat von dete Beitrag anzeigen
    Moin Experten,
    Busteilnehmers möglichst vor Ort zu überprüfen um einen Defekt
    sicher festzustellen?
    (Das sind klobige und teure Geräte)

    Ich würds so machen.
    Eine S7-300 mit DP nehmen ein Profibuskabel konfektionieren und dann jeweils testweise die verschiedenen Profibusteilnehmer direkt anschliessen und ansprechen.

    Es gibt sonnst von Siemens einen Profibustester (ca. 600 Euro) wie der funktioniert kann ich leider nicht sagen, war mir bis jetzt immer zu Teuer um ihn zu kaufen.

    Was ich ausserdem auch schon gehabt habe, das Leute an den Adresschaltern rumgespielt haben und nach nem Stromausfall hatten die Teilnehmer dann auf einmal andere Adressen und stritten sich mit richtig eingestellten Teilnehmern um die Daten.

    mfG René

  4. #4
    dete ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    18.07.2007
    Beiträge
    15
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Vladi, hallo Rene,
    das waren doch schon recht brauchbare Hinweise.

    zur Gerätediagnose: Es gibt im (defekten?) Gerät eine LED, die einen Busfehler
    meldet. Allerdings würde ich dieser Anzeige nicht so sehr vertrauen,
    weil sie sicher auch blinkt, wenn ein vorgeordneter Busteilnehmer einen
    "Buskurzschluss" oä. hat und damit den Rest der Leitung tot macht.

    Die Variante mit der "Service-S7" hört sich gut an.
    Scheint die sinnvollste Variante zu sein.

    Danke vielmals sagt
    Dete

  5. #5
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Hallo,
    es gibt da noch die Software Amprolyzer die eine Profibusdiagnose ermöglicht. Dort wird eine genaue Auflistung der erreichbaren Teilnehmer etc. gemacht.

    Ein sehr hilfreiches Tool aber auch nicht ganz billig!!
    Außerdem benötigt man bei 12MBaud zusätzlich ein aktives Kabel.

    Da ich davon ausgehe, das dein Kabel nicht defekt ist, und alles andere (WIderstände, Anschluss etc.) i.O. ist, würde ich mal versuchen , den ein oder anderen Teilnehmer herauszunehmen aus der HW Konfig um zu schauen ob mann den Bus dann wieder zu laufen bekommt, ist aber bei einem Klärwerk wahrscheinlich nicht so einfach.

    Habe nach Überspannung auch schon mal einen tollen Fehler gehabt, Busfehler 1 Station ausgefallen, Station aber im PG sichtbar. Einbau einer neuen Station kein Erfolg. Alles aus neu an kein Erfolg. Dann kam mein Kollege auf die Idee mal alle stecker abzuziehen und der Reihe nach wieder aufzustecken. -> Fehler weg. Bei der guten S..mens "völlige Ratlosigkeit"
    Ein toller Fehler, hat uns 1 Tag Stillstand beschert.
    Zitieren Zitieren BusAnalyse Software  

  6. #6
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.620
    Danke
    777
    Erhielt 647 Danke für 493 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von mitchih Beitrag anzeigen
    Hallo,
    Dann kam mein Kollege auf die Idee mal alle stecker abzuziehen und der Reihe nach wieder aufzustecken. -> Fehler weg. Bei der guten S..mens "völlige Ratlosigkeit"
    Ein toller Fehler, hat uns 1 Tag Stillstand beschert.
    Sowas Aehnliches hatte ich auch mal. 4 ET200S Stationen eine (am Bus ganz am Schluss) mit SF und Busfehler.

    Stromlos machen hatte keine Wirkung. Dann wollte ich ausprobieren ob vielleicht das Buskabel defekt ist und hab die Station mit der zweitletzen getauscht. Bingo kein Busfehler mehr kein Systemfehler mehr lief alles einwandfrei.
    nach zwei Tagen kam der genau gleiche Fehler wieder diesmal war es die zweitletzte Station Busfehler und Systemfehler.
    Austausch der Station löste Problem für Immer.

    mfG René

Ähnliche Themen

  1. Busfehler, CP342-5
    Von bastler im Forum Feldbusse
    Antworten: 15
    Letzter Beitrag: 06.10.2008, 09:14
  2. Busfehler
    Von Tommy1981 im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 23.09.2008, 09:48
  3. Busfehler
    Von tomk im Forum Feldbusse
    Antworten: 9
    Letzter Beitrag: 06.04.2008, 19:02
  4. Busfehler
    Von sushi7776 im Forum Feldbusse
    Antworten: 13
    Letzter Beitrag: 04.10.2006, 16:47
  5. Busfehler
    Von Outrider im Forum Feldbusse
    Antworten: 6
    Letzter Beitrag: 08.10.2004, 08:56

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •