Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: UDP Verbindung kommt nicht zustande

  1. #1
    Registriert seit
    29.05.2007
    Beiträge
    15
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,

    folgendes Problem beschäftigt mich:

    Ich möchte eine Verbindung zwischen einer SPS (CPU 315-2DP mit CP 343-1 IT) und einem normalen PC über Ethernet herstellen. Ich habe es zuerst mit Hilfe von TCP/IP Protokoll probiert, was auch einwandfrei funktioniert hat. Dabei habe ich die Daten mit AG_SEND verschickt. Allerdings waren die Ergebnisse bezüglich der Übertragungsgeschwindigkeit nicht zufriedenstellend. Deswegen möchte ich jetzt die Verbindung mit UDP aufbauen. Das Problem liegt darin, dass es keine Verbindung zustande kommt. In der Verbindungsdiagnose wird als Status folgendes angezeigt: „Aktiver Verbindungsaufbau läuft“ oder „Verbindung abgebaut“. Die Verbindung in der Diagnose wird als TCP Verbindung bezeichnet, obwohl ich eine UDP Verbindung eingerichtet habe.

    Folgendes wollte ich nun fragen:

    Ist in der Verbindungsdiagnose TCP ein Sammelbegriff für TCP/IP, Iso on TCP und UDP Verbindungen oder wurde die Verbindungsart bei der Umstellung von TCP auf UDP nicht aktualisiert?

    Beim Verbindungseinrichten ist mir aufgefallen, dass bei TCP ein aktiver Verbindungsaufbau vorhanden ist, bei UDP dagegen nicht. Ist er bei UDP nicht notwendig, da es sich um einen verbindungslosen Protokoll handelt oder muss man die Verbindung manuell aufbauen?

    Wo könnte der Fehler denn sonst liegen?
    Zitieren Zitieren UDP Verbindung kommt nicht zustande  

  2. #2
    Registriert seit
    04.06.2007
    Ort
    Mal hier und mal dort
    Beiträge
    116
    Danke
    13
    Erhielt 5 Danke für 4 Beiträge

    Standard

    Ich glaube du müsstest dir deine Frage schon selber beantwortet haben...
    UDP ist verbindungslos, dh die Daten werden nur gesendet, eine Rückmeldung ob die Verbindung besteht, die Daten alle und richtig empfangen wurden gibts es hier nicht.
    siehe auch wiki: http://de.wikipedia.org/wiki/User_Datagram_Protocol

    Achja und wenn du die Daten sicher archivieren willst oä, würde ich dir extrem von UDP abraten
    Geändert von SPSTorsten (24.07.2007 um 16:21 Uhr)

  3. #3
    quant81 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    29.05.2007
    Beiträge
    15
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Leute,

    ich habe mein Problem selbst gelöst. Und zwar bin ich davon ausgegangen, dass beim Urlöschen und neuem Laden nicht nur das Programm selbst, sondern auch die Hardwarekonfiguration geladen wird. Das trifft nicht auf die Netzwerkprojektierung zu,denn diese muss getrennt in die SPS geladen werden. Deswegen hat meine Verbindung nicht funktioniert.

    @SPSTorsten

    Beim TCP handelt es sich wirklich um ein gesichertes Protokoll. Dadurch dauert die Übertragung einer Nachricht bestenfalls genau zwei Zyklen (1. Zyklus: Senden der Nachricht, 2. Zyklus: Empfangen der Nachricht). Ich bin jedoch an einer echtzeitfähigen Datenübertragung interessiert, d. h. die Daten müssen nach jedem Zyklus gesendet werden. Deswegen kommt für mich TCP nur bedingt in Frage.

    Außerdem treten Telegrammverluste in einem Netzwerk nur durch das CSMA/CA Verfahren auf. Verwendet man jedoch Punkt-zu-Punkt Verbindungen, so wie in meinem Fall, dann ist ein Telegrammverlust praktisch unmögich.
    Zitieren Zitieren Problemlösung  

  4. #4
    Registriert seit
    04.06.2007
    Ort
    Mal hier und mal dort
    Beiträge
    116
    Danke
    13
    Erhielt 5 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    1.CSMA/CD (CA wird bei Funknetzen oder zB CANbus verwendet und CD bei Ethernet)arbeitet auf einer tieferen Ebene als TCP und UDP()siehe auch http://de.wikipedia.org/wiki/OSI-Modell ) und erkennt ob zwei Stationen gleichzeitig senden und bricht im Bedarfsfall die Sendung ab.
    2.Ethernet ist genaugenommen auch nicht echtzeitfähig aber bei 100Mbit und zwei Teilnehmern kann man das so behandeln.
    3.Telegrammverluste treten auch auf wenn zB Störungen von aussen ins Kabel induziert werden, je nach Anwendung, Entfernung und Umgebung wäre ich daher vorsichtig mit UDP.

    Ausserdem bin ich der Meinung das der Zyklus solange wartet bis die Kommunikation abgeschlossen ist. (Bei der Sache bin ich mir aber grad unsicher, dass hab ich neulich irgendwo in einer Herstellbeschreibung gelesen und ich weiss nicht welcher das war)

Ähnliche Themen

  1. ET200S kommt nicht online
    Von Wiggi0606 im Forum Feldbusse
    Antworten: 4
    Letzter Beitrag: 28.08.2011, 09:36
  2. Profibusausgang kommt nicht durch
    Von Bär1971 im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 22.05.2011, 17:02
  3. Nürnberg Safety kommt, wir können es nicht lassen
    Von Safety im Forum Werbung und Produktneuheiten
    Antworten: 7
    Letzter Beitrag: 01.03.2011, 07:57
  4. WinSPS-S7+Ausgang kommt nicht
    Von funbiker660 im Forum Sonstige Steuerungen
    Antworten: 2
    Letzter Beitrag: 18.04.2010, 08:23
  5. Druckluftregler kommt nicht auf den Solldruck
    Von da_kine im Forum Elektronik
    Antworten: 9
    Letzter Beitrag: 07.01.2009, 08:09

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •