Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 4 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 32

Thema: Hilfe bei s5, EPROM nervt

  1. #1
    Registriert seit
    02.11.2006
    Beiträge
    496
    Danke
    217
    Erhielt 25 Danke für 6 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe folgendes Problem:

    Ich möchte an einer bestehenden Anlage ein paar kleine Änderungen
    im s5-Prog vornehmen.

    Ich kann die Änderungen nicht online bearbeiten (editieren angewählt), obwohl mir der FB bzw. PB online angezeigt wird, ich kann die Bausteine
    nicht übertragen.
    Jedes Mal kommt die Meldung: " existiert bereits auf dem EPROM" und die
    Aktion wird abgebrochen.
    Selbst, wenn ich den EPROM abstecke, kommt dieser Quatsch.

    Ich will das Prog ändern, das EPROM in der Werkstatt in Ruhe löschen, neu
    schießen und dann (bei ausgeschaltetem Schaltschrank) wieder in das AG
    steckseln.
    Was mache ich verkehrt ???
    Zitieren Zitieren Hilfe bei s5, EPROM nervt  

  2. #2
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    einen S5- Eprom kannst Du nicht im AG ändern!
    da musst Du zuerst einen RAM reinstecken (sofern der CPU Speicher nicht reicht) dein Programm umschreiben und erproben, dann wenn alles funktioniert mit der PG den EPROM (nach dessen Löschung mit UV-Lampe) schiessen und wieder reinstecken.

  3. #3
    Registriert seit
    20.12.2006
    Beiträge
    275
    Danke
    20
    Erhielt 29 Danke für 27 Beiträge

    Standard

    Das liegt an der Bausteinkennung im Vorkopf der Bausteine.
    Ich würde persönlich bei der SPS nur mit der Pufferbatterie arbeiten.

    Schau mal hier: es trifft die Sache zwar nicht 100 prozentig Beitrags-ID:142320

    Hier habe ich noch eine Erklärung zum Bausteinvorkopf im Anhang.

    MFG

    Bitverbieger
    Angehängte Dateien Angehängte Dateien

  4. #4
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    vielleicht check ich es ja nicht aber zu

    "Ich kann die Änderungen nicht online bearbeiten (editieren angewählt), obwohl mir der FB bzw. PB online angezeigt wird, ich kann die Bausteine
    nicht übertragen."

    kann man nur sagen: Ja, das ist so!
    Was hat das mit der Bausteinkennung zu tun?

  5. #5
    Registriert seit
    30.08.2006
    Beiträge
    11
    Danke
    4
    Erhielt 4 Danke für 3 Beiträge

    Standard

    Zitat Zitat von borromeus Beitrag anzeigen
    vielleicht check ich es ja nicht aber zu

    "Ich kann die Änderungen nicht online bearbeiten (editieren angewählt), obwohl mir der FB bzw. PB online angezeigt wird, ich kann die Bausteine
    nicht übertragen."

    kann man nur sagen: Ja, das ist so!
    Was hat das mit der Bausteinkennung zu tun?
    Wo sich das Programm befindet hängt von der CPU ab.
    1) Es gibt CPU's die kopieren den EPROM Inhalt im Anlauf in den internen Ram der CPU. Die Bausteine aus dem EPROM haben aber die Kennung 'Gültig im EPROM' sind damit sozusagen schreibgeschütz und lassen sich nicht ändern. Mit einem Hilfs FB ich meine FB170 von Siemens wird diese Kennung in 'gültig im RAM' geändert. Nun können auch Bausteine im AG geändert werden. Aber Achtung nach Netzausfall ohne Batterie lädt die SPS aber wieder das Programm aus dem EPROM, änderungen, und Parameter sind wieder die Ursprünglichen.

    2) CPU besitzt sehr wenig Ram und Programm bleibt weitgehend auf EPROM und läuft im EPROM. Es läßt sich dann nichts nachträglich ändern. Man kann aber natürlich mit E DB, DB's im Ram einrichten.

  6. #6
    Registriert seit
    27.11.2006
    Ort
    Ostschweiz
    Beiträge
    528
    Danke
    43
    Erhielt 86 Danke für 77 Beiträge

    Standard

    Zitat Zitat von borromeus Beitrag anzeigen
    einen S5- Eprom kannst Du nicht im AG ändern!
    ...Selbst, wenn ich den EPROM abstecke, kommt dieser Quatsch...
    kann sein, dass du versucht, CPU-interne Bausteine zu übertragen? (z.B. FB24x und so...)

    o.s.t.

  7. #7
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Wichtig wäre mal an welcher Steuerung du hängst!!
    Sag mal Typ und CPU
    dann kann man es besser spezifizieren.

    Was genau willst du ändern pb,ob,fb,sb,db,dx,fx????

    So wie du den Fehler beschreibst denke ich du hängst an einer 135U mit CPU 928!!!!

    Dann brachst du ein Ram da diese CPU nur ein DB-Ram hat!!! Dort kann man die DB`s ablegen aber halt nur db`s
    Zitieren Zitieren SPS Typ CPU Typ!!!  

  8. #8
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Zitat Zitat von mitchih Beitrag anzeigen
    Wichtig wäre mal an welcher Steuerung du hängst!!
    Sag mal Typ und CPU
    dann kann man es besser spezifizieren.

    Was genau willst du ändern pb,ob,fb,sb,db,dx,fx????

    So wie du den Fehler beschreibst denke ich du hängst an einer 135U mit CPU 928!!!!

    Dann brachst du ein Ram da diese CPU nur ein DB-Ram hat!!! Dort kann man die DB`s ablegen aber halt nur db`s
    Das stimmt so nicht ganz:
    928er hat soweit ich mich erinnere- da gibt eine breite und eine schmale- die schmale ist die neuere serwohl einen internen RAM.
    bei der schmalen 928er waren es glaub ich 48kB Daten- und 48kB Programm- Speicher

    Aber was mich mehr interessieren würde: woran erkennst Du hier das AG (100,115,135,155) UND die CPU?
    Wäre froh zu verstehen wie Du das siehst... mega_ohm hat ja nicht viel von Typen geschrieben.

  9. #9
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Zitat Zitat von borromeus Beitrag anzeigen
    Das stimmt so nicht ganz:
    928er hat soweit ich mich erinnere- da gibt eine breite und eine schmale- die schmale ist die neuere serwohl einen internen RAM.
    bei der schmalen 928er waren es glaub ich 48kB Daten- und 48kB Programm- Speicher

    Aber was mich mehr interessieren würde: woran erkennst Du hier das AG (100,115,135,155) UND die CPU?
    Wäre froh zu verstehen wie Du das siehst... mega_ohm hat ja nicht viel von Typen geschrieben.

    Richtig ich vergass: Es gibt ja die alte 928 A/B breiet bauform da braucht man immer ein Ram oder Eprom die neue CPU "schmale Bauform" der 928 A/B hat ein internes Ram dort passen auch nur noch Memory Cards!!

    Also das mit den Typen habe ich aus meine Wissen mal so "erahnt"

    Soweit ich weiß arbeiten alle cpù`s der 100U und 115U auch ohne RAM oder Eprom!! (oder ich habe noch keine gesehen)

    Diese Problematik kenne ich nur von der 135U
    Mit der 155U hatte ich erst 1x zu tun und die hatte auch eingebauten Speicher (war das auch immer so?) von daher habe ich auf diese Konstellation getippt!! Oder ich kann hellsehen

  10. #10
    mega_ohm ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.11.2006
    Beiträge
    496
    Danke
    217
    Erhielt 25 Danke für 6 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von borromeus Beitrag anzeigen
    einen S5- Eprom kannst Du nicht im AG ändern!
    da musst Du zuerst einen RAM reinstecken (sofern der CPU Speicher nicht reicht) dein Programm umschreiben und erproben, dann wenn alles funktioniert mit der PG den EPROM (nach dessen Löschung mit UV-Lampe) schiessen und wieder reinstecken.
    Das man in s5 einen EPROM nicht einfach so mit dem PG beschreiben (verschiedene FB od. PB überschreiben) kann, ist mir bekannt. Der Plan
    war ja auch, das EPROM für den E-Fall so zu belassen, wie es ist. Ich wollte das Prog nur im RAM ändern. Die Probleme dabei, wie schon beschrieben.

Ähnliche Themen

  1. Studium nervt...
    Von stift im Forum Stammtisch
    Antworten: 22
    Letzter Beitrag: 22.09.2011, 19:17
  2. fun zum samstag: wer nervt mehr?
    Von vierlagig im Forum Stammtisch
    Antworten: 29
    Letzter Beitrag: 24.09.2008, 21:48
  3. oscat nervt mich...
    Von Markus im Forum Stammtisch
    Antworten: 12
    Letzter Beitrag: 27.02.2007, 01:29

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •