Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 23 von 23

Thema: Probleme mit DBs in SCL

  1. #21
    Registriert seit
    16.12.2004
    Ort
    Schleswig-Holstein
    Beiträge
    400
    Danke
    21
    Erhielt 23 Danke für 20 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    bevor der erste string anfängt 4 Bytes sind. DB40.DBB0 = 19
    DB40.DBB1 = 00
    Was heißt "bevor der erste String anfängt"? Bevor die ersten Daten empfangen sind?

    Was steht in DB40.DBB1 (und DBB2 & 3) nachdem ein STRING empfangen worden ist?

    Wenn in DBB1 immer noch "0" drin ist, dann wird wohl nichts klappen. Wenn dies so ist gibt's die Frage warum. Wie werden die Daten übertragen?

    Hab' gerade geguckt, CP340 kenne ich leider nicht (nie benutzt). Kann es sein, dass die Daten nicht Siemens konform übertragen werden, z.B. ohne die Längendaten?
    Geändert von RMA (08.08.2007 um 13:12 Uhr)

  2. Folgender Benutzer sagt Danke zu RMA für den nützlichen Beitrag:

    chrissi (09.08.2007)

  3. #22
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.710
    Danke
    398
    Erhielt 2.397 Danke für 1.997 Beiträge

    Standard

    Hallo Chrissi,
    da haben wir es doch schon.
    Im Byte 0 steht die Gesamtlänge des deklarierten String (Hex19 = 25). Im Byte 1 deine echte Länge (0). Das du dann überhaupt etwas von dem einen in den anderen String kopiert kriegst ist m.E. ein Bug von Siemens.

    Ich sehe gerade - RMA hat das gleiche auch schon geschrieben ..l.

  4. #23
    chrissi ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.08.2007
    Beiträge
    8
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Vielen Dank für eure Hilfe!
    Jetzt funktioniert es

Ähnliche Themen

  1. Bus Probleme
    Von KR-TKD im Forum Feldbusse
    Antworten: 7
    Letzter Beitrag: 15.06.2011, 16:37
  2. CPU 315 F 2PN/DP DI Probleme
    Von Joke im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 12.05.2009, 21:10
  3. Probleme über Probleme!
    Von tom_2802 im Forum Simatic
    Antworten: 25
    Letzter Beitrag: 12.06.2008, 22:19
  4. Probleme mit ALM
    Von Larry Laffer im Forum PC- und Netzwerktechnik
    Antworten: 4
    Letzter Beitrag: 08.03.2008, 18:13
  5. Probleme mit OPC
    Von ILW im Forum Hochsprachen - OPC
    Antworten: 1
    Letzter Beitrag: 01.11.2007, 12:37

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •