Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 17 von 17

Thema: s5 an s7 system anbinden

  1. #11
    Registriert seit
    20.12.2006
    Beiträge
    275
    Danke
    20
    Erhielt 29 Danke für 27 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hier ein Projekt von mir wie ich es gelöst habe.
    Ich hoffe es hilft dir weiter.
    Angehängte Dateien Angehängte Dateien
    MFG
    Bitverbieger

    Gelingt Dir etwas auf Anhieb, so lass Dir Deine Verblüffung nicht anmerken.

  2. #12
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Beitrag

    Hallo,

    Zitat Zitat von dtsclipper
    Ich glaube, den P-Bereich kann man nur wortweise ansprechen, da er nicht im PAE abgebildet wird.

    An den Befehl T PY... kann ich mich nicht erinnern,
    Um die Erinnerung dann mal aufzufrischen : T PY ... ist genau der Befehl, um byteweise in den Peripheriebereich zu schreiben.

    Gruß

    Question_mark
    ''Ich habe wirklich keine Vorurteile.
    Meine Meinung ist nur die Summe der Erfahrungen" ... (Question_mark)
    Zitieren Zitieren Zur Erinnerung  

  3. #13
    Stefan123 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    18.08.2007
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    @bitverbieger: Ich habe mir diese Projektierung mal angeschaut, und mir ist aufgefallen, dass du dort immer andere Adressen eingegeben hast. Ausserdem hast du die Slave Adressen in den Q Bereich gelegt. Alles das habe ich auch probiert, klappt aber nicht. Ich kann nach wie vor die Ausgänge nicht steuern. Mir würde es helfen, wenn du mal postest, wie du die Eingänge / Ausgänge im S5 Programm angesprochen hast.

    Der Befehl "T PYXXX" verursacht bei mir einen CPU stop. (Adressierungsfehler)
    Ausserdem, sobald ich meinen Test - FB30 (in dem zur Zeit nur "L PY 80 , T MB 150" steht --> das klappt ja) vom OB1 aus aufrufe, leuchtet an der CPU die Diode QVZ (Quittierungverzug).

    Mit welchen Befehlen setzt man einen Ausgang, der dann in der S7 als Eingang ankommt?

    Mfg,
    Stefan

  4. #14
    Registriert seit
    20.12.2006
    Beiträge
    275
    Danke
    20
    Erhielt 29 Danke für 27 Beiträge

    Standard

    Als, ich würde erstmal den E-Bereich von 0 bis 127 meiden.
    Der ist eigentlich für alle Digitalen Ein-und Ausgänge gedacht.
    Der Bereich von 128 bis 255 ist der sogenannte P-Bereich.
    Dort werden Analoge Ein-und Ausgänge, falls vorhanden, adressiert.
    Entweder dort im P-Bereich oder, wie ich es dort im Beispiel gemacht habe,
    im Q-Bereich sucht man sich einen freien Bereich für die Datenübertagung.
    Denke daran, der Q-Bereich sowie der P-Bereich dürfen sich nicht Adressmäßig
    überschneiden Beispiel: PW128 bis pW142 = Analogkarte,QW128 bis QW 142.
    Frag nicht nicht nach dem Sinn, ist aber so. (Darüber gibt es hier auch einen Beitrag).
    Auf der S5 Seite schreibe ich dann z.B.

    L MW 198
    T QW 158
    = Datenübertragung S5 --> S7

    L QW 198
    T MW 166
    = Datenübertragung S7 --> S5

    Wenn du so vorgehst, müsste es funktionieren.
    Sag mal Bescheid über das Ergebnis.
    MFG
    Bitverbieger

    Gelingt Dir etwas auf Anhieb, so lass Dir Deine Verblüffung nicht anmerken.

  5. #15
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Beitrag

    Hallo,

    Zitat Zitat von stefan123
    (in dem zur Zeit nur "L PY 80 , T MB 150" steht --> das klappt ja) vom OB1 aus aufrufe, leuchtet an der CPU die Diode QVZ (Quittierungverzug).
    Dann wird wohl auch keine Peripherie(eingangs)baugruppe mit der Adresse 80 im Gerät vorhanden sein, oder ???

    Gruß

    Question_mark
    ''Ich habe wirklich keine Vorurteile.
    Meine Meinung ist nur die Summe der Erfahrungen" ... (Question_mark)
    Zitieren Zitieren ???  

  6. #16
    Stefan123 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    18.08.2007
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Jo, es klappt!!! Also die Version, die Bitverbieger geschildert hat.
    Danke, danke, danke an alle die mir weitergeholfen haben!
    Mfg, Stefan

  7. #17
    Registriert seit
    20.12.2006
    Beiträge
    275
    Danke
    20
    Erhielt 29 Danke für 27 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Das freund mich auch, dass ich helfen konnte
    MFG
    Bitverbieger

    Gelingt Dir etwas auf Anhieb, so lass Dir Deine Verblüffung nicht anmerken.

Ähnliche Themen

  1. S7 an S5 anbinden
    Von Katrin1982 im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 03.12.2010, 15:53
  2. IEC 60870-5-101 an S7-300 Anbinden?
    Von eYe im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 02.03.2010, 10:35
  3. Umrichter an SPS anbinden
    Von Eddy001 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 13.12.2007, 15:15
  4. Mircomaster an S7-300 anbinden
    Von DJFelix im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 30.07.2007, 17:56
  5. PDA an SPS anbinden
    Von maccap im Forum Feldbusse
    Antworten: 18
    Letzter Beitrag: 01.10.2005, 11:02

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •