Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Referenzdaten können nicht angelegt werden

  1. #1
    Registriert seit
    23.10.2006
    Ort
    Bielefeld-Sennestadt
    Beiträge
    67
    Danke
    22
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Abend liebe Gemeinde!
    Habe folgendes Problem. Bei einer bestehenden Anlage(zur Zeit noch in der Inbetriebnahme) verwende ich zwei 317-2DP. Habe 2 OP 177B drin, 2 PC auf denen eine WinCC flex Runtime läuft. Sind zwei Anlagen, die allerdings auch im Verbund laufen können sollen.Bis heute Mittag war auch noch alles in Ordnung. Aber dann kam der Hammer. Hatte in einem Baustein etwas geändert und wollte ihn speichern. Da kam folgende Meldung:

    Speichern(34:152)
    Die Referenzdaten zum aktuellen Baustein konnten nicht angelegt werden.

    Habe dann versucht das Projekt zu reorganisieren. Dieses brachte kein Erfolg.
    Dann wollte ich die Referenzdaten neu generieren. Folgende Meldung:

    Anzeige (257:26))
    Interner Fehler: Die Verbindung zwischen zwei Objekten konnte nicht hergestellt werden.


    Wat ist das für ein Mist? Was ist da passiert?

    Hatte dieses Problem schon einmal jemand?
    Wäre nett wenn mir da einer helfen könnte.
    „Nicht mir Erfindungen, sondern mit Verbesserungen macht man Vermögen.”
    Zitieren Zitieren Referenzdaten können nicht angelegt werden  

  2. #2
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.697 Danke für 1.949 Beiträge

    Standard

    Versuch mal "Speichern unter" mit Reorganisieren. Das kann man in dem Fenster "Speichern unter" anhaken.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  3. Folgender Benutzer sagt Danke zu Ralle für den nützlichen Beitrag:

    Neuling74 (06.09.2007)

  4. #3
    Registriert seit
    31.07.2004
    Beiträge
    243
    Danke
    16
    Erhielt 13 Danke für 13 Beiträge

    Standard

    habe dazu kürzlich etwas im Siemens Support gelesen,
    vielleciht hilft es dir

    http://support.automation.siemens.co...ad=treecontent
    ---------------------------------------------
    Wo wir sind ist Vorn-und wenn wir Hinten sind-ist Hinten Vorn !

  5. Folgender Benutzer sagt Danke zu edi für den nützlichen Beitrag:

    Neuling74 (06.09.2007)

  6. #4
    Registriert seit
    20.11.2004
    Ort
    Linz, OÖ
    Beiträge
    1.365
    Danke
    96
    Erhielt 177 Danke für 133 Beiträge

    Standard

    Ich kenne dieses Problem nur dann, wenn das S7-Projekt beispielsweise auf einem Netzlaufwerk oder auf einer externen Festplatte liegt. Ist ein Baustein geöffnet und noch nicht gespeichert, und gleichzeitig wird die Verbindung zum Netzlaufwerk getrennt, werden teilweise die Referenzdaten zerschossen. Sie lassen sich dann auch nicht mehr neu generieren, "Speichern unter mit Reorganisation" hilft hier auch nicht.

    Mit einigem Experimentieren habe ich aber einen Weg gefunden:
    Vorweg: mach zuerst eine Sicherheitskopie des Projekts
    1. S7-Programm markieren (also den übergeorneten Ordner von "Bausteine", "Quellen" und Symbole) --> rechte Maustaste --> kopieren (alternativ: ctrl-c)
    2. im hauptordner des Projektes das kopierte Programm einfügen. Bei dem nun folgenden Kopiervorgang wird das Komplette Programm mit Quellen und Symbolik kopiert - die Referenzdaten werden NICHT mitkopiert.
    3. Wählt man bei dem kopierten Programm nun "Extras --> Referenzdaten --> anzeigen", bietet der Simatic Manager die Option "aktualisieren" gar nicht an, sondern erlaubt nur "neu generieren" (kann übrigens ein paar Minuten dauern)
    4. War dieser Generier-Vorgang erfolgreich, muss man das ganze natürlich umgekehrt auch wieder machen, nämlich:
    5. Das S7-Programm, welches als Unterordner an der CPU hängt (und dessen referenzdaten zerschossen wurden) muss komplett gelöscht werden.
    6. Das zuvor kopierte S7-Programm aus dem Hauptordner des Projekts wieder als unterordner der CPU kopieren
    7. Referenzdaten erneut generieren.

    Bei uns arbeiten häufig mehrere Leute auf einem S7-Projekt, welches auf der Festplatte eines dieser Leute, auf einem Server oder auf einem NAS liegt. Da kam es schon mal vor, dass jemand ein Netzwerkkabel aussteckt, während er einen Baustein offen hat - dabei trat i.d.R. meist dieses Problem auf.
    Mit der oben Beschriebenen Methode haben wir jedes dieser Projekte wieder in die Gänge gekriegt.

    mfg
    Maxl
    Bin aufgrund §2 der "Rechte des Betreibers" der Forum-Regeln nicht mehr aktiv, da nicht nicht akzeptiere, dass Informationen und Erkenntnisse ohne Quellangabe weitergegeben werden sollen. Jedem steht frei, auf die gleichen Erkenntnisse durch Eigenversuche zu kommen, vor allem Buchautoren.

  7. Folgende 3 Benutzer sagen Danke zu Maxl für den nützlichen Beitrag:

    Baumgartner (11.02.2014),fr13th (13.03.2008),Neuling74 (06.09.2007)

  8. #5
    Registriert seit
    23.10.2006
    Ort
    Bielefeld-Sennestadt
    Beiträge
    67
    Danke
    22
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Zitat Zitat von Ralle Beitrag anzeigen
    Versuch mal "Speichern unter" mit Reorganisieren. Das kann man in dem Fenster "Speichern unter" anhaken.
    Sorry das ich mich erst jetzt melde. Das habe ich probiert und es hat nicht funktioniert. Trotzdem Danke für deine schnelle Antwort.
    „Nicht mir Erfindungen, sondern mit Verbesserungen macht man Vermögen.”

  9. #6
    Registriert seit
    23.10.2006
    Ort
    Bielefeld-Sennestadt
    Beiträge
    67
    Danke
    22
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Zitat Zitat von edi Beitrag anzeigen
    habe dazu kürzlich etwas im Siemens Support gelesen,
    vielleciht hilft es dir

    http://support.automation.siemens.co...ad=treecontent
    Auch Dir ein Dankeschön für den Hinweis. Habe es zwar nicht probiert, weil ich so verfahren bin wie Maxl es beschrieben hat.
    „Nicht mir Erfindungen, sondern mit Verbesserungen macht man Vermögen.”

  10. #7
    Registriert seit
    23.10.2006
    Ort
    Bielefeld-Sennestadt
    Beiträge
    67
    Danke
    22
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Zitat Zitat von Maxl Beitrag anzeigen
    Ich kenne dieses Problem nur dann, wenn das S7-Projekt beispielsweise auf einem Netzlaufwerk oder auf einer externen Festplatte liegt. Ist ein Baustein geöffnet und noch nicht gespeichert, und gleichzeitig wird die Verbindung zum Netzlaufwerk getrennt, werden teilweise die Referenzdaten zerschossen. Sie lassen sich dann auch nicht mehr neu generieren, "Speichern unter mit Reorganisation" hilft hier auch nicht.

    Mit einigem Experimentieren habe ich aber einen Weg gefunden:
    Vorweg: mach zuerst eine Sicherheitskopie des Projekts
    1. S7-Programm markieren (also den übergeorneten Ordner von "Bausteine", "Quellen" und Symbole) --> rechte Maustaste --> kopieren (alternativ: ctrl-c)
    2. im hauptordner des Projektes das kopierte Programm einfügen. Bei dem nun folgenden Kopiervorgang wird das Komplette Programm mit Quellen und Symbolik kopiert - die Referenzdaten werden NICHT mitkopiert.
    3. Wählt man bei dem kopierten Programm nun "Extras --> Referenzdaten --> anzeigen", bietet der Simatic Manager die Option "aktualisieren" gar nicht an, sondern erlaubt nur "neu generieren" (kann übrigens ein paar Minuten dauern)
    4. War dieser Generier-Vorgang erfolgreich, muss man das ganze natürlich umgekehrt auch wieder machen, nämlich:
    5. Das S7-Programm, welches als Unterordner an der CPU hängt (und dessen referenzdaten zerschossen wurden) muss komplett gelöscht werden.
    6. Das zuvor kopierte S7-Programm aus dem Hauptordner des Projekts wieder als unterordner der CPU kopieren
    7. Referenzdaten erneut generieren.

    Bei uns arbeiten häufig mehrere Leute auf einem S7-Projekt, welches auf der Festplatte eines dieser Leute, auf einem Server oder auf einem NAS liegt. Da kam es schon mal vor, dass jemand ein Netzwerkkabel aussteckt, während er einen Baustein offen hat - dabei trat i.d.R. meist dieses Problem auf.
    Mit der oben Beschriebenen Methode haben wir jedes dieser Projekte wieder in die Gänge gekriegt.

    mfg
    Maxl
    Hallo Maxl!
    Danke für den Tipp. Habe es so probiert und es hat funktioniert. Vielen Dank. Das Problem war wahrscheinlich genau das wie Du es beschrieben hast. Funktionirt wenigstens alles wieder. Wir haben das Programm nämlich tatsächlich über Netzwerk(zwei Notebooks) geändet. Wahrscheinlich ist die Verbindung kurz abgerissen als wir Pause gemacht haben. Nochmals Dankeschön.
    „Nicht mir Erfindungen, sondern mit Verbesserungen macht man Vermögen.”

  11. #8
    Registriert seit
    21.11.2011
    Ort
    Basel Land
    Beiträge
    1
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Daumen hoch


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Der Rat steht zwar schon einige Zeit im Netz ist aber noch immer aktuell und hat bestens geholfen!
    Zitieren Zitieren Danke!  

Ähnliche Themen

  1. Antworten: 4
    Letzter Beitrag: 17.06.2013, 20:28
  2. SDB's können nicht übertragen werden
    Von blasterbock im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 04.10.2010, 14:51
  3. Antworten: 4
    Letzter Beitrag: 23.07.2010, 12:21
  4. Antworten: 8
    Letzter Beitrag: 18.12.2008, 12:39
  5. GRAPH: Quellen können nicht geöffnet werden
    Von derbenny im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 08.11.2007, 14:24

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •