Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Brauche Hilfe mit Libnodave

  1. #1
    Registriert seit
    09.08.2006
    Beiträge
    125
    Danke
    15
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Habe mir jetzt mal die Libnodave bibliothek runtergeladen, bekomme aber nichtmal eine Verbindung hin.

    Habe eine 315-2DP und einen CP343-Lean dran und habe in Net Pro eine ISO on TCP verbindung projektiert. Welche Partner ID muss ich ich projektieren ??


    Sollte jetzt schon was passieren wenn ich die testisotcp.exe starte?

    Sorry für die blöden fragen....
    Zitieren Zitieren Brauche Hilfe mit Libnodave  

  2. #2
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.263
    Danke
    537
    Erhielt 2.708 Danke für 1.957 Beiträge

    Standard

    Ich weiß ehrlich nicht, ob du überhaupt eine Verbindung anlegen mußt, deine CP sollte aber auf jeden Fall eine passende Adresse eingestellt bekommen. Bei libnodave ist auch ein Testprogramm für Windows (im Delphi-Ordner) dabei, damit kannst du ein wenig besser "spielen" bis die Verbindung zustande kommt.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  3. #3
    Snoopy123123 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.08.2006
    Beiträge
    125
    Danke
    15
    Erhielt 2 Danke für 2 Beiträge

    Standard

    mein CP hat die passende adresse !

    habe im Delphi ordner geschaut, aber auch die dortige .exe macht irgendwie nichts

    Habe noch nie was mit Libnodave gemacht. Habe den Visual C compiler drauf aber mir fehlt ein grundsätlicher ansatz wie ich Libnodave nutzen kann. Möchte damit gerne in eine SQL Datenbank schreiben.

  4. #4
    Registriert seit
    19.09.2005
    Ort
    Freudenstadt
    Beiträge
    811
    Danke
    64
    Erhielt 101 Danke für 64 Beiträge

    Standard

    Zitat Zitat von Ralle Beitrag anzeigen
    Ich weiß ehrlich nicht, ob du überhaupt eine Verbindung anlegen mußt ...
    Nee, Verbindung projektieren ist überflüssig, aber es müssen in der CPU noch freie Verbindungen zur Verfügung stehen.

    Zitat Zitat von Snoopy123123 Beitrag anzeigen
    habe im Delphi ordner geschaut, aber auch die dortige .exe macht irgendwie nichts
    Was "sagen" denn die testiso_tcp.exe und das Delphi-Programm ?

    Vor allem die test....exe-Programme liefern im Fehlerfall wichtige Infos, um die Ursache zu ermitteln. Stell hier doch einfach mal rein, was das Programm ausspuckt.


    Gruß Axel
    Man muß sparn wo mn knn!

  5. #5
    Snoopy123123 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.08.2006
    Beiträge
    125
    Danke
    15
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Ok jetzt bin ich ganz verwirrt. Ich hab zwar ein paar exe dateien da drinn aber keine Test.exe

    In meinem Delphi ordner gibts eine NoDaveDemo.exe. kann es sein das ich was falsches runtergeladen habe ? Kann mir mal jemand den richtigen download link senden ?

    Danke

  6. #6
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Ja genau,
    Nodavedemo ist das Testprogramm, mit den folgenden Einstellungen hab ich meine Verbindung probiert
    Angehängte Grafiken Angehängte Grafiken

  7. Folgender Benutzer sagt Danke zu jabba für den nützlichen Beitrag:

    Snoopy123123 (17.09.2007)

  8. #7
    Snoopy123123 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.08.2006
    Beiträge
    125
    Danke
    15
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Ja aber bei mir geht die nicht weil Libnodave.dll nicht gefunden wurde !!

    Sorry, weiss leider nicht wo ich da suchen soll.

  9. #8
    Registriert seit
    19.09.2005
    Ort
    Freudenstadt
    Beiträge
    811
    Danke
    64
    Erhielt 101 Danke für 64 Beiträge

    Standard

    Zitat Zitat von Snoopy123123 Beitrag anzeigen
    Ok jetzt bin ich ganz verwirrt.
    Das war nicht meine Absicht ...

    Zitat Zitat von Snoopy123123 Beitrag anzeigen
    Ich hab zwar ein paar exe dateien da drinn aber keine Test.exe
    Die gibt's nicht, das ist schon richtig so. mit test....exe meinte ich die testiso_txp.exe, testmpi.exe, usw.

    Zitat Zitat von Snoopy123123 Beitrag anzeigen
    In meinem Delphi ordner gibts eine NoDaveDemo.exe.
    Die ist für die Anwender gedacht, die mit der Kommandozeile nicht viel anfangen können, aber die Testprogramme von Zottel (die test....exe ) liefern mehr Infos, wenn es nicht funktrioniert.

    Zitat Zitat von Snoopy123123 Beitrag anzeigen
    kann es sein das ich was falsches runtergeladen habe ? Kann mir mal jemand den richtigen download link senden ?
    Wird schon richtig sein, aber auf SourceForge findest Du die immer aktuelle Version.

    Zitat Zitat von Snoopy123123 Beitrag anzeigen
    Ja aber bei mir geht die nicht weil Libnodave.dll nicht gefunden wurde !!
    Die libnodave.dll liegt im Unterverzeichnis "win" von libnodave, die mußt Du einfach in das gleiche Verzeichnis kopieren, in der auch die NoDaveDemo.exe liegt.


    Gruß Axel
    Man muß sparn wo mn knn!

  10. Folgender Benutzer sagt Danke zu afk für den nützlichen Beitrag:

    Snoopy123123 (17.09.2007)

  11. #9
    Snoopy123123 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.08.2006
    Beiträge
    125
    Danke
    15
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Ok mit der dll bekomme ich jetzt schonmal das programm geöffnet und der scheint sich auch mit der PLC verbunden zu haben. Aber bevor ich jetzt wieder was blödes frage werde ich mich noch mal ein bissjen plagen.

    Danke schon mal für die Hilfe !!!



    Zitat Zitat von afk Beitrag anzeigen
    Das war nicht meine Absicht ...


    Die gibt's nicht, das ist schon richtig so. mit test....exe meinte ich die testiso_txp.exe, testmpi.exe, usw.


    Die ist für die Anwender gedacht, die mit der Kommandozeile nicht viel anfangen können, aber die Testprogramme von Zottel (die test....exe ) liefern mehr Infos, wenn es nicht funktrioniert.


    Wird schon richtig sein, aber auf SourceForge findest Du die immer aktuelle Version.


    Die libnodave.dll liegt im Unterverzeichnis "win" von libnodave, die mußt Du einfach in das gleiche Verzeichnis kopieren, in der auch die NoDaveDemo.exe liegt.


    Gruß Axel

  12. #10
    Registriert seit
    14.12.2006
    Beiträge
    21
    Danke
    14
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    na, so ein rookie wie ich wird euch gerade noch gefehlt haben...

    meine Herausforderung beginnt schon nach dem download.*Linux Files. (tar.gz) wie bekomme ich WIN32 Files daraus, bzw. kann die jemand zur Verfügung stellen ?

    Allerbesten Dank schon mal vorab !
    Zitieren Zitieren oooops...  

Ähnliche Themen

  1. Antworten: 90
    Letzter Beitrag: 21.03.2010, 12:35
  2. Brauche hilfe
    Von Butsche im Forum Stammtisch
    Antworten: 1
    Letzter Beitrag: 26.11.2006, 18:01
  3. Brauche Hilfe OP5
    Von spsler im Forum HMI
    Antworten: 1
    Letzter Beitrag: 16.01.2006, 10:42
  4. bin neu, brauche hilfe
    Von Maddi0406 im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 15.09.2005, 08:26
  5. Brauche mal Hilfe OP 5
    Von Anonymous im Forum HMI
    Antworten: 8
    Letzter Beitrag: 20.02.2005, 11:47

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •