Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: Probleme mit DP/DP Koppler AugebStd2 (Verbindung unterbrochen)

  1. #1
    Registriert seit
    23.01.2006
    Beiträge
    75
    Danke
    17
    Erhielt 7 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    morgen,

    vorab der hinweis darauf, dass die ursache des problems gefunden wurde und ich nun versuche herauszufinden was eigentlich schiefgegangen ist.

    wer nicht alles lesen möchte, die kurzfassung:

    -kopplung auf anderen teilnehmer mittels DP/DP koppler (ich: S7-400, er: drei maschinen mit einer soft-sps TwinCAT)
    -bussgeschwinidigkeiten: ich: 187,5kbit/s, er: 19,2kbit/s
    -länge der daten 21byte IN / 25byte OUT
    -problem: busskoppler meldet sich willkürlich vom bus ab und nach 8-10s wiede an
    -lösung: seine geschwindigkeit anheben
    -FRAGE: WARUM TAT DER KOPPLER WAS ER TAT?


    long version :

    problembeschreibung:
    nach einer erweiterung der softwareschnittstelle von 5byte IN / 5byte OUT auf 21byte IN / 25byte OUT meldeten dies slaves (drei kopplungen zum selben maschinentyp) sich in willkürlichen abständen vom bus ab und waren nach 8-10sek wieder ok (die screens sind später entstanden... also zeitangabe 8-10s passt nicht).






    steuerung gekoppelter maschinentyp:
    die maschine arbeit mit einen panel-pc und hat eine soft-sps zu laufen (TwinCat).



    was die letzten tage so alles geschah :
    ursprünglich waren die maschinen in einen busstrang mit weiteren slaves. in diesem bussystem war alles mögliche, von et-stationen über panels bishin zu "nicht siemens" perepherie.
    anfangs tippten wir auf ein kabelproblem, da zum gleichen zeitpunkt der schnittstellenerweiterung noch eine andere maschine (s7-300) dazu kam (inkl. einige meter an kabel). Deshalb plazierten wir nachträglich ein repeater, was natürlich nichts brachte... anschließend versuchten wir das problem zu lösen, indem wir die zweite schnittstelle der 414-2DP nutzten, um so die drei "problemteilnehmer" unabhängig vom rest zu machen... aber auch erfolglos.
    damit konnten wir ein hardwareproblem ausschliessen und ich telefonierte mit den maschinenlieferanten, [k]der mir erzählte das er seinen bus auf 19,2kbit/s fährt (mein bus: 187,5)... darauf bat ich ihn die geschwindigkeit anzuheben[/k]... und siehe da, seit gestern kein busausfall mehr....

    frage:
    nun hängt das ganze ja offensichtlich mit der erweiterung der schnittstelle und der geschwindigkeit des buses zusammen. mir will nur nicht ganz einleuchten warum der koppler so reagiert... währe schön wenn jemand mal nen paar erklärende worte dazu abgeben könnte.
    Zitieren Zitieren Probleme mit DP/DP Koppler AugebStd2 (Verbindung unterbrochen)  

  2. #2
    Registriert seit
    05.10.2005
    Beiträge
    2.373
    Danke
    321
    Erhielt 296 Danke für 266 Beiträge

    Standard

    nur ne Vermutung: Hat der Langsame Bus den Koppler ausgebremst, das dieser die Daten nicht "fortschaffen" konnte?

    Man könnte dies testen, indem man ständig schnell Daten sendet und schaut, ob alle ankommen.


    Thomas

  3. #3
    Registriert seit
    23.01.2006
    Beiträge
    75
    Danke
    17
    Erhielt 7 Danke für 4 Beiträge

    Standard

    das würde ja heißen das irgendwo ein puffer übergelaufen wäre... dann ist es aber nicht die feine art die verbindung zu "kappen" und keine weitere diagnose auszugeben.

  4. #4
    Registriert seit
    27.11.2005
    Ort
    im Osten
    Beiträge
    1.183
    Danke
    141
    Erhielt 271 Danke für 248 Beiträge

    Standard

    Sowas ähnliches hatte ich auch vor Kurzem
    Buskoppler meldete beiden CPU´s (317-2F und 315F) für einige ms Baugruppe gestört. Sonst stand nix weiter an. Dies geschah mehrmals im Zeitraum von 2 Tagen

    Merkwürdigerweise wurde in dem Zeiraum nix an der Anlage geändert und nachdem am folgenden Tag die Produktion wieder startete und wir weitere Ursachenforschung betreiben wollten, passierte nix mehr ??????
    Das ist jetzt ca. 4 Wochen her

  5. #5
    Registriert seit
    23.01.2006
    Beiträge
    75
    Danke
    17
    Erhielt 7 Danke für 4 Beiträge

    Standard

    hm, möglichwerweise lag es am kabel bzw. steckern die durch umwelteinflüsse (wärme/kälte/feuchtigkeit) beeinflusst wurden/werden... man weiß ja nie.

    ich kann mir bei meinen problem vorstellen das das ganze irgendwie mit dieser soft-sps zusammenhängt.

  6. #6
    Registriert seit
    11.02.2007
    Beiträge
    90
    Danke
    32
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Hallo, ich habe bis jetzt wenig Erfahrung mit DP-Kopplern....

    Aber wenn der schnelle Bus die Daten schneller in den Stack (Zwischenspeicher) des DP-Koppler schreibt als der langsame Bus die wieder ausliest läuft der Stack irgendwann über weil der Speicherplatz des Stack begrenzt ist.

    Wenn du den zweiten Bus jetzt schneller gemacht hast liest er die Daten schnell genug aus, so das der Stack nicht mehr überläuft.

    Ganz sicher bin ich mir nicht aber ich glaube das könnte das Problem gewesen sein. Wenn es jemand besser weiß würde ich mich über eine Bestättigung meine These freuen.

    nfg
    Zitieren Zitieren Stack  

  7. #7
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Aus dem Siemens Handbuch über DP/DP-Koppler
    Beitrags ID 1179382


    Desweiteren kann in jedem Netz mit einer anderen Baudrate gearbeitet werden. Netz 1 füllt den Ausgangspuffer langsamer, als er von Netz 2 gelesen wird. Netz 2 liest somit mehrmals die identischen Daten hintereinander. Umgekehrt ist es in der Richtung von Netz 2 nach Netz 1. Es wird der Ausgangspuffer mehrmals überschrieben, ehe er vom Netz 1 gelesen wird. Es stehen somit immer die zuletzt geschriebenen Daten zur Verfügung.
    Auf Seite 1-2 im Handbuch gibt es auch eine Abbildung, wo eine Seite vom Bus mit 1,5 MBaud und die andere mit 12 MBaud projektiert ist.
    Daher sollte es nicht an den unterschiedlichen Baudraten liegen
    Geändert von marlob (21.09.2007 um 08:08 Uhr)

  8. Folgender Benutzer sagt Danke zu marlob für den nützlichen Beitrag:

    elektro_mensch (21.09.2007)

  9. #8
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Du könntest den DP/DP-Koppler auch noch auf Ausgabestand 3 hochrüsten.

  10. #9
    Registriert seit
    19.07.2007
    Beiträge
    78
    Danke
    14
    Erhielt 2 Danke für 1 Beitrag

    Standard

    Hallo,

    ich habe im Moment haar genau das gleiche Problem wie Lockenfrosch es ganz oben beschrieben hat.
    Kann mir jemand dazu helfen ?
    Ich hab keine Ahnung mehr wo ich noch suchen soll...

    Danke und Grüße
    Carsten

  11. #10
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    @carstem
    Also fangen wir mal an:
    a) Diagnosepuffer?
    b) Wenn du das gleiche Problem hast, hilft dann auch die gleiche Lösung - siehe Post vom TE.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

Ähnliche Themen

  1. Probleme mit DP-DP Koppler
    Von Trajan im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 15.09.2011, 15:13
  2. Probleme mit PN/PN-Koppler
    Von D E N Y S im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 19.04.2011, 20:00
  3. Probleme mit DP/DP Koppler
    Von cpg im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 07.01.2011, 16:08
  4. Probleme mit DP/DP Koppler
    Von smartie im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 24.03.2010, 11:22
  5. DP/PA Koppler. Keine Verbindung
    Von dpd80 im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 16.02.2006, 15:57

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •