Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: String aus DB wird nur gekürzt in Protool dargestellt

  1. #1
    Registriert seit
    27.06.2005
    Beiträge
    51
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    hab da ein Problemchen mit Protool: und zwar wird mir ein String mit 26 Buchstaben, der in einem DB gespeichert ist, nur bis zum 18. Buchstaben in einem Protool-Augabefeld angezeigt. Die Protool-Variable ist direkt mit dem DB-String symbolisch verknüpft. Das Ausgabefeld in Protool ist auf "String" eingestellt und die Feldlänge steht auf 26 ....
    Sollte ich vielleicht mal Pause machen? Bin für jeden Hinweis zu haben!
    Volker
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren String aus DB wird nur gekürzt in Protool dargestellt  

  2. #2
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Ist das Ausgabefeld auch lang genug. Ich meine nicht die Einstellung in den Parametern sondern in deinem Bild.
    Ziehe das doch mal länger und gucke ob du immer noch nur 18 Zeichen siehst

  3. #3
    Registriert seit
    30.03.2005
    Beiträge
    2.096
    Danke
    0
    Erhielt 673 Danke für 541 Beiträge

    Standard

    Ist der String im DB richtig initialisiert?

    String

    Byte 0 = Maximale Länge Sting
    Byte 1 = Aktuelle Länge String
    Byte 2 = 1. Zeichen String
    Byte 3 = 2. Zeichen Sting
    ...

    Wenn Du in ProTool 26 Zeichen darstellen willst, dann muss also in Byte 0 und Byte 1 des Strings jeweils der Wert 26 stehen.

    Gruß Kai

  4. #4
    Registriert seit
    30.03.2005
    Beiträge
    2.096
    Danke
    0
    Erhielt 673 Danke für 541 Beiträge

    Standard

    Zur Initialisierung des Strings siehe auch hier:

    http://www.sps-forum.de/showthread.php?t=14808

    Gruß Kai

  5. #5
    Registriert seit
    27.06.2005
    Beiträge
    51
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Jetzt gehts, aber keine Ahnung warum. Der Fehler lässt sich nicht reproduzieren. Mgw. mag es PLCSIM nicht, wenn man im "Run-P"-Modus dauernd neue Werte schickt ...
    Trotzdem "Danke" für die Tipps!

Ähnliche Themen

  1. Antworten: 10
    Letzter Beitrag: 16.04.2011, 00:03
  2. Antworten: 9
    Letzter Beitrag: 18.11.2009, 16:04
  3. protool string archivieren?
    Von pascal im Forum HMI
    Antworten: 47
    Letzter Beitrag: 12.02.2008, 17:54
  4. Antworten: 5
    Letzter Beitrag: 21.11.2007, 12:24
  5. ProTool-Fehlermeldungen in String ?
    Von Larry Laffer im Forum HMI
    Antworten: 4
    Letzter Beitrag: 28.04.2007, 09:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •