Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Problem beim Stringvergleich EQ_STRNG

  1. #1
    Registriert seit
    28.11.2007
    Beiträge
    2
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich möchte 2 Strings vergleichen die ich einem FC übergebe.
    Mein Problem, der Baustein zum Stringvergleich akzeptiert die
    in der Schnittstelle unter "IN" parametrierten Variablen unter
    S1/S2 nicht (rot hinterlegt, Variablen sind als String parametriert).
    Lege ich die gleichen Variablen unter "Schnittstelle/Temp" an
    (habe die Variablen aus "IN" kopiert,wegen Tippfehler), werden
    die Parameter akzeptiert.

    Wo liegt der Unterschied ?
    Im voraus vielen Dank.
    Gruß
    Michael
    Zitieren Zitieren Problem beim Stringvergleich EQ_STRNG  

  2. #2
    Registriert seit
    07.03.2004
    Beiträge
    4.369
    Danke
    946
    Erhielt 1.158 Danke für 831 Beiträge

    Standard

    Also in der Hilfe von EQ_STRING steht drin das nur der D und L bereich für die Strings als Eingabe möglich ist. Darüber hinaus steht drin:
    Zitat Zitat von Step7 Hilfe
    Die Eingangsparameter können nur mit einer symbolisch definierten Variablen belegt werden.
    Warum das so ist kann ich Dir aus dem Stehgreif nicht beantworten.
    If you open your Mind too much, your Brain will fall out.

  3. Folgender Benutzer sagt Danke zu zotos für den nützlichen Beitrag:

    BohneM (28.11.2007)

  4. #3
    Registriert seit
    30.03.2005
    Beiträge
    2.096
    Danke
    0
    Erhielt 673 Danke für 541 Beiträge

  5. Folgender Benutzer sagt Danke zu Kai für den nützlichen Beitrag:

    BohneM (28.11.2007)

  6. #4
    Registriert seit
    27.08.2003
    Ort
    Schweitenkirchen
    Beiträge
    472
    Danke
    101
    Erhielt 73 Danke für 59 Beiträge

    Standard

    Probiers mal jeweils mit "Array of Char".
    Sollte gehen.

  7. Folgender Benutzer sagt Danke zu Zefix für den nützlichen Beitrag:

    BohneM (28.11.2007)

  8. #5
    BohneM ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.11.2007
    Beiträge
    2
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    danke erst mal für die schnelle Hilfe.
    Durch eure Antworten habe ich mir in der Step7 Hilfe mal die zulässigen Datentypen beim übergeben von Parametern angeschaut.
    Also wenn ein FC einen anderen FC aufruft sind keine Zusammengesetzen Datentypen erlaubt, wenn jedoch ein FB einen FC aufruft sind sind sie erlaubt.
    Habe mein Programm jetzt statt in einen FC, in einen FB gepackt, dann funktionierts.

    Gruß
    Michael
    Zitieren Zitieren Problem erledigt  

Ähnliche Themen

  1. SCL: Stringvergleich funktioniert nicht
    Von Scanda im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 07.08.2011, 11:12
  2. Stringvergleich FC10
    Von rr_zx im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 17.07.2011, 18:34
  3. S7 Problem beim E/A beschriften
    Von Gabriel im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 06.09.2009, 19:20
  4. SCL Stringvergleich indirekt aus DB
    Von MFreiberger im Forum Simatic
    Antworten: 23
    Letzter Beitrag: 13.11.2008, 15:49
  5. Problem beim Verfahren mit FM 354
    Von Kastele im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 22.10.2004, 17:18

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •