Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: ASi Eingang

  1. #1
    Registriert seit
    04.10.2007
    Ort
    Delmenhorst
    Beiträge
    339
    Danke
    53
    Erhielt 43 Danke für 27 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!
    Das ist mein erster Beitrag hier, also hoffe ich mal, dass ich keine wichtigen Angaben vergesse.
    Habe 3 im Prinzip ähnliche Anlagen in Betrieb genommen, bei denen das gleiche Phänomen auftrat: wenn man die Variablen, die über den ASi-Bus kommen, beobachtet hat, dann war immer ein Eingang gesetzt, der nicht angeschlossen war. An diesem Eingang war jeweils gar kein Modul angeschlossen. Eingang war jedes Mal E64.6.
    Verwendete Hardware: CPU 314, CP 343-2P, je nach Anlage mehrere ASi- - A/B bzw. Standard-Slaves. A/B-Slaves alle auf den A-Adressen.
    Ich hoffe, irgendjemand kann mir dieses Phänomen erklären.
    Vielen Dank im Voraus!

    Eliza
    Zitieren Zitieren ASi Eingang  

  2. #2
    Registriert seit
    03.01.2006
    Ort
    Im sonnigen Süden von Österreich!
    Beiträge
    1.377
    Danke
    227
    Erhielt 183 Danke für 168 Beiträge

    Standard

    Hallo!

    +++++++++
    Edit:
    Habe gerade gesehen das du von einem Eingang sprichst und nicht von einem Ausgang!
    Mein Beitrag bezieht sich auf Ausgänge.
    +++++++++

    War das eine normale 314CPU oder eine 314C?

    Wenn 314C dann siehe:

    Zitat von Siemens:
    Mit dem Firmware-Update V2.6.3 werden die folgenden Änderungen wirksam:
    • VKE Ergebnisverfälschungen beim „O“ Befehl (ODER-Verknüpfung vor UND-Funktion) im PG-Betrieb mit Status-Baustein sind behoben.
    Aufgrund eines Problems in der Firmware V2.6.1 und V2.6.2, kann es im PG Betrieb beim online Beobachten mit Status-Baustein von folgender Programmsequenz zur Verfälschung des VKE Ergebnisses kommen:
    U a b.c
    U d e.f
    .
    .
    U x y.z
    O // das hier gebildete VKE kann (ausschließlich bei Baustein beobachten dieser Sequenz) verfälscht werden
    U y z.x
    .
    .
    U s t.u
    Und:
    http://www.sps-forum.de/showthread.p...highlight=314C
    zum Schluss steht die Lösung

    godi
    Geändert von godi (04.12.2007 um 17:08 Uhr)

  3. #3
    Eliza ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    04.10.2007
    Ort
    Delmenhorst
    Beiträge
    339
    Danke
    53
    Erhielt 43 Danke für 27 Beiträge

    Standard

    Hallo!
    das ist eine "normale" 314 CPU. Ja, und es ist ein Eingang. Deswegen bin ich ja so erstaunt. Wo nichts angeschlossen ist, sollte auch eigentlich nichts ankommen, oder?
    Zitieren Zitieren ASi-Eingang  

  4. #4
    Registriert seit
    13.02.2004
    Beiträge
    206
    Danke
    46
    Erhielt 17 Danke für 17 Beiträge

    Standard

    Ich mag mich erinnern, dass die ASI Module mit 5 Löcher pro Buchse einen Pin intern auf den nächsten Eingang geschalten haben.
    Bei z.B. SICK Lichtschranken kann man dann beide Schaltzustände abfragen. Kontrolliere mal wie die Beschaltung bei dir aussieht.

    Guenni

  5. #5
    Eliza ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    04.10.2007
    Ort
    Delmenhorst
    Beiträge
    339
    Danke
    53
    Erhielt 43 Danke für 27 Beiträge

    Standard

    so, habe nochmal nachgeguckt: verwendet wurden die Kompaktmodule K45 (3RK2400). Die haben zwar 5 Pins, aber müsste dieser Effekt dann nicht bei jedem Modul auftreten? Pro Anlage haben wir mindestens 7 Module verbaut, und nur dieser eine Eingang ist immer 1.
    Was mir dabei Kopfschmerzen bereitet ist nämlich: Was passiert, wenn ich an der Adresse wirklich mal ein Modul habe und diesen Eingang weiterverarbeite? Kann ich mich auf diesen Eingang verlassen, wenn da schon ohne Modul was anliegt?
    Schonmal Danke im Voraus, falls noch irgendjemand eine Idee hat.

    Gruß, Eliza

  6. #6
    Registriert seit
    13.02.2004
    Beiträge
    206
    Danke
    46
    Erhielt 17 Danke für 17 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Eliza Beitrag anzeigen
    verwendet wurden die Kompaktmodule K45 (3RK2400).
    Sind alle Module gleich beschaltet?
    Bleibt E64.6 auf 1 wenn kein Eingang beschaltet ist?
    Ich glaube bei dem deinem Modul wurde die Y Beschaltung verwendet.
    Schau dazu mal den Beitrag 4744547 auf der Siemens Homepage an.

    Gruss
    Guenni

Ähnliche Themen

  1. FC 32 Eingang IN
    Von Alexandr im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 04.08.2010, 12:59
  2. 1 Eingang -> 2 Schaltzustände
    Von Prog22 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 28.06.2010, 15:11
  3. Eingang blockieren
    Von Marco_Ulm im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 30.04.2008, 12:13
  4. FP mit Eingang?
    Von Drain im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 26.10.2007, 10:19
  5. ob 1 en eingang
    Von fra226 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 04.09.2006, 15:34

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •