Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 17

Thema: An SM334 ein Poti anschließen?

  1. #1
    Registriert seit
    18.05.2004
    Beiträge
    203
    Danke
    2
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe zwar die Suche schon verwendet, aber ich werde auf die Antworten daraus nicht schlau.

    Ich habe eine CPU 314-IFM und eine Analogeingabebaugruppe SM334
    6ES7 334-0CE01-0AA0. Ich möchte nun an dieser Baugruppe ein Poti mit 5kOhm anschließen. Ich brauche dafür eine 10V Spannungsversorgung. Diese bekomme ich momentan aus einem Analogausgang, der auf 10V eingestellt ist. Den Schleifer des Potis schließe ich wiederum an den Analogeingang an. Zusätzlich noch die 0V des Analogausgangs an den Analogeingang. Ob dies überhaupt nötig ist, ist schonmal die Frage?

    Gibt es eine Möglichkeit an diese Baupgruppe das Poti direkt anzuschließen, also ohne das ich eine 10V Spannungsversorgung brauche? Dann würd ich mir den letzten Analogausgang sparen.

    Viele Dank für euere Antworten!!!

    Gruß
    Michael
    Zitieren Zitieren An SM334 ein Poti anschließen?  

  2. #2
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Die Baugruppe kann keine Widerstände messen.
    Wenn Du eine andere nimmst, gehen für die Widerstandsmessung immer zwei Analogeingänge drauf.
    Je nachdem wie genau die Messung reicht, kann man mit einem Netzteil auf 0-10V wandeln (z.B. Phönix oder Murr), oder einen Spannungsteiler Bauen, oder eine Konstantspannungshalter einbauen und die 10V selber machen.

  3. #3
    S7_Mich ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.05.2004
    Beiträge
    203
    Danke
    2
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Hallo,

    vielen Dank für die Nachricht.

    Habe ich mir fast schon gedacht. Werd mal sehen, ob wir in der Arbeit ein Netzteil haben. Ich bräuchte eigentlich nur so ein Teil, das die Spannung von 24V auf 10V wandelt. Hab keine 230V zur verfügung.

    Aber ich glaub, wenn ich mir ein Netzteil kaufe, ist es immer noch besser, als wenn ich einen Analogausgang verschwende.

    Gruß
    Michael

  4. #4
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Also die Murr oder Phönix Teile wandeln die 24V nach 10V, davon war ich ausgegangen.

    z.B. Murr.

    http://onlineshop.murrelektronik.com...anguage=German

  5. Folgender Benutzer sagt Danke zu jabba für den nützlichen Beitrag:

    SPS_S5_S7 (22.10.2009)

  6. #5
    S7_Mich ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.05.2004
    Beiträge
    203
    Danke
    2
    Erhielt 2 Danke für 2 Beiträge

    Standard

    ja genau, sowas wäre ideal. da muß ich schauen, ob wir in unserem betrieb sowas haben.

    Dankeschön

    Michael

  7. #6
    Registriert seit
    05.12.2007
    Beiträge
    25
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,
    ich hatte kürzlich das gleiche Problem.
    Ich habe einen Messumformer von Phönix eingebaut, Typ MCR-T-UI-NC, das ist eigentlich ein Temperaturmessumformer der sich als Potimessumformer programmieren lässt und dann den Potiwert 0....100% als Normsignal, z,B. 4...20mA ausgibt.
    Vielleicht hilft dir das ja weiter.
    Zitieren Zitieren Messumformer  

  8. #7
    Registriert seit
    19.11.2007
    Beiträge
    78
    Danke
    23
    Erhielt 13 Danke für 10 Beiträge

    Standard

    Zitat Zitat von S7_Mich Beitrag anzeigen
    Zusätzlich noch die 0V des Analogausgangs an den Analogeingang. Ob dies überhaupt nötig ist, ist schonmal die Frage?
    Das wirst du wohl so machen müssen, da die meisten Karten ja Potigetrennt sind.

    Gehe mal davon aus das du es so machen willst aber trotzdem:
    Nicht vergessen solltest du auch den zweiten Endpunkt des Potis ebenfalls an diese Masse anzuschließen damit du einen Spannungsteiler und nicht nur einen Vorwiderstand am Eingang hast
    1= +10V 3= GND 2= Schleifer an AI

  9. #8
    Registriert seit
    19.11.2007
    Beiträge
    78
    Danke
    23
    Erhielt 13 Danke für 10 Beiträge

    Standard

    Solange es nicht zu genau werden braucht kannst du doch auch einen Vorwiderstand an der + Seite in Reihe zum Poti schalten und die +24V verwenden.

    Oder eben die Lösung mit einem Konstantregler z.B. 7810 (und 2..3 kleinen Kondensatoren!) direkt am Poti gelötet, kannst du ja auch aus den 24V versorgen.
    So kostet es nur Pfennige gegen deinen Wandler für einige EUR mehr...

  10. #9
    Registriert seit
    24.10.2007
    Ort
    stuttgart
    Beiträge
    16
    Danke
    3
    Erhielt 1 Danke für 1 Beitrag

    Standard

    moin,

    letztere methode (10V-festspannungs-laengsregler 7810 mit abblockkondensatoren hoffentlich auf der nicht sichtbaren unterseite der platine) benutzt sogar phoenix selbst in seinen starterkits, um mit einem poti in einem kleinen hutschienengehaeuse mit durchsichtigem deckel und schraubklemmen aus 24V eine variable 0..10V-spannung zur ansteuerung von analogeingaengen zu machen.
    cu,
    *markus*

  11. #10
    Registriert seit
    19.11.2007
    Beiträge
    78
    Danke
    23
    Erhielt 13 Danke für 10 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Genau, sauber aufgebaut spricht sicher nix gegen eine "Selbstlötlösung" sogar im produktiven Einsatz.
    Wir haben früher mal kleine Hutschienenträger mit Klemmen für solche Potis mit M10? Befestigung gehabt. Das sah dann wirklich ganz passabel aus und hatte sogar Platz für zusätzliche Bauteile, ich weiß nur nicht mehr
    woher die kamen..

Ähnliche Themen

  1. Beschaltung SM334
    Von Manfred Stangl im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 28.01.2010, 07:31
  2. Drehgeber als Poti ersatz 'Digital Poti'
    Von GFI im Forum Elektronik
    Antworten: 1
    Letzter Beitrag: 08.11.2008, 21:08
  3. Analogbaugruppe SM334
    Von Andy_speedy im Forum Simatic
    Antworten: 16
    Letzter Beitrag: 03.10.2007, 13:09
  4. PT100 am SM334
    Von Tom137 im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 17.07.2007, 15:57
  5. Defekte eingangen SM334
    Von Revave im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 03.01.2006, 19:57

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •