Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 27 von 27

Thema: CPU 317 Datenbausteininhalt plötzlich alles 0

  1. #21
    Registriert seit
    16.12.2004
    Ort
    Schleswig-Holstein
    Beiträge
    400
    Danke
    21
    Erhielt 23 Danke für 20 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe es vielleicht übersehen, aber Bibi scheint nicht gesagt zu haben ob die DBs als nicht remanent deklariert waren oder nicht. Wenn doch, dann reicht ein Umschalten RUN -> STOP -> RUN um die Initialwerte der DBs neu zu laden, mindestens mit Firmware ab V2.0.

    Wie schon erwähnt, für zukünftige Sicherheit soll unbedingt die Aktualwerte mit RAM nach ROM kopieren in die Initialwerte geschrieben werden.

    Vor ein Paar Jahren gab es ein interessantes Thread über das Thema hier . Die Tabelle auf Seite 4 dürfte für manche interessant sein.

  2. #22
    BiBi ist offline Benutzer
    Themenstarter
    Registriert seit
    23.02.2007
    Ort
    Regensburg
    Beiträge
    53
    Danke
    18
    Erhielt 4 Danke für 4 Beiträge

    Standard

    @RMA

    Die DBs sind nicht als nicht Remanent markiert.

    RAM nach ROM kopieren werde ich auf jeden Fall beim nächsten Besuch machen.

    PS: Die Tabelle des Links ist tatsächlich interessant.
    Gruß

    BiBi

    Alle Menschen sind klug - die einen vorher, die anderen nachher. (Voltaire)


  3. #23
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.220
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Zitat Zitat von RMA Beitrag anzeigen
    Ich habe es vielleicht übersehen, aber Bibi scheint nicht gesagt zu haben ob die DBs als nicht remanent deklariert waren oder nicht. Wenn doch, dann reicht ein Umschalten RUN -> STOP -> RUN um die Initialwerte der DBs neu zu laden, mindestens mit Firmware ab V2.0.

    Wie schon erwähnt, für zukünftige Sicherheit soll unbedingt die Aktualwerte mit RAM nach ROM kopieren in die Initialwerte geschrieben werden.

    Vor ein Paar Jahren gab es ein interessantes Thread über das Thema hier . Die Tabelle auf Seite 4 dürfte für manche interessant sein.
    Bist du da sicher? Das hab ich noch nie erlebt, daß nach Run-Stop-Run meine Datenbausteine wieder auf ihren Initialwerten standen. Das passiert doch im Prinzip bei jedem kompletten Ausschalten der Anlage. Ich hab in der Hardwarekonfig jedenfalls keine DB extra remanent deklariert.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  4. #24
    Registriert seit
    28.09.2005
    Beiträge
    428
    Danke
    118
    Erhielt 91 Danke für 76 Beiträge

    Standard

    Zitat Zitat von Ralle Beitrag anzeigen
    Bist du da sicher? Das hab ich noch nie erlebt, daß nach Run-Stop-Run meine Datenbausteine wieder auf ihren Initialwerten standen. Das passiert doch im Prinzip bei jedem kompletten Ausschalten der Anlage. Ich hab in der Hardwarekonfig jedenfalls keine DB extra remanent deklariert.
    Hätte ich auch noch nicht gehört - im Merkerbereich schon.

  5. #25
    Registriert seit
    16.12.2004
    Ort
    Schleswig-Holstein
    Beiträge
    400
    Danke
    21
    Erhielt 23 Danke für 20 Beiträge

    Standard

    Bist du da sicher? Das hab ich noch nie erlebt, daß nach Run-Stop-Run meine Datenbausteine wieder auf ihren Initialwerten standen. Das passiert doch im Prinzip bei jedem kompletten Ausschalten der Anlage. Ich hab in der Hardwarekonfig jedenfalls keine DB extra remanent deklariert.
    Ja, siehe Ausschnitt vom Siemens Handbuch in #46 auf Seite 4 in o.g. Thread.

    Aber - gilt nur ab Firmware V2.1 (nicht V2.0, hab' mich vertan da oben) und per Default sind DBs (nur bis max. 256 kB im 317'er und möglicherweise 319'er?) remanent - also man müsste die extra nicht remanent setzen, was zugeben selten gebraucht wird.
    Geändert von RMA (09.01.2008 um 17:01 Uhr)

  6. #26
    JonnyBravo81 Gast

    Cool

    Hi BiBi,
    gaaaanz einfach.
    Schau mal nach, ob das Programm in der CPU das gleiche wie in der Flash Karte ist.
    Das Problem könnte sein, dass die Programmstände (RAM und FlashCard) unterschiedlich waren. Und nach einem Spannungsausfall hatte die SPS sich das Programm aus der FlashCard den falschen Stand geholt.

    Eine andere Möglichkeit könnte sein, dass die Deklaration eines DB's falsch war. Du kannst in der Simatic Umgebung umswitchen zwischen Daten- und Deklarationsansicht.

    Als erfahrener SPS'ler würde ich auf eine der beiden Ursachen tippen.
    Gruß
    Jonny

  7. #27
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.727
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von JonnyBravo81 Beitrag anzeigen
    Hi BiBi,
    gaaaanz einfach.
    Schau mal nach, ob das Programm in der CPU das gleiche wie in der Flash Karte ist.
    Das Problem könnte sein, dass die Programmstände (RAM und FlashCard) unterschiedlich waren. Und nach einem Spannungsausfall hatte die SPS sich das Programm aus der FlashCard den falschen Stand geholt.

    Eine andere Möglichkeit könnte sein, dass die Deklaration eines DB's falsch war. Du kannst in der Simatic Umgebung umswitchen zwischen Daten- und Deklarationsansicht.

    Als erfahrener SPS'ler würde ich auf eine der beiden Ursachen tippen.
    Gruß
    Jonny
    Da hier von einer MMC und nicht einer MC die Rede ist kann man deine 1te Möglichkeit zu 100% auschließen,
    es ist definitiv physikalisch nich möglich das sich das Programm in der CPU vom Stand auf der MMC unterscheidet.

    Das mit der Deklaration ist zwar möglich, würde aber vorraussetzen, das der DB von irgendwem in die Steuerung übertragen wurde,
    aber auch das ist hier scheinbar nicht der Fall.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

Ähnliche Themen

  1. Fup plötzlich nur mehr AWL
    Von simon.s im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 26.10.2011, 13:49
  2. Plötzlich viel Freizeit.
    Von Rafa im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 07.06.2009, 18:27
  3. DB plötzlich gelöscht...CPU 313C-2DP
    Von Jochen Kühner im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 14.11.2007, 15:35
  4. Datenbausteininhalt online beobachten aber wie ?
    Von noeppkes im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 12.09.2007, 12:00
  5. HW-Update fehlt plötzlich
    Von Kniffo im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 26.04.2007, 08:53

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •