Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: S5 problem

  1. #1
    Registriert seit
    07.02.2008
    Beiträge
    18
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hi sps forum,

    Ich hab jede Menge Probleme mit S5, ich muß nämlich aus einem altes S5 eine neue Rockwell zaubern (meine 2 wochen S5 grundkurs im jahr 2001 haben mich dazu qualifiziert ), natürlich reicht das nicht für :

    Netzwerk 1
    :O M 0.0
    :ON M 0.0
    :***

    Netzwerk 2
    :L KF +0
    :T MW 220
    :SPA FB 244
    Name :SEND
    SSNR : KY 0,1
    A-NR : KY 0,0
    ANZW : MW 220
    QTYP : KC DB
    DBNR : KY 0,0
    QANF : KF +0
    QLAE : KF +0
    PAFE : MB 200
    :L KF +0
    :T MW 220
    :SPA FB 245
    Name :RECEIVE
    SSNR : KY 0,1
    A-NR : KY 0,0
    ANZW : MW 220
    ZTYP : KC DB
    DBNR : KY 0,0
    ZANF : KF +0
    ZLAE : KF +0
    PAFE : MB 200
    :BE

    Was macht dieses Teil
    Zitieren Zitieren S5 problem  

  2. #2
    Registriert seit
    28.01.2004
    Ort
    Bodensee
    Beiträge
    260
    Danke
    18
    Erhielt 15 Danke für 13 Beiträge

    Standard

    Hallo William700,

    Das sind Send-/RECEIVE-Bausteine für eine S5- AG115.
    Bedeutung: ISO-Transportverbindung über Industrial Ethernet zwischen der SIMATIC S5 und SIMATIC S7

    Im NW1 wird das VKE = 1 gebildet.

    Im NW2 werden die FB244 und FB245 aufgerufen und parametriert.

    Die Beduetung der einzelnen Parameter findest du bei Siemens unter der
    folgenden Beitrags-ID: 17661306.

    Viel Glück!!


    Grüße INST

  3. Folgender Benutzer sagt Danke zu INST für den nützlichen Beitrag:

    William700 (14.02.2008)

  4. #3
    Registriert seit
    20.10.2004
    Beiträge
    650
    Danke
    5
    Erhielt 26 Danke für 26 Beiträge

    Standard

    Zitat Zitat von INST Beitrag anzeigen
    S7

    Im NW1 wird das VKE = 1 gebildet.
    aber was machen die damit !!!!

    vke wird zwar eins aber kenen intresierts

  5. #4
    Registriert seit
    08.09.2007
    Beiträge
    43
    Danke
    0
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Die "SEND" und "RECEIVE" Bausteine brauchen ein VKE ='1' beim Aufruf, sonst wird nur das Anzeigenwort aktualiesiert. Die BAussteine sind als Send-ALL und Receive-ALL parametriert. Irgendwo im Programm sollte die Bausteine nochmal auftauchen mit Auftragsnr. =/= 0,0.

  6. #5
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Beitrag

    Hallo,

    Zitat Zitat von INST
    Bedeutung: ISO-Transportverbindung über Industrial Ethernet zwischen der SIMATIC S5 und SIMATIC S7
    Woran kann man denn im Programmbeispiel erkennen, das es sich hier um eine ISO-Transportverbindung handelt ?
    Gemäss dem S5-Code kann da fast jeder beliebe Kommunikationsprozessor hinterstecken. Egal ob ISO, ISO-on-TCP, Profibus, seriell etc. Die HTB's in der S5 hatten ja gerade den Sinn, für jeden CP die HTB Aufrufe einheitlich zu haben.
    @William700 : Diese Bausteine kannst Du nicht direkt nach Rockwell umsetzen. Du musst nachsehen, welche CP's in der S5 verbaut sind, d.h. welche Kommunikationswege zu anderen Partnern bestehen. Und diese Wege mit Rockwell Möglichkeiten (die ich nicht kenne) neu aufbauen.

    Gruß

    Question_mark

    PS : Du hast allerdings jetzt weniger ein S5 Problem sondern eher ein Rockwell Problem
    Geändert von Question_mark (14.02.2008 um 21:28 Uhr) Grund: Tippfehler
    ''Ich habe wirklich keine Vorurteile.
    Meine Meinung ist nur die Summe der Erfahrungen" ... (Question_mark)
    Zitieren Zitieren S5 Problem ?  

  7. Folgender Benutzer sagt Danke zu Question_mark für den nützlichen Beitrag:

    argv_user (14.02.2008)

  8. #6
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Beitrag

    Hallo,

    Zitat Zitat von F_AP
    Irgendwo im Programm sollte die Bausteine nochmal auftauchen mit Auftragsnr. =/= 0,0.
    Können schon. Müssen aber nicht, wenn diese S5 nur der Passive Partner (im Sinne einer Kommunikationsbeziehung) ist. Wenn z.B der andere Partner dieser S5 sich mit einem "Fetch" Auftrag Daten holt und keine Aufträge auf dem CP-EPROM programmiert sind, reichen diese Bausteinaufrufe völlig aus.
    Allerdings könnte ich mir vorstellen, dass diese Bausteine eher noch mal mit einer Schnittstellennummer = 0 im S5-Programm auftauchen.

    Gruß

    Question_mark
    ''Ich habe wirklich keine Vorurteile.
    Meine Meinung ist nur die Summe der Erfahrungen" ... (Question_mark)
    Zitieren Zitieren Spekulatius ..  

  9. #7
    Registriert seit
    20.10.2004
    Beiträge
    650
    Danke
    5
    Erhielt 26 Danke für 26 Beiträge

    Standard

    Zitat Zitat von F_Ap Beitrag anzeigen
    Die "SEND" und "RECEIVE" Bausteine brauchen ein VKE ='1' beim Aufruf, sonst wird nur das Anzeigenwort aktualiesiert. Die BAussteine sind als Send-ALL und Receive-ALL parametriert. Irgendwo im Programm sollte die Bausteine nochmal auftauchen mit Auftragsnr. =/= 0,0.
    allso es kann ja sein das ich schon zulange nicht mehr s5 programmiert habe so sicher ganze 8 tage ( hab eh schon entzugserscheinungen )

    aber ein neues netzwerk und vke geht automatisch auf 1

    korrigiert mich wenn ich mich irre

  10. #8
    Registriert seit
    08.09.2007
    Beiträge
    43
    Danke
    0
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Nein

    ein neues Netzwerk geht das VKE nicht auf '1'.
    Netzwerke sind sogesehen nur für die Darstellung, sie beeinflussen nicht das Programm. Soll heißen ob der code in 20 Netzwerken steht oder in einem, das Ergebniss leibt das selbe, nur unübersichtlicher, wenn alles in 1 Netzwek steht.

  11. Folgender Benutzer sagt Danke zu F_Ap für den nützlichen Beitrag:

    kpeter (15.02.2008)

  12. #9
    Registriert seit
    08.09.2007
    Beiträge
    43
    Danke
    0
    Erhielt 6 Danke für 6 Beiträge

    Standard

    In obigen Beispiel hätte ich aber trotzdem beide Netzweke Zusammengefasst, weil die einfach zusammengehören. Kommt wahrscheinlich aus der KOP oder FUP Programmierung, da geht es nicht anders.

    noch einen schönen Tag an alle die sich mit SIEMENS herrumschlagen müssen

  13. #10
    Registriert seit
    20.10.2004
    Beiträge
    650
    Danke
    5
    Erhielt 26 Danke für 26 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von F_Ap Beitrag anzeigen
    Nein

    ein neues Netzwerk geht das VKE nicht auf '1'.
    Netzwerke sind sogesehen nur für die Darstellung, sie beeinflussen nicht das Programm. Soll heißen ob der code in 20 Netzwerken steht oder in einem, das Ergebniss leibt das selbe, nur unübersichtlicher, wenn alles in 1 Netzwek steht.

    ok ok

    schande über mein haupt

    man sollte nicht immer voreilig die schnauze aufmachen

    ich meinte eigentlich was anderes aber lassen wir es

Ähnliche Themen

  1. OPC Problem routen problem
    Von kpeter im Forum Hochsprachen - OPC
    Antworten: 1
    Letzter Beitrag: 25.08.2010, 19:54

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •