Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: AWL: "SFB 3 TP" Verwendung in einem FB?

  1. #1
    Registriert seit
    11.12.2007
    Beiträge
    32
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!
    Ich hab mal wieder eine Anfängerfrage.
    Wenn man in einem FB die Statischen Timer Txxx bis Tyyy nicht verwenden kann/will, gibt es da eine Möglichkeit aus der Zykluszeit die Timer SI,SV,SE,SS,SA nachzubilden?
    Gibts dafür irgendwo Infos? Im Help finde ich nix.

    Im AWL, SCL Buch steht was von IEC Zeitfunktionen SFB 3 TP, SFB 4 TON, SFB 5 TOF.
    Kann man die auch dazu hernehmen?

    Ich hab mir ein Beispiel aus dem Buch genommen, kriege es aber nicht zum laufen weil die Befehle irgendwie nicht angenommen werden.


    // So funktionierts:
    // U #LampTest // Eingang
    // L S5T#10S
    // SV T 150
    // U T 150
    // = #hm08 // Setzt die Lampe 10s


    // Das gleiche soll mit der SFB 3 TP laufen
    // Aber die Befehle werden schon mal gar nicht angenommen

    call #tp // Aufruf IMPULS SFB 3 TP
    in: = "#LampTest" // Eingang
    pt: = #PT3 // Impulsdauer 10s
    q := "#hm8" //
    et:=#ET3 // abgelaufenen Zeitdauer

    Könnte mir bitte einer sagen was ich falsch mache?

    Gruß
    Hans
    Zitieren Zitieren AWL: "SFB 3 TP" Verwendung in einem FB?  

  2. #2
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Im Anhang ein Beispielprogramm mit SFB3 als Multinstanz
    Angehängte Dateien Angehängte Dateien

  3. #3
    hans55 ist offline Benutzer
    Themenstarter
    Registriert seit
    11.12.2007
    Beiträge
    32
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Marlob!
    Hast du das Beispiel mit Archivieren zusammengepackt? Dann sollte ichs doh eigentlich über Dearchivieren laden können, geht aber leider nicht.
    Wenn ich im Beispiel nach dem auspacken den OB1 anklicke kommt die Fehlermeldung:
    "Fehler beim erzeugen einen leeren Dokuments"
    Gruß
    Hans

  4. #4
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Erst ganz normal entpacken. Danach ist es eine selbstextrahierende Datei.

  5. #5
    Registriert seit
    30.03.2005
    Beiträge
    2.096
    Danke
    0
    Erhielt 673 Danke für 541 Beiträge

    Standard

    Ich habe das Beispielprogramm von marlob noch einmal neu als S7-Programm archiviert.

    Gruß Kai
    Angehängte Dateien Angehängte Dateien

  6. #6
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Zitat Zitat von Kai Beitrag anzeigen
    Ich habe das Beispielprogramm von marlob noch einmal neu als S7-Programm archiviert.

    Gruß Kai
    Schön das du das gemacht hast, aber eigentlich sollte ein Programmierer in der Lage sein eine Datei zu entpacken und sie danach auszuführen.
    exe-files natürlich immer vorher auf Viren checken

  7. #7
    hans55 ist offline Benutzer
    Themenstarter
    Registriert seit
    11.12.2007
    Beiträge
    32
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Marlob, Hallo Kai!
    Danke nochmal.

    Ich hatte Probleme mit meiner Installierten S7 SW am Laptop, deshalb ging nicht nur das nicht, sondern auch anderes Zeug.
    Rechner Runter und Hochfahren hat das Problem gelöst, nun kann ichs auspacken und auch ansehen.
    Danke an Beide!

    Ja, so isses halt, wenn man als S7 Anfänger irgendwas machen will, da zwickts an allen Ecken und Enden. Meißt sind es selbstgemachte Probleme.

    Gruß
    Hans
    und noch einen schönen Sonntag.

Ähnliche Themen

  1. Verwendung von SFB 104 "IP_CONF"
    Von Marcus im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 22.02.2012, 12:20
  2. Antworten: 6
    Letzter Beitrag: 19.12.2011, 15:53
  3. "Index Pulse", "Home Switch" und "Position Limit Switch"
    Von senmeis im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 07.03.2011, 11:21
  4. Verwendung "normaler" SPS'n nach 13849
    Von istat_gb im Forum Maschinensicherheit - Normen und Richtlinien
    Antworten: 15
    Letzter Beitrag: 22.07.2009, 12:35
  5. Speicherbedarf nach Verwendung von "Struct"
    Von Anonymous im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 12.02.2005, 17:06

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •