Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: Anschluss Messumformer an Analog Eingang

  1. #1
    Registriert seit
    05.05.2007
    Beiträge
    280
    Danke
    14
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich würde gern einen 2-Draht Drucksensor der mir +/-10V ausgibt an meine
    Analoge Eingangskarte (331-7KB01-0AB0) anschließen, weiß aber nicht wie.
    Kann mir da vielleicht jemand helfen.

    Gruß Markus
    Zitieren Zitieren Anschluss Messumformer an Analog Eingang  

  2. #2
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    +- 10V geht nicht als Zweidraht, geht nur bei 4-20mA

    Also hat dein Sensor wohl eine externe Versorgung z.B. 24V DC ?

    Vieleicht hast Du eine Beschreibung oder gibt mal die Pinne an
    z.B
    1: 24VDC
    2: 0V DC
    3 +- 10V
    4 Gnd

  3. #3
    settelma ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.05.2007
    Beiträge
    280
    Danke
    14
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Im Prinzip hab ich den Sensor noch nicht. Könnt dann auch einer mit
    4-20mA sein.
    Ich will meine Eingangskarte mal testen und will +/-10V über ein Netzteil
    einspeisen um den Füllstand zu simulieren.
    Jetzt weis ich aber nicht wo ich die +/-10V anschließen muss.
    Die AI-Karte brauch immer die 24V versorgung oder?

    Gruß Markus

  4. #4
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Beitrag

    Hi,
    ja, di Karte braucht die 24 VDC Versorgung.
    Der Anschluss ist von innen an das "Türchen" der Karte gedruckt.
    Normalerweise MANA(Masse) und der entspr. Pin des PEWs, je nach Konfiguration.

    Gruss: Vladi
    ______________________________________
    relax, take it easy
    Zitieren Zitieren Ai  

  5. #5
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Die Karte braucht immer +24V an Pin 1, 0V an Pin 20,
    bei manchen Signalarten auch 0V an Pin 11 MAna.

    Ganz Wichtig, den Codierstecker an der Seite richtig einstellen, da sonst die Baugruppe zestört werden kann. (B ist voreinstellung)

    Bei +-10V muss der in Stellung B

    Dann kann man mit dem Netzteil + an 2 und Minus bzw 0V an die 3 testen.
    Da die zulässige Spannungsdifferenz zwischen Mana und 0V nur 2,5V beträgt , sollte der Minus vom Netzteil mit dem Minus von der SPS und MAna verbunden sein.

    Dann in der Hardwareconfig die baugruppe parameterieren,
    +- 10V, je nachdem welche CPU Du hast, kannst Du bei Adressen den hacken Systemvorgabe wegmachen, und die Adresse auf einen kleineren Wert als 128 stellen. Dadurch kannst Du den ANalogwert direkt bei Steuern Variablen ansehen, ohne erst das PEW einzulesen.

  6. #6
    settelma ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.05.2007
    Beiträge
    280
    Danke
    14
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Danke schon mal. Der Anschluss ist jetzt anscheinend richtig.
    Ich hab zumindest mal einen Wert.
    Jetzt hab ich nur das Problem das der Wert am Panel (TP177A) nicht
    wirklich richtig angezeigt wird. Ich muss den Wert doch nicht scalieren?
    Oder vielleicht doch?
    Wenn ich den Wert (+/-10V) am Panel direkt anzeigen will kann ich doch
    einfach das PEW in ein DBW schreiben und das am Panel übernehmen.
    Meine Füllstandsanzeige am Panel springt aber nur hin und her ( mal übervoll, mal ganz leer) wenn ich die Spannung langsam ändere.
    Hat hier vielleicht noch jemand ne Idee an was das liegen kann?

    Gruß Markus

  7. #7
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Mit dem FC105 aus der TI-Bibliothek kannst Du den Analogwert scalieren.

    z.B. 0-100%, mal die Suche benutzen

    Hi wäre 100.0
    Lo wäre 0.0

    Bipolar entweder high oder Low, je nachdem ob du +-10V oder 0-10V verwendest.


    Wenn der Analogwert sehr stark "zappelt" kann es dein Netzteil sein,
    oder eine Fehlerhafte Masseverbindung.

Ähnliche Themen

  1. Analog Eingang / Analog Ausgang - Twin CAT System
    Von tech007 im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 23.05.2011, 18:22
  2. Analog eingang
    Von Placidjam im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 24.06.2009, 21:34
  3. Anschluss 2-Draht Messumformer an SM331
    Von Nuecke im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 30.01.2008, 13:46
  4. Antworten: 4
    Letzter Beitrag: 31.05.2007, 07:24
  5. analog Eingang normieren
    Von ElektronikJack im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 17.11.2006, 08:55

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •