Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 4 of 4

Thread: Profibus:S5/IM308C-Master->S7-314-Slave: Probleme!

  1. #1
    Join Date
    15.05.2004
    Posts
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,
    ich habe ein aktuelles Problem. Ein Kollege sitzt in Estland und versucht einen Profibus zu erweitern. Als Master sind 2 S5-IM308C eingesetzt, eine S7-314-2DP war bereits als Slave integriert und arbeitete, die 2.S7 soll jetzt eingebunden werden (313C-2DP). Die Konfiguration wurde genauso gewählt. Profibus Software für IM308C ist COM PBV5.1. Beim Zurücklesen aus der IM308C werden die S7-Slaves nicht mehr angezeigt.
    Unter der Diagnose erscheint eine Meldung: Slave not ready for communication, pls. parameterize (o.ö.) again!

    Hat jemand eine Idee, bzw. Erfahrung mit ähnlichen Problemen?

    Danke

    Addi
    Reply With Quote Reply With Quote Profibus:S5/IM308C-Master->S7-314-Slave: Probleme!  

  2. #2
    Join Date
    17.10.2004
    Posts
    154
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    Da beide Slaves scheinbar nicht antworten, hat er wohl beide mit der gleichen Adresse versehen.

    Vorschlag:
    2ten (neuen) Slaven ausbauen, 1ten Slaven testen.
    1ten (alten) Slaven ausbauen und 2ten Slaven testen.
    Ggf auch die fehlermeldungen an den Slaves auslesen.

    Im Übrigen sind die Resultate der Diagnose bei Anlagen mit mehreren CPUs mit Vorsicht zu genießen.

    Limbo
    Wenn ich Schuhe und Strümpfe ausziehe, kann ich bis 20 zählen.

  3. #3
    62addi is offline Neuer Benutzer
    Themenstarter
    Join Date
    15.05.2004
    Posts
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    Danke schon Mal für Deine Antwort,
    ich hole noch Mal etwas weiter aus:
    1. Mit der ersten S7 (314-2DP, PB-Adresse 30), funktionierte es bereits schon (Inbetriebnahme vor ca. 5 Monaten).
    2. Eigenartigerweise ließ sich die Applikation nicht von der IM308 hochladen. (Fehlermeldung muß ich nochmal erfragen)
    3. Die alte Konfiguration (Punkt 1) funktioniert auch nicht mehr, wurde damals von einem anderen Kollegen in Betrieb genommen, klar mit seinem PC, seinen GSD-files etc..(wurde nochmal zum Test übertragen)
    4. Die Erweiterung um einen weiteren S7-Slave (313-2DP, PB-Adresse 31) wurde genauso wie die 314 von mir vorgenommen (S5-Seite).
    5. Nun kommt bei beiden CPUs die Meldung wie in meinem 1. Beitrag beschrieben.

    Gruß

    Addi

  4. #4
    62addi is offline Neuer Benutzer
    Themenstarter
    Join Date
    15.05.2004
    Posts
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Problem gelöst!
    Es lag an der COM Profibus Version. Installiert war nur V5.1 SP2, damit trat der Fehler auf. Notwendig waren die Hotfixes 1, 2,3, die nacheinander installiert werden müssen.

    Gruß

    Addi

Similar Threads

  1. Replies: 11
    Last Post: 14.01.2020, 11:11
  2. Replies: 1
    Last Post: 22.09.2017, 11:33
  3. Master-Slave-Profibus
    By Berta in forum Simatic
    Replies: 2
    Last Post: 25.03.2011, 09:15
  4. Replies: 4
    Last Post: 21.02.2006, 15:54
  5. Replies: 2
    Last Post: 11.01.2005, 17:32

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •