Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Schreibweise SCL Debug Info...

  1. #1
    Registriert seit
    08.01.2007
    Ort
    Dülmen
    Beiträge
    393
    Danke
    58
    Erhielt 24 Danke für 17 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    EDIT: Schon gefunden... irgendwann habe ich das richtige in der Hilfe eingegeben ...


    ... irgendwie bin ich bei der Hilfefunktion gerade gehemmt.

    Wenn ich den Baustein Online sehen möchte (SCL Editor) kommt immer: Nicht möglich, kein Debug Info erstellt worden.

    Ich kenne es von VB das ich im Code z.B.
    Debug.Print = "Kommentar " &VariableX
    mit einfügen kann, und mir das Ergebnis unten im Fenster anschauen kann.

    Ist das hier ähnlich, und wie ist die Syntax?
    Geändert von AndreK (18.03.2008 um 11:28 Uhr)
    Zitieren Zitieren Schreibweise SCL Debug Info...  

  2. #2
    Registriert seit
    18.03.2008
    Beiträge
    267
    Danke
    3
    Erhielt 26 Danke für 26 Beiträge

    Standard

    Weiss jetzt nicht wie das genau geht, hab mein Step7 nicht gerade zur Hand.

    Im SCL - Editor irgenwie bei Einstellungen, gibts da eine Checkbox "Debug Info erstellen" oder ähnlich. Dies musst du anhacken, dann gehts.

    Zu beachten ist auch, dass du im SCL-Editor nur immer eine Quelle beobachten kannst (ist leider so). Wenn du einen anderen Baustein beobachten willst, musste jeweils unter Test (so heisst glaub ich das menu) Test abbrechen, oder Verbindung trennen... erst dann kannste eine neue Quelle beobachten.

    Ach ja,

    nach dem Anhacken der Checkbox musste die Quelle natürlich nochmals neu Übersetzen und laden.

  3. #3
    Registriert seit
    18.03.2008
    Beiträge
    267
    Danke
    3
    Erhielt 26 Danke für 26 Beiträge

    Standard

    Ach ja, irgend so ein von Visual Studio bekanntes DEBUG.PRINT wäre mir nicht bekannt, dass es da sowas gibt...

  4. #4
    Registriert seit
    27.11.2005
    Ort
    im Osten
    Beiträge
    1.183
    Danke
    141
    Erhielt 271 Danke für 248 Beiträge

  5. #5
    AndreK ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    08.01.2007
    Ort
    Dülmen
    Beiträge
    393
    Danke
    58
    Erhielt 24 Danke für 17 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ... aber ich hatte im "EDIT" ja schon angegeben das ich es gefunden habe.

    Ist ja recht kompfortabel, aber scheint nicht ohne Bugs zu sein. Teilweise werden Statuszeilen erst aktualsiert wenn man weiter vorne in den Code klickt... naja, aber ich habe das was ich brauche
    Zitieren Zitieren Danke für eure Mühen...  

Ähnliche Themen

  1. SCL gibt Fehler wegen debug info aus
    Von Bensen83 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 22.01.2017, 22:32
  2. Debug-Infos von LibNoDave deaktivieren?
    Von muhmann im Forum Hochsprachen - OPC
    Antworten: 21
    Letzter Beitrag: 14.12.2010, 13:24
  3. Gibt es eine andere Schreibweise?
    Von bastler im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 08.09.2010, 19:18
  4. SCL Debug
    Von Rose im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 03.07.2008, 10:23
  5. Schreibweise String bei FC Aufruf
    Von SPS_Checker im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 06.03.2008, 18:29

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •