Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 4 von 4 ErsteErste ... 234
Ergebnis 31 bis 40 von 40

Thema: Reglerwahl

  1. #31
    Steve38 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.02.2008
    Beiträge
    472
    Danke
    23
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ok, hab ich gemacht.

    Mein Regler sieht jetzt so aus:

    U A 7.0
    = L 0.0
    BLD 103
    U "S_1_End_Auf"
    = L 0.1
    BLD 103
    U "S_1_End_Zu"
    = L 0.2
    BLD 103
    U E 127.1
    = L 0.3
    BLD 103
    U E 127.2
    = L 0.4
    BLD 103
    U E 127.3
    = L 0.5
    BLD 103
    U E 127.4
    = L 0.6
    BLD 103
    CALL "CONT_S" , DB5
    COM_RST :=L0.0
    LMNR_HS :=L0.1
    LMNR_LS :=L0.2
    LMNS_ON :=L0.3
    LMNUP :=L0.4
    LMNDN :=L0.5
    PVPER_ON:=L0.6
    CYCLE :=
    SP_INT :=1.500000e+002
    PV_IN :=1.900000e+002
    PV_PER :=
    GAIN :=
    TI :=
    DEADB_W :=
    PV_FAC :=
    PV_OFF :=
    PULSE_TM:=
    BREAK_TM:=
    MTR_TM :=
    DISV :=
    QLMNUP :="S_1_Anrieb_Ein_Auf"
    QLMNDN :="S_1_Anrieb_Ein_Zu"
    PV :=
    ER :=
    NOP 0


    fester Sollwert, fester Istwert doch er arbeitet im PLCSIM immer noch nicht, auch nciht wenn ich beim Start den Com_Rst auf High gesetzt habe.

  2. #32
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    OT: nutze [code ] und [/code ] (jeweils ohne leerzeichen)
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  3. Folgender Benutzer sagt Danke zu vierlagig für den nützlichen Beitrag:

    marlob (27.03.2008)

  4. #33
    Registriert seit
    02.02.2007
    Beiträge
    104
    Danke
    12
    Erhielt 16 Danke für 13 Beiträge

    Standard

    Solange Du keine Abtastzeit angibst wird der Basutein nicht funktioniern!


    F1:

    CYCLE TIME >= 1ms T#1s SAMPLE TIME / AbtastzeitDie Zeit zwischen den Bausteinaufrufen muß konstant sein. Der Eingang "Abtastzeit" gibt die Zeit zwischen den Bausteinaufrufen an.

  5. #34
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.728
    Danke
    729
    Erhielt 1.161 Danke für 972 Beiträge

    Standard

    Es sei noch zu erwähnen, das der SFB42 nur in der PLC existiert.
    Zum simulieren in PLCSIM also den FB42 benutzen.
    Siehe auch hier
    Welche Unterschiede gibt es zwischen S7-PLCSIM und einem "echten" Automatisierungssystem?

  6. #35
    Steve38 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.02.2008
    Beiträge
    472
    Danke
    23
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Dummy Beitrag anzeigen
    Solange Du keine Abtastzeit angibst wird der Basutein nicht funktioniern!


    F1:

    CYCLE TIME >= 1ms T#1s SAMPLE TIME / AbtastzeitDie Zeit zwischen den Bausteinaufrufen muß konstant sein. Der Eingang "Abtastzeit" gibt die Zeit zwischen den Bausteinaufrufen an.

    Ich hab doch die Standarteinstellung drin. 1s

  7. #36
    Steve38 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.02.2008
    Beiträge
    472
    Danke
    23
    Erhielt 0 Danke für 0 Beiträge

    Standard

    PLCSIM kann es nicht!
    Das sind die Bausteiner die PLCSIM verarbeiten kann:
    Systemfunktionsbausteine (SFBs) SFB0, SFB1, SFB2, SFB3, SFB4, SFB5, SFB8, SFB9, SFB12, SFB13, SFB14, SFB15, SFB16, SFB19, SFB20, SFB21, SFB22, SFB23, SFB32, SFB33, SFB34, SFB35, SFB36 und SFB37

  8. #37
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.728
    Danke
    729
    Erhielt 1.161 Danke für 972 Beiträge

    Standard

    Zitat Zitat von Steve38 Beitrag anzeigen
    PLCSIM kann es nicht!
    Das sind die Bausteiner die PLCSIM verarbeiten kann:
    Systemfunktionsbausteine (SFBs) SFB0, SFB1, SFB2, SFB3, SFB4, SFB5, SFB8, SFB9, SFB12, SFB13, SFB14, SFB15, SFB16, SFB19, SFB20, SFB21, SFB22, SFB23, SFB32, SFB33, SFB34, SFB35, SFB36 und SFB37
    Lese dazu auch meinen vorherigen Beitrag
    http://www.sps-forum.de/showpost.php...6&postcount=34

  9. #38
    Registriert seit
    02.02.2007
    Beiträge
    104
    Danke
    12
    Erhielt 16 Danke für 13 Beiträge

    Standard

    Zitat Zitat von Steve38 Beitrag anzeigen
    Ich hab doch die Standarteinstellung drin. 1s
    In deinem Code sehe ich nur, dass der Eingang des Bausteins an der Stelle nicht beschaltet ist.

    Übernimmt die Eingangsvariable dann einen Standardwert?

  10. #39
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.728
    Danke
    729
    Erhielt 1.161 Danke für 972 Beiträge

    Standard

    Da hier doch noch einige Schwierigkeiten bestehen. Im Anhang mal das Siemens Beispiel quick and dirty abgeändert auf FB42
    Mit VAT2 testen. Funktioniert auch im Simulator
    Angehängte Dateien Angehängte Dateien

  11. #40
    Steve38 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.02.2008
    Beiträge
    472
    Danke
    23
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Dummy Beitrag anzeigen
    In deinem Code sehe ich nur, dass der Eingang des Bausteins an der Stelle nicht beschaltet ist.

    Übernimmt die Eingangsvariable dann einen Standardwert?

    Ja die werden übernommen.

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •