Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 4 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 37

Thema: Datenanpassung WinCC / Siemens S7

  1. #1
    Registriert seit
    16.11.2007
    Beiträge
    93
    Danke
    67
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich bin seit einigen Tagen WinCC-Anfänger.
    Benutze die Version 6.2.

    Mir ist es nun gelungen die S7-300 an WinCC anzubinden. Das heißt: Ich kann meine binären Signale (ein und Ausgaben) im Runtime anzeigen lassen.

    Nun das Problem:
    Analoge Messwerte packe ich innerhalb der S7 in den DB1.DBW0.
    Diese lese ich dann in WinCC über eine externe Variable aus und lasse mir dieses in einem E/A-Feld anzeigen.

    Nur statt die exakten Werte 0...20mA bekomme ich folgende Zahlen:
    0mA: 32768
    1mA: 32768
    2mA: 62080
    10mA: 10372
    20mA: 27652

    Ich befürchte, dass ich diese noch irgendwie anpassen muss.
    Wenn ja, bitte helft mir!

    Wäre über eine kleine Anleitung und Erklärung sehr dankbar!!!!
    Zitieren Zitieren Datenanpassung WinCC / Siemens S7  

  2. #2
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.719
    Danke
    729
    Erhielt 1.159 Danke für 970 Beiträge

    Standard

    Analoge Messwerte bei Siemens haben einen Bereich von 0-27648 bei 0-20mA
    Willst du denn den Strom anzeigen, oder den entsprechenden Wert in bar, l, l/min oder was weiss ich.
    Die kannst du dann in der S7 mit dem FC105 skalieren

  3. #3
    Registriert seit
    16.11.2007
    Beiträge
    93
    Danke
    67
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,
    ich wollte das Ganz gerne in mA (Strom) darstellen lassen.
    Wie mache ich das denn mit diesem Baustein?

  4. #4
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.719
    Danke
    729
    Erhielt 1.159 Danke für 970 Beiträge

    Standard

    Zitat Zitat von sascha-nrw Beitrag anzeigen
    Hallo,
    ich wollte das Ganz gerne in mA (Strom) darstellen lassen.
    Wie mache ich das denn mit diesem Baustein?
    du kannst dort auch von 0-20 skalieren. lese dir mal die Hilfe vom Baustein durch (F1)

  5. #5
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.719
    Danke
    729
    Erhielt 1.159 Danke für 970 Beiträge

    Standard

    Der nette Kollege vierlagig hat auch eine FAQ dazu geschrieben
    http://www.sps-forum.de/showthread.p...ighlight=FC105

  6. #6
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    1. deine Werte deuten auf ein 4..20mA Signal hin, dafür sprechen die Werte bei 0mA und 1mA -> Unterlauf und bei 2mA Untersteuerungsbereich

    2. um die Werte als skalierte Werte darzustellen, was anderes möchtest du ja nicht, nimm diese Berechnung zur Hilfe:

    y = ( x / 27648 * 16mA ) + 4mA -> gilt für 4..20mA

    y = ( x / 27648 * 20mA ) -> gilt für 0..20mA

    wobei y der anzuzeigende Wert ist, x der Wert deines Eingangs, der allerdings ins Gleitpunktformat gewandelt sein muß.

    3. würde ich dir empfehlen die Skalierung in der Steuerung vorzunehmen ... dazu vielleicht mal das hier zu Gemüte führen
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  7. #7
    Registriert seit
    16.11.2007
    Beiträge
    93
    Danke
    67
    Erhielt 0 Danke für 0 Beiträge

    Standard

    OK - erstmal VIELEN DANK! Werde mich mal durchlesen...

  8. #8
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.719
    Danke
    729
    Erhielt 1.159 Danke für 970 Beiträge

    Standard

    Zitat Zitat von sascha-nrw Beitrag anzeigen
    OK - erstmal VIELEN DANK! Werde mich mal durchlesen...
    und kontrolliere mal deine Einstellungen in der HW-Konfig, ob du auch wirklich 0-20mA hast und nicht 4-20mA

  9. #9
    Registriert seit
    16.11.2007
    Beiträge
    93
    Danke
    67
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also könnte die ganz geschichte bei 0-20mA so aussehen?!?!:

    U M 1.0
    = L 20.0
    BLD 103
    CALL "SCALE"
    IN :=PEW272
    HI_LIM :=1.446759e-002
    LO_LIM :=0.000000e+000
    BIPOLAR:=L20.0
    RET_VAL:=MW8
    OUT :=MD10
    NOP 0


    L MD 10
    AUF DB 1
    T DBW 0
    T PAW 256
    NOP 0


    Danke für den Tipp, sie HW-Konfig muss ich umstellen.
    Dann klappt es bestimmt besser ....

  10. #10
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.719
    Danke
    729
    Erhielt 1.159 Danke für 970 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Auf den ersten Blick würde ich mal sagen, das HI_LIM verkehrt ist,
    Da würde sich eine 20 gut machen

Ähnliche Themen

  1. Siemens Panel mit Beckhoff in WinCC - Welcher CPU Typ
    Von Gerri im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 12.07.2009, 16:13
  2. WinCC flex Touch Displays nur von Siemens???
    Von franzlurch im Forum HMI
    Antworten: 16
    Letzter Beitrag: 29.10.2008, 20:23
  3. Alternative zu WinCC für Siemens OP73
    Von neibeck im Forum HMI
    Antworten: 8
    Letzter Beitrag: 05.12.2006, 11:23
  4. WinCC flexible und TP270 (siemens)
    Von DerDBK im Forum HMI
    Antworten: 9
    Letzter Beitrag: 26.02.2006, 19:52
  5. Siemens TD200 mit WinCC ersetzen
    Von buffi4711 im Forum HMI
    Antworten: 0
    Letzter Beitrag: 19.08.2005, 18:51

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •