Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Referenzdaten bei S7

  1. #1
    Registriert seit
    22.01.2008
    Ort
    Allgäu, da wo die Kühe schöner sind als die Mädels
    Beiträge
    1.774
    Danke
    50
    Erhielt 729 Danke für 434 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    Ich habe mein S7 auf V5.4 SP3 HF1 hochgezogen.

    Seid dem meine ich folgende Änderung beobachtet zu haben.

    In ein bestehendes Projekt wurde ein neuer Baustein kopiert.
    Danach GeheZurVerwendungsstelle aufgerufen.
    Es kommt die Frage: Sollen die Referenzdaten aktuallisiert werden?
    Wenn auf Ja geklickt wird, werden auch die SCL Quellen neu übersetzt.
    Ich meine, dass dies bei der alten Version noch nicht der Fall war.
    Hat jemand von Euch dies auch schon beobachtet?

    Gruss
    Audsuperuser
    Gruss Audsuperuser

    Herzlich Willkommen im Chat:
    SPS-Forum Chat (Mibbit) | SPS-Forum Chat (MIRC)
    Zitieren Zitieren Referenzdaten bei S7  

  2. #2
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    ich glaub nicht, dass das erst seit gestern ist, in der step7 5.3 hilfe z.b. hab ich das hier gefunden:

    Zur Aktualisierung der Referenzdaten werden die Bausteine neu übersetzt. Dabei wird für jeden Baustein der passende Compiler aufgerufen.
    ...vielleicht hattest du vorher nur keine scl-bausteine drin

    [edit]übrigens ruft er den SCL-Compiler nur auf, wenn die entsprechende Quelle noch vorhanden ist, löscht du sie aus dem Quellenordner is alles beim alten ... aber ohne quelle macht SCL ja keinen sinn ... [/edit]
    Geändert von vierlagig (24.04.2008 um 12:03 Uhr)
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  3. #3
    Avatar von AUDSUPERUSER
    AUDSUPERUSER ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    22.01.2008
    Ort
    Allgäu, da wo die Kühe schöner sind als die Mädels
    Beiträge
    1.774
    Danke
    50
    Erhielt 729 Danke für 434 Beiträge

    Standard

    ...vielleicht hattest du vorher nur keine scl-bausteine drin

    Ganz so einfach ist es sicher nicht. Ich hatte eine falsche Quelle im Projekt (kann jedem mal passieren).
    Jahre lang gab das kein Problem. Nun wurde die Quelle übersetzt, und AG und Programm waren unterschiedlich.
    Daher meine Vermutung mit der neuen S7 Version

    [edit]übrigens ruft er den SCL-Compiler nur auf, wenn die entsprechende Quelle noch vorhanden ist, löscht du sie aus dem Quellenordner is alles beim alten ... aber ohne quelle macht SCL ja keinen sinn ... [/edit][/quote]

    Das war mir auch bekannt, und Du hast recht, ohne Quelle hat SCL keinen Sinn
    Gruss
    Audsuperuser
    Gruss Audsuperuser

    Herzlich Willkommen im Chat:
    SPS-Forum Chat (Mibbit) | SPS-Forum Chat (MIRC)

  4. #4
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    beobachte einen unterschied zwischen "generieren" und "aktualisieren" ... beim aktualisieren wurde nicht neu übersetzt.
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  5. #5
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    nochmal zusammengefasst:

    - beim generieren wird übersetzt, wenn die quelle vorhanden ist
    - beim aktualisieren wird nicht übersetzt, auch dann nicht, wenn die quelle geändert wurde (hätte ja sein können, das wenigstens die zeitstempel abgeglichen werden)
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  6. #6
    Registriert seit
    24.11.2006
    Ort
    57072 Siegen
    Beiträge
    466
    Danke
    59
    Erhielt 121 Danke für 109 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von AUDSUPERUSER Beitrag anzeigen

    ...
    Jahre lang gab das kein Problem. Nun wurde die Quelle übersetzt, und AG und Programm waren unterschiedlich.
    Daher meine Vermutung mit der neuen S7 Version

    Gruss
    Audsuperuser
    Hallo ASU,

    den Effekt habe ich auch gehabt,
    ich glaube bei der Installation des SP2 zu S7 V5.4.

    Die SCL - Quellen im Programm stimmten mit den Bausteinen überein.
    Dennoch forderte S7 bei Anzeige der Referenzdaten die Neuübersetzung
    der Quellen an.

    Nach der Übersetzung konnte ich feststellen, das die Bausteine, bis auf den
    aktualisierten Zeitstempel, unverändert waren.

    Möglicherweise werden die Referenzdaten von neueren S7 Versionen mit
    zusätzlichen Infos versehen, so dass "alte" Bausteine, welche über die
    Infos noch nicht verfügen, angemeckert werden.

    Ach ja, ich habe in SCL unter "Einstellungen" den Punkt
    "Referenzdaten erzeugen" immer angewählt.

    CU,

    Jürgen.


    .

    Zur Beachtung:
    Ich distanziere mich ausdrücklich von allen Aussagen in diesem Forum
    welche nicht von mir stammen und mache mir deren Inhalte nicht zu eigen.


    www.ibn-service.com

  7. Folgender Benutzer sagt Danke zu IBN-Service für den nützlichen Beitrag:

    AUDSUPERUSER (26.04.2008)

Ähnliche Themen

  1. Bug in Strukturanzeige Referenzdaten?
    Von Toki0604 im Forum Simatic
    Antworten: 20
    Letzter Beitrag: 06.02.2011, 17:45
  2. Referenzdaten Online???????????????
    Von hbedir im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 15.01.2011, 13:23
  3. Referenzdaten sind weg
    Von blue dun im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 22.09.2010, 23:08
  4. Referenzdaten Filtern
    Von Thomas R im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 28.01.2010, 09:29
  5. SCL-Referenzdaten
    Von Onkel Dagobert im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 26.03.2004, 00:08

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •