Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 26

Thema: Funktionsaufruf aus OB 35 ... )-:

  1. #1
    Registriert seit
    29.02.2008
    Beiträge
    58
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi all,

    habe ne funktion und einen PID Regler. Die Funktion skaliert einfach den eingangwert und gibt sie dem PID Regler.

    Beide Funktionen habe ich im OB 35 programmiert!.

    wenn ich aber die SPS starte tut sich hier gar nix... ausser wenn ich die Funktion in den OB1 schreibe, dann tut sich hier was.

    jemand ne idee??

    oder habe ich was elementares nicht verstanden?
    Zitieren Zitieren Funktionsaufruf aus OB 35 ... )-:  

  2. #2
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.716
    Danke
    398
    Erhielt 2.399 Danke für 1.999 Beiträge

    Standard

    Wie hast du das Aufruf-Intervall für den OB35 in der HW-Konfig eingestellt ?

  3. #3
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    220
    Erhielt 233 Danke für 204 Beiträge

    Standard

    Zeig doch mal beide Codes
    Karl

  4. #4
    Andi_W ist offline Benutzer
    Themenstarter
    Registriert seit
    29.02.2008
    Beiträge
    58
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    im OB35 habe ich 50ms eingestellt


    der Code ist jetzt auf meinem anderen PC (habe Vista...)

    habs grad ausprobiert..

    egal was ich im OB35 tue auch nur wenn es einen Ausgang setzen ist: es tut sich nix

  5. #5
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.716
    Danke
    398
    Erhielt 2.399 Danke für 1.999 Beiträge

    Standard

    Der OB 35 wird so durchlaufen wie der OB1, nur eben Zeitraster-gesteuert. Wenn dein Programm also im OB1 funktioniert, dann sollte es das auch im OB35 - es sein denn der OB1 macht Sachen zunichte, die du im OB35 auslösen möchtest ...

    Erzähl mal was zur Hardware ... und Software. Richtige CPU oder PLCSim ?

    Ansonsten siehe Beitrag von Gravieren ...

  6. #6
    Andi_W ist offline Benutzer
    Themenstarter
    Registriert seit
    29.02.2008
    Beiträge
    58
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi Hardware CPU314IFM+ SM332
    Panel OP270

    Programm eigentlich ganz einfach:

    im OB1 wird nur eine Funktion aufgerufen, die boolsche Verknüpfungen beinhaltet.

    im OB35 sind 3 PID Regler drin die jeweils über einen AI das Ist signal bekommen und hier anfangs noch sklaiert werden. Der Sollwert kommt vom Panel und der Ausgang des wird jeweils auf einen PAWxxx der SM332 verschalten

    thats it

    ???

  7. #7
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.716
    Danke
    398
    Erhielt 2.399 Danke für 1.999 Beiträge

    Standard

    Zitat Zitat von Larry Laffer Beitrag anzeigen
    ... Ansonsten siehe Beitrag von Gravieren ...
    ...?

  8. #8
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.716
    Danke
    398
    Erhielt 2.399 Danke für 1.999 Beiträge

    Standard

    Ach ja, was sagt die Status-Anzeige im OB35 ?

    Laß doch da mal ein MW hochzählen und sieh es dir in einer VAT an ...

  9. #9
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Der Larry und seine Geduld.

    Frag doch nicht nach dem Merkerwort,
    vieleicht hängt bei seinem OB ja ein blauer Faden raus

  10. #10
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.716
    Danke
    398
    Erhielt 2.399 Danke für 1.999 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ... da fällt mir im Augenblick kein Spruch drauf ein ...

    Aber - das mit dem blauen Band ist Klasse ...!

Ähnliche Themen

  1. Hilfe Funktionsaufruf IF Funktion !!
    Von elektrowurm im Forum CODESYS und IEC61131
    Antworten: 8
    Letzter Beitrag: 04.11.2011, 13:16
  2. Funktionsaufruf in SCL
    Von petzi im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 30.04.2009, 16:29
  3. Funktionsaufruf in ST
    Von Vogei im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 01.09.2008, 18:19
  4. Funktionsaufruf mit Aktualparamerern
    Von manas im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 06.03.2008, 13:41
  5. Funktionsaufruf funktioniert nicht - SCL
    Von amateur im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 16.10.2007, 13:49

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •