Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 21

Thema: Aktualisierung bei TD200C

  1. #11
    Registriert seit
    05.05.2008
    Ort
    Österreich
    Beiträge
    74
    Danke
    9
    Erhielt 8 Danke für 8 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Prof

    Wo und wie hast du "CALL TD_CTRL_xxx" aufgerufen?
    Gruß OB1

  2. #12
    Avatar von Prof
    Prof ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.01.2006
    Beiträge
    20
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    im OB1 rufe ich immer "TD_CTRL_xx" und auch mein Unterprog mit dem Einlesen auf.

  3. #13
    Registriert seit
    05.05.2008
    Ort
    Österreich
    Beiträge
    74
    Danke
    9
    Erhielt 8 Danke für 8 Beiträge

    Standard

    Hallo Prof

    Hast du deine Werte von VB1297 - VB1303 im Tabellenstatus schon mal beobachtet, ob auch drinnen steht, was du nach dem schieben willst?
    Gruß OB1

  4. #14
    Avatar von Prof
    Prof ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.01.2006
    Beiträge
    20
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    also mit STR_CPY sieht es bei mir auch nicht besser aus
    Ich hab das mal so getestet :
    LD E3.0
    SCPY "OK", VB1297

    Und es erscheint ... nichts auf der Anzeige

  5. #15
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Anzeigen von dynamischen Meldetexten auf dem TD200

    mit beispiel ... vielleicht hilft es
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  6. #16
    Avatar von Prof
    Prof ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.01.2006
    Beiträge
    20
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke, hat leider nicht geholfen. Ist das gleiche Bsp. wie in den Beispielen unter S7 Documents , womit ich mich auch schon rumgeschlagen habe.
    Das Einschreiben an sich ist ja auch kein Problem, aber halt nur einmal, wenn sich mein "Abhängigkeitsbit" ändert passiert halt nichts mehr. Hab auch schon versucht das "Reset Bit" TD_Reset_0 zyklisch zu setzen, mit dem gleichen Erfolg.

  7. #17
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von OB1 Beitrag anzeigen
    Hallo Prof

    Hast du deine Werte von VB1297 - VB1303 im Tabellenstatus schon mal beobachtet, ob auch drinnen steht, was du nach dem schieben willst?
    hast du da schon mal nachgeschaut?
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  8. #18
    Avatar von Prof
    Prof ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.01.2006
    Beiträge
    20
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    ja hab ich .Da scheint es zu passen. Die entsprechenden ASCII-Zeichen werden auf die Bits geschrieben.

    Un nu?

  9. #19
    Registriert seit
    05.05.2008
    Ort
    Österreich
    Beiträge
    74
    Danke
    9
    Erhielt 8 Danke für 8 Beiträge

    Standard

    Hab mir mein Programm noch mal angeschaut und bin draufgekommen das ich vor 2 Jahren mit meiner Laufzeile auch Probleme hatte.
    Ich habe dann einfach fünf Datenfelder eingebaut. (Siehe Anhang)
    Angehängte Grafiken Angehängte Grafiken
    • Dateityp: jpg 2.JPG (55,5 KB, 13x aufgerufen)
    Gruß OB1

  10. #20
    Avatar von Prof
    Prof ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.01.2006
    Beiträge
    20
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Daumen hoch


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von vierlagig Beitrag anzeigen
    probier es mal bitte mit STR_CPY ... manchmal is komisch
    stimmt irgendwie...
    kaum macht man es richtig schon funzt es!
    Zielsystemdaten auf "VB" und Datenformat auf "Zeichenkette".
    Danke an Euch

Ähnliche Themen

  1. Aktualisierung Hardwarekatalog
    Von Steffen33 im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 13.04.2012, 09:12
  2. schnelle SPS-Bus-Aktualisierung?
    Von daduda im Forum Simatic
    Antworten: 25
    Letzter Beitrag: 03.09.2010, 11:00
  3. Antworten: 3
    Letzter Beitrag: 02.11.2009, 13:45
  4. B&R-X20 X2X IO-Aktualisierung
    Von Franschitz im Forum Sonstige Steuerungen
    Antworten: 5
    Letzter Beitrag: 07.10.2008, 23:56
  5. Aktualisierung Meldetexte TP 070
    Von Scroll im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 30.11.2004, 15:42

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •