Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 19 von 19

Thema: LED Anzeige Stellplatz nicht belegt.

  1. #11
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.797
    Danke
    398
    Erhielt 2.417 Danke für 2.013 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von godi Beitrag anzeigen
    Was willst du denn da indirekt Adressieren?
    Die Frage hätte ich jetzt von dir nicht erwartet ...
    Ich würde den Codierschalter nehmen um mit ihm die Speicheradresse zu be-/errechnen, die mit den beiden Schaltern gesetzt/rückgesetzt werden soll un deren Zustand über eine Leuchte abgefragt wird. So würde es als "Hausaufgabe" auch Sinn machen ...

    Gruß
    LL

  2. #12
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.797
    Danke
    398
    Erhielt 2.417 Danke für 2.013 Beiträge

    Standard

    @MW: zu spät ...

  3. #13
    Registriert seit
    27.11.2005
    Ort
    im Osten
    Beiträge
    1.183
    Danke
    141
    Erhielt 271 Danke für 248 Beiträge

    Standard

    Zitat Zitat von godi Beitrag anzeigen
    @MW:
    Bist du dir sicher das er nur 4 Stellplätze hat? könnten auch 16 sein!
    Geht doch auch mit 16


    EDIT: schonwieder zuspät *heul*
    Geändert von MW (11.05.2008 um 18:27 Uhr)

  4. #14
    Registriert seit
    03.01.2006
    Ort
    Im sonnigen Süden von Österreich!
    Beiträge
    1.377
    Danke
    227
    Erhielt 183 Danke für 168 Beiträge

    Standard

    Zitat Zitat von Larry Laffer Beitrag anzeigen
    Die Frage hätte ich jetzt von dir nicht erwartet ...
    Ich würde den Codierschalter nehmen um mit ihm die Speicheradresse zu be-/errechnen, die mit den beiden Schaltern gesetzt/rückgesetzt werden soll un deren Zustand über eine Leuchte abgefragt wird. So würde es als "Hausaufgabe" auch Sinn machen ...

    Gruß
    LL
    Wie MW schon schrieb:
    Nicht gleich so kompliziert. Ich meine indirekt kann ich alles Adressieren aber ob es für einen Anfänger / Betriebselektriker dann auch noch leicht zum nachvollziehen ist ist eine andere Frage...

  5. #15
    Nero23 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    05.02.2008
    Ort
    Berlin
    Beiträge
    13
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    na klar hat der schalter 0-15 aber ich benötige nur 1-11

    Naja ich hatte mir ja auch gedacht das wenn der merker nicht mehr gesetzt ist die LED aus geht aber das ist nicht der fall also bzw. die LED bleibt an wenn ich am 4bit schalter drehe. Der neue Zustand wird nicht an die LED weitergegeben. Wenn stellplatz 1 die led setzt und ich auf 5 weiter drehe hätte ich gedacht die led geht aus aber das amcht sie nicht.

  6. #16
    Registriert seit
    03.01.2006
    Ort
    Im sonnigen Süden von Österreich!
    Beiträge
    1.377
    Danke
    227
    Erhielt 183 Danke für 168 Beiträge

    Standard

    Dann zeig uns mal deinen Code dann können wir dir sagen an was es liegt..

  7. #17
    Nero23 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    05.02.2008
    Ort
    Berlin
    Beiträge
    13
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hab den fehler gefunden.

    ich muß die zahl + merker besetzt verundet auf den Ausgang der LED geben jetzt geht es.

  8. #18
    Registriert seit
    03.01.2006
    Ort
    Im sonnigen Süden von Österreich!
    Beiträge
    1.377
    Danke
    227
    Erhielt 183 Danke für 168 Beiträge

    Standard

    Zitat Zitat von Nero23 Beitrag anzeigen
    Hab den fehler gefunden.

    ich muß die zahl + merker besetzt verundet auf den Ausgang der LED geben jetzt geht es.
    Jo wenn du jetzt den Beispielcode von MW und/oder von mir anschaust dann wirst du bemerken das wir das "verundet" haben...



    godi

  9. #19
    Nero23 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    05.02.2008
    Ort
    Berlin
    Beiträge
    13
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    tja manchmal sieht man den Wald vor lauter Bäumen nicht
    Aber trotzdem danke für die Antworten.

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 26.01.2011, 16:45
  2. CP5511 belegt
    Von PBO-WE im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 29.12.2008, 22:10
  3. Alle Steckplätze belegt ?
    Von noeppkes im Forum Simatic
    Antworten: 19
    Letzter Beitrag: 01.08.2008, 15:50
  4. HW-Konfig PEB122 belegt?!?
    Von eYe im Forum Simatic
    Antworten: 17
    Letzter Beitrag: 16.11.2007, 20:10
  5. das triggerereignis ist belegt....
    Von mertens2 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 04.12.2006, 20:55

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •