Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Ethernet Kommunikation mit ISO Protokoll

  1. #1
    Registriert seit
    14.08.2006
    Beiträge
    52
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich habe eine S7-414-2DP die mit zwei S7-417-4-H kommunizieren soll.

    Als CP wird jeweils ein CP443-1 verwendet.

    Es soll das ISO-Protokoll verwendet. Als Verwendungstyp soll eine S7-Verbindung projektiert sein.

    Soweit so gut. Nun mein Problem:

    Die Verbindung baut sich nicht auf. Auch nach separatem Übertragen der Verbindungsdaten in NetPro (Zielsystem-->Laden iim aktuellen Projekt-->Verbindungen und Netzübergänge) baut sich die Verbindung nicht auf.

    Erst wenn ich von der SS7-400-H Seite aus die Verbindungsdaten auf den CP443-1 übertrage baut sich die Verbindung auf.

    Nach einem einem Neustart der CPU (nach Urlöschen und ladenn von EPROM) funzt die Verbindung aber nicht.
    Wenn ich die Systemdaten nach dem Übertragen von dder S7-400-H aus einlese und offline abspeicher funzt es zwar, aber meine Systemdaten sind auch unterschhiedlich.

    Hat jemand ne Idee warum sich die Verbindung nicht automatisch aufbaut?

    Anbeei noch ein paar Screenshots.

    Gruß Mütze
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren Ethernet Kommunikation mit ISO Protokoll  

  2. #2
    Registriert seit
    14.05.2008
    Beiträge
    23
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    hallo,

    was willst du denn am ende machen, bzw. mit welchen bausteinen willst du die kommunikation einrichten?

    hast du schon mal versucht, kreuzweise mit SEND und RECEIVE bausteinen daten auch konkret auszutauschen (über die Verbindungs-ID, wie gesagt immer kreuzweise - also SEND sollte auch in der anderen CPU einen entsprechenden RECEIVE haben)

    An welcher Stelle (welche CPU lädst du da gerade) kommt der unterschied in den systemdaten, d.h. auch nach gesamtübersetzen NetPro und laden der verbindungen? da sollte es eigentlich nicht passieren. welche step7 version hast du?

  3. #3
    Mütze ist offline Benutzer
    Themenstarter
    Registriert seit
    14.08.2006
    Beiträge
    52
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Morgen,

    ich stelle in der S7-414-2DP zei Datenbausteine zur Verfügungg. Einer zum Datenaustausch in Richtung Leittechnik und einen um Daten von der Leittechnik zu empfangen.

    Die Kommunikation soll rein von der H-Steuerung aus geführt werden mit Put und Get Bausteinen.

    Das Problem ist, das wenn ich NetPro von der S7-414-2DP übertrage die Verbindungen nicht aaufgebaut werden. Wenn ich aber dem CP auf der Seite der der S7-414-2DP von der H-Steuerung aus die Verbindungen rüberlade, funktioniert es.
    Wenn ich dann aber die online Systemdaten in die offline Systemdaten zurücklese sind die Systemdaten trottzdem unterschiedlich.


    Es gibt beim ISO Prootokoll auch noch diee Möglichkeit unter OObjekteigenschaften das Häckchen bei "Projektierrungsdaten in der CPU speichern" wegzunehmen, hat aber auch nicht zum Ziel geführtt. Die Verbindung baut sich erst auf, wenn ich die Verbindungen von der S7-H Steuerung aus übertrage.

    Kann das etwas mit dem aktiven Verbindungsaufbau zutun haben? Was bedeutet dieser eigentlich ganz genau? Was ist wenn der passive Partner zu anfang gar nicht da iist und erst später eingeschaltet wird? Wie erkennt das der "MAster" undd kan dieser die VErbindung auch nachträglich aufbauen?

    Gruß

    Mütze


    PS:

    Achso, ich benutze Step7 V5.3 +SP3

  4. #4
    Registriert seit
    10.03.2008
    Beiträge
    89
    Danke
    1
    Erhielt 19 Danke für 18 Beiträge

    Standard

    Hallo Mütze.
    Ich möchte dir einige Hinweise geben.
    Die gesamte Hardwareprokektierung in einem Projekt zu machen (alle drei Steuerungen). Weiter ist der aktive Partner der CP, der die Verbindung aktiv aufbauen soll (anrufen). Die "nicht aktiven Parner" warten quasi auf einen Anruf.
    Weiter habe ich die Erfahrung gemacht, das es nach der Verbindungsprojektierung im Netpro sinnvoll ist bei allen an einer Verbindung beteiligten Partner die Systemdaten komplett neu zu übertragen. Die Parametrierdaten des CP lasse ich immer auf dwer CPU hinterlegt, das macht den Austausch gegebenfalls einfacher. Sollte die Verbindung dann nicht aufgebaut werden kann mann in der Baugruppendiagnose des CP in der HW_Konfig einen ersten Überblick verschaffen. Weiter kann mann aus dem Status, den die Kommunikationsbausteine ausgeben auf weitere Fehlerquellen schließen.
    MfG Fritze

  5. #5
    Mütze ist offline Benutzer
    Themenstarter
    Registriert seit
    14.08.2006
    Beiträge
    52
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo,

    Die gesamte Hardwareprokektierung in einem Projekt zu machen (alle drei Steuerungen).
    ?? Hab ich ja gemacht, nur kann ich ja nicht auf H-CPUs zugreifen, da die ja von PCS7 aus projektiert werden. Ich hab nur meine S7-414-2DP.

    Weiter ist der aktive Partner der CP, der die Verbindung aktiv aufbauen soll (anrufen). Die "nicht aktiven Parner" warten quasi auf einen Anruf.
    Es ist doch auf beiden Seiten ein CP. Ich kann ja meiner S7 Steurung in den Verbindungsdaten ja nur sagen dass sie nicht aktiv ist. das hat doch mit dem CP nix zu tun, oder?
    Eine Seite muss ja passiv sein.

    Die Parametrierdaten des CP lasse ich immer auf dwer CPU hinterlegt, das macht den Austausch gegebenfalls einfacher.
    Soweit so gut. Mein Problem ist ja auch lediglich, dass ich nachdem meine CPU sich die Daten neu vom Eprom holt, dass die Verbindungen jedesmal nicht funzen.

    Weiter kann mann aus dem Status, den die Kommunikationsbausteine ausgeben auf weitere Fehlerquellen schließen.
    Die KommBausteine auf seiten der PCS7 sagen lediglich Fehler. Die Verbindungen sind auch auf beiden Seiten (PCS7 und SPS) nicht aktiv in der online Ansicht in NetPro (Verbindung wird aufgebaut steht da).

    Ich hab sowas schon übers IP Protokoll gemacht, das ging super. Hier wünscht der Kunde aber expliziet das ISO Protokoll, damit es keinen IP_Konflikt geben kann.

    Oder darf man bei ner Kommunikation mit einer H_Steuerung keine S7-Verbindung wählen sondern muss eine S7-Verbindung hochverfügbar nehmen?
    Gruß Mütze

  6. #6
    Registriert seit
    14.05.2008
    Beiträge
    23
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hi,

    das heißt also, die H-CPU's werden von PCS 7 aus parametriert und deine CPU in normalem Step7? Das ist an sich schon sehr problematisch.

    Hast du schon mal dran gedacht, dass über eine unspezifierte Verbindung zu projektieren? Bitte auch beachten, dass das ISO-Protokoll nicht ohne weiteres Routingfähig ist (soweit ich weiß), also was noch zwischen deinen CPU'n an Netzwerk steckt.

    Übrigens würde ich bei Kommunikation mit H-Systemen als AS/AS Komm nicht einfach so arbeiten, es gibt da spezielle Bausteine von Siemens (für PCS 7), die auch nicht billig sind, weil man da sehr viel beachten muss.

  7. #7
    Mütze ist offline Benutzer
    Themenstarter
    Registriert seit
    14.08.2006
    Beiträge
    52
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    das heißt also, die H-CPU's werden von PCS 7 aus parametriert und deine CPU in normalem Step7? Das ist an sich schon sehr problematisch.
    Das ist richtig. Wieso problematisch? Ist schon oft im Einsatz.

    Hast du schon mal dran gedacht, dass über eine unspezifierte Verbindung zu projektieren?
    Funzt leider nicht. Hatte ich auch für einfacher gehalten da ich dann die HW-Konfig von der H-CPU nicht bei mir im Projekt brauche.

    Bitte auch beachten, dass das ISO-Protokoll nicht ohne weiteres Routingfähig ist
    Erklärt das das Phänomen, dass es funzt wenn ich die Verbindungen von PCS7 aus auf den CP übertrage?

    Übrigens würde ich bei Kommunikation mit H-Systemen als AS/AS Komm nicht einfach so arbeiten, es gibt da spezielle Bausteine von Siemens (für PCS 7), die auch nicht billig sind, weil man da sehr viel beachten muss.
    Hab leider nicht viel Ahnung von PCS7. Bislang hats immer hingehauen, wenn ich einfach eine "andere Station" in NetPro eingefügt habe. Den Rest hat imemr die Leittechnik selbständig erledigt. Nun wollen die Leittechniker aber ne S7-Verbindung (mit ID) haben. Dachte dass das genau so geht.

    Also die Verbindung an sich bekomme ich zum Laufen, nur nach einem Anlauf vom Eprom funzen die Verbindunegn nicht, ohne dass ich sie vomPCS7 aus neu übertrage.

    Gruß Mütze

  8. #8
    Registriert seit
    10.03.2008
    Beiträge
    89
    Danke
    1
    Erhielt 19 Danke für 18 Beiträge

    Standard

    Hallo Mütze,
    leider kenne ich mich mit PCS7 nicht so gut aus aber was meist du damit wenn du sagst, das du die Verbindung vom PCS7 auf den CP überträgst ?
    Ich vermote allerdings das dein Projekt nicht komplett mit dem Programm auf deinem EPROM übereinstimmt aus dem du wie du schreibst beim Neustart das Programm ja lädst.
    MfG Fritze.

  9. #9
    Registriert seit
    14.05.2008
    Beiträge
    23
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ich vermute das auch, kann ja auch sein, dass vom PCS 7 andere Bausteinversionen kommen als vom Step 7 (die PCS 7 Version ist hier noch unbekannt..)

    Anders kann ichs mir zumindest so nicht erklären.

Ähnliche Themen

  1. Kommunikation MFR<->SPS Logfile TIM Protokoll
    Von jackjones im Forum Programmierstrategien
    Antworten: 3
    Letzter Beitrag: 18.11.2014, 15:43
  2. Ethernet Kommunikation mit PC
    Von SIX im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 21.07.2011, 19:03
  3. Ethernet kommunikation
    Von trappe2222 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 14.12.2010, 14:01
  4. S7 über Ethernet an PC (spezielles Protokoll)
    Von Hocheck im Forum Feldbusse
    Antworten: 24
    Letzter Beitrag: 09.03.2010, 13:59
  5. PRIM Ethernet - Frei definierbares Protokoll für Ethernet TCP/IP
    Von whatisnesps im Forum Werbung und Produktneuheiten
    Antworten: 0
    Letzter Beitrag: 20.08.2008, 13:51

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •