Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 21

Thema: Sporadischer Absturz nach CPU- wechsel

  1. #11
    Registriert seit
    03.01.2006
    Ort
    Im sonnigen Süden von Österreich!
    Beiträge
    1.377
    Danke
    227
    Erhielt 183 Danke für 168 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Aboden Beitrag anzeigen
    Hi
    also wie in meiner Anfangsfrage festgehalten, kommt der Fehler nur Ab und zu vor wenn mann auf eine OP17 Taste betätigt.
    Passiert das bei allen Tasten?
    Wenn es nur bei der einen Auftritt dann sollte mal nachgeforscht werden was die Taste bewirkt. Vielleicht löst sie ja eine Rechenoperation aus die sich bei der CPU mit 4 Akkus anders verhält als mit 2 Akkus.

    Stell mal den Diagnosepuffer von der CPU hier herein.

    godi

  2. Folgender Benutzer sagt Danke zu godi für den nützlichen Beitrag:

    Aboden (17.05.2008)

  3. #12
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Zitat Zitat von Aboden Beitrag anzeigen
    Hi
    also wie in meiner Anfangsfrage festgehalten, kommt der Fehler nur Ab und zu vor wenn mann auf eine OP17 Taste betätigt.
    Mehr Infos bitte.
    Was löst diese Taste aus? Mit welcher Variable ist sie verbunden?
    Was löst das in der CPU für eine Funktion aus? Du schreibst von "Tasten".
    Heisst das, das es egal ist welche Taste? Ist es eine bestimmte Taste? Sind es mehrere Tasten, die alle ähnliche/gleiche Funktionen aufrufen?
    Welche von den vorher vorgestellten Vorschlägen, hast du schon probiert?

  4. Folgender Benutzer sagt Danke zu marlob für den nützlichen Beitrag:

    Aboden (17.05.2008)

  5. #13
    Registriert seit
    09.05.2006
    Beiträge
    94
    Danke
    19
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Ich hatte vor Jahren das gleiche Problem, dass nach dem Wechsel von 315 auf 318 die
    318 sporadisch abgestürzt ist. Bei mir war der Fehler in der
    HW-Konfig, dass unter PB-Betriebsarten der PD-Mode als Default-Wert auf 'DPV1' gestellt war. Nach dem umstellen auf 'S7-Kompatibel' lief die Anlage ohne Probleme.

  6. Folgender Benutzer sagt Danke zu Vbxler für den nützlichen Beitrag:

    Aboden (17.05.2008)

  7. #14
    Registriert seit
    02.04.2006
    Ort
    nähe Muc
    Beiträge
    2.787
    Danke
    115
    Erhielt 126 Danke für 107 Beiträge

    Standard

    Zitat Zitat von godi Beitrag anzeigen
    Passiert das bei allen Tasten?
    Wenn es nur bei der einen Auftritt dann sollte mal nachgeforscht werden was die Taste bewirkt. Vielleicht löst sie ja eine Rechenoperation aus die sich bei der CPU mit 4 Akkus anders verhält als mit 2 Akkus.

    Stell mal den Diagnosepuffer von der CPU hier herein.

    godi
    Hi Godi,

    die Akkus dürften das nicht sein. Das würd der Logik wiederpsrechen.

    Hoffe ist hilfreich.

    Grüsse
    ___________________________________________





    Sende eine SMS mit dem Stichwort "Feuer" an die 112 und innerhalb von 10 Minuten steht ein roter Partybus mit derbem Sound vor deiner Tür.


    AGB: Wer Rechtschreibfehler findet darf diese behalten. Bitte meine in eile gefertigten, selten anfallenden Vertipsler zu entschuldigen.

  8. Folgender Benutzer sagt Danke zu maxi für den nützlichen Beitrag:

    Aboden (17.05.2008)

  9. #15
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    220
    Erhielt 233 Danke für 204 Beiträge

    Standard

    Die CPU315-2DP hast du ja noch.

    Vergleiche doch mal alle Hardwareeinstellungen der 315er mit der 318er.

    Vornehmlich die Einstellungen für den DP.

    Ich denke, einfach CPU-tauschen und gut ist geht nicht.

    Die Einstellungen der 315er werden nach meiner Meinung NICHT auf die 318er übertragen.


    Frage: Wie hast du die Einstellungen der Hardware im Projekt übernommen/überprüft ?
    Karl

  10. Folgender Benutzer sagt Danke zu gravieren für den nützlichen Beitrag:

    Aboden (17.05.2008)

  11. #16
    Aboden ist offline Benutzer
    Themenstarter
    Registriert seit
    08.11.2006
    Beiträge
    76
    Danke
    27
    Erhielt 0 Danke für 0 Beiträge

    Standard

    erst mal vielen Dank für eure rege Beteiligung!

    Also, Einstellungen hab ich so wie 315 übernommen, stimmen auch soweit überein.

    OP17 Tasten wenn es sporadisch zum Absturz kommt sind Systemtasten wie zB. gelbe Taste oder Aufruf Störmeldespeicher. Diese sind im Programm nicht verwertet. Bei den anderen Tasten ist es noch nicht vorgekommen. Wenn man die genannten Tasten nicht betätigt läuft die Anlage problenlos bzw. die CPU stürzt nicht ab

    Komisch ist nur dass er dann im Diagnosespeicher den Moby FC44 anmeckert und zwar mit Zugriffsfehler aller Adressen ab 272 lesend und schreibend.

    Ich habe den FC44 für ASM450 V2.0 byteweise im Einsatz. Vieleicht benötige eine höhere Version (zur Zeit V2.4 glaube ich)

    Eine Einstellung so wie Vbxler beschrieben mit DPV1 finde ich nicht.
    Es handelt sich um eine CPU318-2 mit DP 6ES7 318-2AJ00-0AB0 V1.1

    Auch ja, es sind 2x OP17 Pulte die am DP Strang hängen bei den es vorkommt.
    Geändert von Aboden (17.05.2008 um 15:42 Uhr)
    Zitieren Zitieren Antworten zu euren Fragen  

  12. #17
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    Sind bei den OP17 die Hardware-Keys angelegt, vielleicht ist da etwas im Argen. Das kann aber nur sein, wenn die OP in der Hardwarekonfig eingetragen sind. Du könntest auch mal eins per MPI an die CPU hängen und prüfen, ob es dann geht.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  13. Folgender Benutzer sagt Danke zu Ralle für den nützlichen Beitrag:

    Aboden (17.05.2008)

  14. #18
    Aboden ist offline Benutzer
    Themenstarter
    Registriert seit
    08.11.2006
    Beiträge
    76
    Danke
    27
    Erhielt 0 Danke für 0 Beiträge

    Standard

    OP`s sind nicht in der HW-Konfig

  15. #19
    Aboden ist offline Benutzer
    Themenstarter
    Registriert seit
    08.11.2006
    Beiträge
    76
    Danke
    27
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo
    nachdem ich den aktuellen FC44 eingespielt hatte kam der Absturz nicht mehr vor!
    Zitieren Zitieren Lösung  

  16. #20
    Registriert seit
    16.12.2004
    Ort
    Schleswig-Holstein
    Beiträge
    400
    Danke
    21
    Erhielt 24 Danke für 21 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Denk daran, dass es ein Unterschied gibt zwischen 300er CPUs und 400er CPUs (was der 318 eigentlich ist) was die Sprungbefehle angeht. Im 300er wird der VKE-Zustand "mitgenommen" beim Sprung, beim 400er wird der VKE-Zustand zurückgesetzt.

    Kann es sein, dass wenn Du eine OP-Taste druckst, dass Du dann im Programm ein Sprung direkt in einer Logik-Kette ausführst?

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 30.06.2011, 14:11
  2. SPS Absturz nach Download
    Von Grubro im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 14.09.2010, 15:11
  3. Sporadischer Fehler mit DP/DP Koppler
    Von shotar im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 22.04.2010, 21:43
  4. Sporadischer Profibusfehler
    Von bernd67 im Forum Feldbusse
    Antworten: 12
    Letzter Beitrag: 14.04.2008, 19:57
  5. Absturz bei Datenübertragung nach Lenzeregler
    Von Gast im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 30.06.2006, 17:52

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •