Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 5 von 6 ErsteErste ... 3456 LetzteLetzte
Ergebnis 41 bis 50 von 51

Thema: [PROBLEM] FB lässt sich nicht mehrfach aufrufen bzw ..

  1. #41
    Registriert seit
    21.05.2008
    Beiträge
    49
    Danke
    7
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Larry Laffer Beitrag anzeigen
    Zurück zum Thema ...

    @openminded:
    Auch an dem FC88 kann ich auf dem ersten (und zweiten) Blick erstmal nichts Schlimmes entdecken. Ich gehe mal davon aus, das er Stand-Alone funktioniert. Wie sieht es den mit den IN_OUT-Merkern im restlichen Programm aus ... Ist es wirklicher sichergestellt, dass sie (wenn überhaupt) im Weiteren nur lesend benutzt werden ...?
    Ja, das ist sichergestellt. Zur Zeit werden die Merker nur von den Funktionen beschrieben.
    -------------------------------------------------------------------------
    Wer Fehler findet, darf sie behalten!

  2. #42
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.708
    Danke
    398
    Erhielt 2.397 Danke für 1.997 Beiträge

    Standard

    ... dann sag doch noch mal, was der FC88 nicht so macht, wie er soll ...

  3. #43
    Registriert seit
    21.05.2008
    Beiträge
    49
    Danke
    7
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Wie gesagt:
    Bei Aufruf erfolgen unkontrollierte Zugriffe, und die Funktionen funktionieren nicht oder nur unzulässig (halt unkontrolliert ...)
    -------------------------------------------------------------------------
    Wer Fehler findet, darf sie behalten!

  4. #44
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.708
    Danke
    398
    Erhielt 2.397 Danke für 1.997 Beiträge

    Standard

    ... und Stand-Alone ist alles in Ordnung ...?

  5. #45
    Registriert seit
    21.05.2008
    Beiträge
    49
    Danke
    7
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Genau.
    -------------------------------------------------------------------------
    Wer Fehler findet, darf sie behalten!

  6. #46
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.708
    Danke
    398
    Erhielt 2.397 Danke für 1.997 Beiträge

    Standard

    ... dann weiß ich mir da im Augenblick wirklich keinen Rat.

    Resume:
    Dein Baustein ist Stand-Alone OK
    Im Baustein sind keine Offensichtlichen Fehler
    Die Merker und Timer werden nicht doppelt verwendet ...

    Vorschlag:
    Da das Ding bei dir (in deiner Firma) ja so eine Art Standard-Charkter einnehmen soll (so habe ich es verstanden) ...

    Mach einen FB daraus.
    Verwende als Timer IEC-Timer (z.B. SFB 4). Die kannst du mit in die Instanz integrieren - du bist somit unabhängig von den "normalen" Timern.
    Benenne Variablen nach deren Funktion (nicht Merker).
    Lege die "Merker" in den STAT-Bereich (wie schon bei deinem anderem Beispiel).

    noch so zum Schluß:
    Wenn du den Ablauf im Baustein startest ... entsprechen die Merker in ihrem Zustand dann dem Sollzustand ... (Frage gilt für den Doppel-Betrieb) ?

  7. #47
    Registriert seit
    17.10.2007
    Ort
    35043 Marburg
    Beiträge
    176
    Danke
    4
    Erhielt 30 Danke für 29 Beiträge

    Standard

    Also dein FC 88, da stimmt was nicht mit dem #EIN zum rücksetzen wolltest du doch bestimmt den #AUS benutzen?

    erklär doch mal was passieren soll!

  8. #48
    Registriert seit
    24.10.2007
    Ort
    Niederlande
    Beiträge
    673
    Danke
    22
    Erhielt 143 Danke für 135 Beiträge

    Standard

    In OB1 werden die merker M12.5 M12.6 und M12.7 in Netzwerk2 2x benutz und das gibt volgens mir die fehler.

    Joop

  9. #49
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.708
    Danke
    398
    Erhielt 2.397 Danke für 1.997 Beiträge

    Standard

    Zitat Zitat von JoopB Beitrag anzeigen
    In OB1 werden die merker M12.5 M12.6 und M12.7 in Netzwerk2 2x benutz und das gibt volgens mir die fehler.

    Joop
    Stimmt ...!
    Sie sind als IN_OUT and der Merkern und auch an den OUT's dran ... Das hatte ich überhaupt nicht gesehen ...

  10. #50
    Registriert seit
    21.05.2008
    Beiträge
    49
    Danke
    7
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Problem besteht immer noch - trotz Änderungen.
    -------------------------------------------------------------------------
    Wer Fehler findet, darf sie behalten!

Ähnliche Themen

  1. SCL-FC lässt sich nicht in SPS einspielen
    Von Aksels im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 16.03.2011, 06:55
  2. Antworten: 9
    Letzter Beitrag: 26.12.2009, 11:01
  3. cpu 315 2dp lässt sich nicht starten
    Von davidooo im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 06.04.2009, 23:03
  4. 928 lässt sich nicht urlöschen
    Von blaubaer im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 05.02.2008, 17:50
  5. SPS -S5- lässt sich nicht auslesen
    Von Anonymous im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 26.05.2005, 18:02

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •