Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: SFB 4 keine Funktion

  1. #1
    Registriert seit
    13.06.2008
    Beiträge
    182
    Danke
    15
    Erhielt 25 Danke für 22 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich habe ein Problem mit dem SFB4 (IEC-Timer TON). Ich möchte den Timer in einem Multiinstanz FB verwenden und bekomme ihn nicht zum laufen. Aus Frust habe ich es dann mit den SFB 3 und SFB 5 probiert die funktionieren komischerweise. Weiß jemand was ich falsch mache??

    1. Ich deklariere im Deklarationsteil des FB unter "STAT" den SFB4 als Instanz
    2. Aufruf der Instanz im FB mit dem im "STAT" vereinbarten Namen
    3. Beschaltung des FB wie gewohnt "IN" mit Steuereingang, "PT" mit Sollzeit also z.B. T#15s, "Q" mit dem Schaltausgang und "ET" mit einer lokalen "Time"-Variable
    4. Aufruf des FB im OB1 mit dazugehörigem DB
    5. Bausteinkonsistenz des Programms prüfen lassen und alles übersetzt
    6. an PLCSIM übertragen und getestet
    7. langes Gesicht gemacht
    8. an SPS-Forum gewendet.......

    Siehe auch Anhang (Bild des FB)

    Danke für euere Hilfe!!

    Gruß
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren SFB 4 keine Funktion  

  2. #2
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.622
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Es ist ein bekanntes problem mit PLCSIM. Du brauchst vermutlich ein hotfix.
    Welcher version hast Du ?
    Jesper M. Pedersen

  3. #3
    L.T. ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    13.06.2008
    Beiträge
    182
    Danke
    15
    Erhielt 25 Danke für 22 Beiträge

    Standard

    V5.3+SP1 Korrekturstand 5.3.1.0

  4. #4
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.622
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Hier ist HF1 für PLCSIM v5.3 SP1
    Angehängte Dateien Angehängte Dateien
    Jesper M. Pedersen

  5. #5
    Registriert seit
    01.11.2007
    Beiträge
    1.236
    Danke
    91
    Erhielt 407 Danke für 368 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    , war bei mir auch so. Habe ich durch Suche hier im Forum herausgefunden (5 Fundstellen bei Suche nach PLCSIM und SFB4): Danke Forum !

    Grüße von HaDi
    Geändert von HaDi (13.06.2008 um 21:24 Uhr) Grund: Nachtrag

Ähnliche Themen

  1. funktion SPS
    Von SheepLord im Forum Stammtisch
    Antworten: 19
    Letzter Beitrag: 19.12.2010, 18:20
  2. keine Touch-Funktion mehr beim TP177Micro
    Von olitheis im Forum HMI
    Antworten: 1
    Letzter Beitrag: 01.06.2010, 09:41
  3. CP 340 ASCII Protokoll - keine Funktion
    Von fr4nk im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 12.01.2010, 12:11
  4. Nach übertragung keine Funktion im OP3
    Von Vetten im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 29.09.2006, 09:18
  5. Funktion
    Von isensa im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 26.07.2006, 18:07

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •