Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: FB 223 "F_SENDDP" und FB 224 "F_RCVDP"

  1. #1
    Registriert seit
    03.01.2006
    Ort
    Im sonnigen Süden von Österreich!
    Beiträge
    1.377
    Danke
    227
    Erhielt 183 Danke für 168 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!

    Ich habe da schon wieder etwas Merkwürdiges wo ich ein wenig anstehe...
    Ich habe 2x CPU315F-2DP die über einen DP DP Koppler verbunden sind.
    Diese 2 CPUs tauschen über den Koppler mit den Bausteinen FB 223 "F_SENDDP" und FB 224 "F_RCVDP" ein Sicherheitsgerichtetes Bit aus. Das Merkwürdige ist das bei der CPU die Sendet kein Fehler ist und die CPU die empfängt setzt das Error Bit auf 1 und es kommt das zu sendende Bit nicht an.
    Beim Sendebaustein sind die Ausgänge Retval14/15 und Diag auf 0 und beim Empfangsbaustein ist ebenfalls Retval14/15 auf Null und bei Diag ist das Bit 6 gesetzt.

    Hat da jemand eine Ahnung von was das kommen kann bzw wie ich den Fehler korrigiere?

    godi
    Zitieren Zitieren FB 223 "F_SENDDP" und FB 224 "F_RCVDP"  

  2. #2
    Registriert seit
    09.11.2006
    Beiträge
    693
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Hallo,

    also wichtig ist erstmal die Konfiguration des Kopplers und des Bausteins, besonders die DP ID diese muss gleich sein also Master 2 Slave auch2 Koppler Universalmodul Sendeseite 6 byte Eingang 12 byte Ausgnag Empfangsseite 12 byte eingang 6 byte ausgang!!!!
    Zitieren Zitieren Konfiguration  

  3. #3
    Avatar von godi
    godi ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    03.01.2006
    Ort
    Im sonnigen Süden von Österreich!
    Beiträge
    1.377
    Danke
    227
    Erhielt 183 Danke für 168 Beiträge

    Standard

    Zitat Zitat von mitchih Beitrag anzeigen
    Hallo,

    also wichtig ist erstmal die Konfiguration des Kopplers und des Bausteins, besonders die DP ID diese muss gleich sein also Master 2 Slave auch2 Koppler Universalmodul Sendeseite 6 byte Eingang 12 byte Ausgnag Empfangsseite 12 byte eingang 6 byte ausgang!!!!
    Die Konfiguration sollte stimmen.
    Siehe hier

    godi

  4. #4
    Registriert seit
    09.11.2006
    Beiträge
    693
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Sollte passen,

    das einzige was auffält , ist das die DP E/A`s teilweise außerhalb des Prozessabbildes liegen. (War doch bei der 315-F 1k oder??)

    Bin mir aber nicht 100% sicher ob das so sein darf oder nicht!!
    ansonsten scheint alles korrekt zu sein. Wichtig ist dann halt noch die DP ID am Baustein.

    Wie hoch steht der Timeout??

    Was sagen die Parameter Subs on?? Error &ACK_REQ???

  5. #5
    Avatar von godi
    godi ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    03.01.2006
    Ort
    Im sonnigen Süden von Österreich!
    Beiträge
    1.377
    Danke
    227
    Erhielt 183 Danke für 168 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von mitchih Beitrag anzeigen
    Sollte passen,

    das einzige was auffält , ist das die DP E/A`s teilweise außerhalb des Prozessabbildes liegen. (War doch bei der 315-F 1k oder??)

    Bin mir aber nicht 100% sicher ob das so sein darf oder nicht!!
    ansonsten scheint alles korrekt zu sein. Wichtig ist dann halt noch die DP ID am Baustein.

    Wie hoch steht der Timeout??

    Was sagen die Parameter Subs on?? Error &ACK_REQ???
    Das Prozessabbild der 315F liegt irgendwas bei 385.7 oder so.
    Also die 1000.0 ist vollständig ausserhalb des Prozessabbildes.

    Die ID sollte auch stimmen. Sie ist beim Sendebaustein 1024 und beim Empfangsbaustein 1000. Die LADDR ist gleich beschaltet wie die ID.

    Der Timeout liegt beim senden und empfangen bei einer Sekunde.

    Error ist beim Sendebaustein False und beim Empfangsbaustein True.
    Die anderen Werte kann ich erst Morgen in der früh sagen wenn ich wieder in der Firma bin.

    godi

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 16.03.2012, 18:20
  2. "Index Pulse", "Home Switch" und "Position Limit Switch"
    Von senmeis im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 07.03.2011, 11:21
  3. Antworten: 8
    Letzter Beitrag: 16.05.2008, 11:26
  4. Antworten: 2
    Letzter Beitrag: 14.12.2007, 15:09
  5. Antworten: 4
    Letzter Beitrag: 29.11.2006, 08:59

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •