Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 16

Thema: Bereichslängenfehler beim Schreiben

  1. #1
    Registriert seit
    14.07.2008
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!

    hab folgendes problem.
    ich wollte eine S7-400er anlage eine uhrzeitsynchronisation programmieren. es gibt andere anlagen wo dies bereits schon vorhanden ist.
    jetzt hab ich mir gedacht ich kopier mir einfach den FB mit DB rüber und fertig.
    leider bekomm ich dann diese fehlermeldung:
    Code:
    Ereignis 1 von 120:  Ereignis-ID 16# 2523
    Bereichslängenfehler beim Schreiben 
    Global -DB  ,Bitzugriff,   Zugriffsadresse:     91
    FB-Nummer:    60
    Bausteinadresse:    702
    Angeforderter OB: Programmierfehler-OB (OB 121)
    Prioritätsklasse:  1
    interner Fehler, kommendes Ereignis
    05:38:53.562  14.07.2008
    hab schon nach dem problem hier im forum gesucht ...da heißts meistens das ich da eine adresse anspreche im DB die es nicht gibt ....aber des kann ja net sein wenn ich den FB und den DB original rüberkopiert hab oder?

    Gruß
    Butty
    Zitieren Zitieren Bereichslängenfehler beim Schreiben  

  2. #2
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    du hast wahrscheinlich *seinekugelauspack* nur den FB und den dazu gehörigen Instanz-DB kopiert ... dein fehler ist aber ein zugriffsfehler auf einen Global-DB ... schau in den FB oder dessen Schnittstelle, auf welchen DB dieser zugreift und kopiere diesen aus dem alten projekt...
    Geändert von vierlagig (14.07.2008 um 07:13 Uhr)
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  3. #3
    Butty ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    14.07.2008
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    also ich kenn mich da ja net so aus.
    ich hab da:
    DBD
    DBB
    DBW

    nach welchen soll ich da nun schaun?

  4. #4
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.718
    Danke
    398
    Erhielt 2.400 Danke für 2.000 Beiträge

    Standard

    @4L:
    Jetzt wäre der richtige Zeitpunkt auch noch die zweite Kugel auszupacken ...

    @Butty:
    Du solltest dich schon nach der Fehler-Meldung orientieren. Irgendwo hast du da einen DBxxx.DBWyyy parametriert, den es nicht gibt ...

  5. #5
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    das sind nur die adressen in dem entsprechenden DB

    ich könnte mir vorstellen, dass da evtl. etwas wie

    Code:
    *
          AUF   DB     9
    oder

    Code:
    *
          AUF   DB [#db_nummer]
    ...steht.

    wenn du es nicht findest, lass uns an deinem code teilhaben...

    @larry: ich sag nüx!
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  6. #6
    Butty ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    14.07.2008
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    also erstens ...jo ...ich bin der volle n00b

    ich programmier fast nie was ...und jetzt kommt mal wieder einer daher der einfach sagt ...mach des mal "schnell" ...wies halt meistens so läuft

    so ...also im FB60 steht ganz am anfang "Auf DB60"
    der DB60 ist aber kein instanz DB von FB60

  7. #7
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von Butty Beitrag anzeigen
    so ...also im FB60 steht ganz am anfang "Auf DB60"
    der DB60 ist aber kein instanz DB von FB60
    jopp, dann ist erstens der baustein doof, aber daran sollten wir nichts ändern, das würde zu weit führen und

    2. fehlt der db60 mindestens in der steuerung, also nimm dir den DB60 aus dem projekt, aus dem du auch den FB und die Instanz kopiert hast und lad ihn hoch - zack, läuft
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  8. #8
    Registriert seit
    22.01.2008
    Ort
    Allgäu, da wo die Kühe schöner sind als die Mädels
    Beiträge
    1.774
    Danke
    50
    Erhielt 729 Danke für 434 Beiträge

    Standard

    Zitat Zitat von Butty Beitrag anzeigen
    also erstens ...jo ...ich bin der volle n00b

    ich programmier fast nie was ...und jetzt kommt mal wieder einer daher der einfach sagt ...mach des mal "schnell" ...wies halt meistens so läuft

    so ...also im FB60 steht ganz am anfang "Auf DB60"
    der DB60 ist aber kein instanz DB von FB60

    Du bist keine n00B, glaub an Dich.
    Und lass Dich von 4L nicht fertig machen.
    Du schaffst das

    Gruss
    Audsuperuser
    Gruss Audsuperuser

    Herzlich Willkommen im Chat:
    SPS-Forum Chat (Mibbit) | SPS-Forum Chat (MIRC)

  9. #9
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von AUDSUPERUSER Beitrag anzeigen
    Und lass Dich von 4L nicht fertig machen.
    als ob das meine absicht wäre - was soll das? das ist ja schon fast üble nachrede
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  10. #10
    Butty ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    14.07.2008
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    nene ...also ich hab den FB60 und DB60 vom anderen projekt ja original rüberkopiert.
    nur wollt ich nur sagen das der im original projekt kein instanz DB schon war

    ich glaub ich such mir hier in der firma mal so nen SPS typen ....dem kann ichs vor ort glei zeigen.
    weil ich darf den code hier net posten ...sonst glaub ich hat sich das mit der arbeit erledigt ....obwohl ...wär ja auch ne option

    edit: achja ...und vielen dank an euch für die hilfe und schnellen antworten!!!
    Geändert von Butty (14.07.2008 um 11:45 Uhr)

Ähnliche Themen

  1. bereichslängenfehler beim schreiben
    Von dedl im Forum Simatic
    Antworten: 17
    Letzter Beitrag: 26.09.2011, 15:58
  2. Bereichslängenfehler beim Schreiben
    Von Stemmann im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 26.11.2010, 13:28
  3. Antworten: 16
    Letzter Beitrag: 22.08.2009, 15:21
  4. Bereichslängenfehler beim lesen/schreiben
    Von mitchih im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 28.01.2008, 21:57
  5. Bereichslängenfehler beim Schreiben in den DB
    Von Anonymous im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 08.04.2005, 11:19

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •