Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Mit dem FB414 auf Festanschlag fahren

  1. #1
    Registriert seit
    10.07.2008
    Beiträge
    75
    Danke
    14
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    Ich habe eine 317T und zwei Motoren.Den einen Motor möchte ich mit dem Baustein FB 414 MoveToEndPos gegen ein Moment fahren.IN S7 Konfig habe ich den Festanschlag eingeschaltet (Moment).Dann habe ich die Werte an den Baustein gegeben.Leider bekomme ich nach Freigabe durch EXECUTE den Fehler 8045.Muss ich vorher noch irgendwas projektieren bevor ich den Baustein benutzen kann.

    Danke
    Harald2
    Geändert von harald2 (30.07.2008 um 09:46 Uhr)
    Zitieren Zitieren Mit dem FB414 auf Festanschlag fahren  

  2. #2
    Registriert seit
    10.07.2008
    Beiträge
    75
    Danke
    14
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo

    Ich habe mal versucht mit dem Baustein FB437 SetTorqueLimit eine Momentenregelung zu machen.Aber dieser Baustein belastet den Motor ja eigentlich nur mit einem Moment was es schwerer macht ihn zu drehen.Gibt es noch eine Möglichkeit eine Momentenregelung mit den Motion Bausteinen zu betreiben.Kennt sich vielleicht doch jemand mit dem FB414 aus.

    Danke
    Harald2

  3. #3
    Registriert seit
    17.07.2006
    Beiträge
    351
    Danke
    0
    Erhielt 79 Danke für 70 Beiträge

    Standard

    Ich habe die Erfahrung gemacht, dass es sinnvoller ist, MC_TorqueLimit zu nutzen und nicht MC_MoveToEndPos. Man muss zwar etwas mehr drum herum programmieren, ist aber was das rausfahren aus dem Anschlag angeht erheblich flexibler.

  4. #4
    Registriert seit
    10.07.2008
    Beiträge
    75
    Danke
    14
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo

    Muss man denn bei dem MoveToEndPos irgenwas beachten damit es funktioniert.Der eine Motor ist als Gleichlaufachse projektiert.Könnte das zu der Störung führen.Bei dem Baustein SetTorque müsste sich die Achse eigentlich bewegen wenn keine Last an ihr hängt,oder ist das Korrekt das sie sich nur schwerer bewegen lässt.

    Danke

    harald2

  5. #5
    Registriert seit
    17.07.2006
    Beiträge
    351
    Danke
    0
    Erhielt 79 Danke für 70 Beiträge

    Standard

    Du musst vor allem die Einstellungen in T-Config auch korrekt gemacht haben, sonst geht´s nicht richtig.
    Expertenliste -> Konfigurationsdaten -> TypeOfAxis -> SetPointDriverInfo -> DriveData -> maxTorque
    Hier wird die Bezugsgrösse eingestellt. Vorzugsweise würde ich den Wert auf 100 einstellen, dann kann man die Grenze quasi als prozentualen Wert sehen.
    Wenn Du einen S120 betreibst, dann muss zusätzlich noch p1544 auf 16384 setzen.

    Du musst immer darauf achten, dass sich hier ein Schleppfehler aufbauen kann. Dieser wird schlagartig abgebaut, sobald die Achse wieder Moment hat ! Also im Zweifelsfall mit MC_MoveVelocity, PositionControl = FALSE den Schleppfehler löschen !

    SetTorqueLimit begrenzt nur das zur Verfügung stehende Moment, ob sich die Achse bewegt oder nicht... Beim MoveToEndPos wird auch nch die Bewegung ausgelöst, bis Momentengrenze/Schleppgrenze erreicht. Dann wird die Position gehalten.
    Geändert von offliner (30.07.2008 um 16:29 Uhr)

  6. #6
    Registriert seit
    10.07.2008
    Beiträge
    75
    Danke
    14
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo

    Ja hat funktioniert,aber das ist wirklich nicht das was ich mir gedacht hatte.Ich habe zwei Motoren.einen Wickler und einen Bandnachschub.Den Bandnachschub möchte ich mit Drehmoment regeln,den Wickler mit der Drehzahl.Mit den FB Bausteinen kann ich ja kein moment auf die Achse geben.Ich habe irgenwo in S7-Konfig ein Register gesehen mit Zusatzmoment und anderen Einstellungen.Wie kann ich auf die Achse ein moment geben.Muss ich das in der Expertenliste eintragen.

    Danke
    Harald

  7. #7
    Registriert seit
    17.07.2006
    Beiträge
    351
    Danke
    0
    Erhielt 79 Danke für 70 Beiträge

    Standard

    Ich hab zwar noch nicht ganz verstanden, was Du machen willst, ich könnte mir aber folgendes vorstellen:
    Achse friegeben mit MC_Power Mode = 2
    Telegram des Antriebs erweitern und über ein zusätzliches Wort im Antrieb direkt das Moment vorgeben mit WritePeirphery. Alternativ geht nat. auch WriteDriveParameter

  8. #8
    Registriert seit
    10.07.2008
    Beiträge
    75
    Danke
    14
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo

    Das zusätzliche Wort habe ich eingefügt.Wenn ich in S7 Konfig das Telegramm konfigurieren will habe ich bei Profibus Empfangsrichtung einige Parameter an Auswahl.Von Zusatzdrehmoment 1-3 bis Zusatzsollwert.Aber sollte das nicht ein Drehmomentsollwert sein den ich über den Profibus versende.Kann mir jemand weiterhelfen

    Danke
    harald2

  9. #9
    Registriert seit
    10.07.2008
    Beiträge
    75
    Danke
    14
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo

    Wenn ich in S7 Konfig bei meinem Antrieb auf die Schaltfläche Momentensollwert gehe kann ich den Drehzahlregler nicht in einen Drehmomentenregler umstellen.Grund hierfür ist das Profibustelegramm (p0922).Ich habe versucht ein anderes Telegramm zu benutzen aber das Umschalten ist auch dann nicht möglich.Welches Telgramm ist hierfür geeignet,kann mir jemand das sagen.

    Danke
    harald2

  10. #10
    Registriert seit
    17.07.2006
    Beiträge
    351
    Danke
    0
    Erhielt 79 Danke für 70 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Du kannst direkt im Steuerwort des Antriebs von Drehzahl- auf Momentenregelung umschalten. Hierfür kanst Du MC_WriteParameter nutzen. Parameternummer ist 4500. Belegung für die Parameterwerte müsste sein (ohne Gewähr) ValueDWord2 = DW#16#00004000 als Maske für Bit14 STW1; ValueDWord1 = DW#16#00004000 zum Einschalten und DW#16#0 zum Ausschalten. Im Antrieb nimmst Du Zusatzdrehmoment 1 oder 2, die sitzen vor der Momentenbegrenzung.
    Vorsicht, der Antrieb geht Drehzahlmäßig durch, wenn keine Last dran hängt !!

Ähnliche Themen

  1. Rollomotoren fahren unkontrolliert
    Von blasterbock im Forum Elektronik
    Antworten: 16
    Letzter Beitrag: 12.10.2010, 06:46
  2. Fahren auf Festanschlag
    Von capri-fan im Forum Antriebstechnik
    Antworten: 1
    Letzter Beitrag: 23.03.2010, 16:23
  3. du glaubst du kannst auto fahren?
    Von Markus im Forum Stammtisch
    Antworten: 3
    Letzter Beitrag: 24.02.2010, 16:49
  4. MC_Jog / Fahren über Handbedientaste
    Von Itus im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 14.12.2009, 09:22
  5. Problem bei FC und Grundstellung fahren
    Von Nero23 im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 05.05.2008, 07:21

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •