Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 20

Thema: Ausgänge nur kurz aktiv

  1. #1
    Registriert seit
    21.08.2008
    Beiträge
    21
    Danke
    39
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hallo sps-gemeinde!

    ich hab wieder ein kleines problem:

    Aufgabe ist, dass ich ein programm mache, welches bei bestimmter schaltung entweder den motor dreht, links dreht oder hupt!
    falls die entsprechenden schalter nicht innerhalb 10s geschaltet sind, solls hupen!

    problem dabei ist, dass der simatic s7 cpu 212 nur kurz die zeitschaltuhr aktiv macht und dann wieder ausschaltet.... im endeffekt rührt sich nix!

    danke


    Geändert von MarcusS81 (25.08.2008 um 13:56 Uhr)
    Zitieren Zitieren Ausgänge nur kurz aktiv  

  2. #2
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    innerhalb von 10s ab wann?
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  3. Folgender Benutzer sagt Danke zu vierlagig für den nützlichen Beitrag:

    MarcusS81 (25.08.2008)

  4. #3
    MarcusS81 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    21.08.2008
    Beiträge
    21
    Danke
    39
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von vierlagig Beitrag anzeigen
    innerhalb von 10s ab wann?
    nachdem einer der schalter aktiv gemacht wurde...! achso ja auf dem bild ist das drauf..... sorry fürs nicht-schreiben!

  5. #4
    Registriert seit
    25.05.2007
    Beiträge
    47
    Danke
    0
    Erhielt 3 Danke für 3 Beiträge

    Standard

    müsste dass nicht ein TONR-Glied sein...???

  6. Folgender Benutzer sagt Danke zu baalrok für den nützlichen Beitrag:

    MarcusS81 (25.08.2008)

  7. #5
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    dann mußt du das weiter ausbauen ... denn so wie du es jetzt hast, mußt du die taste zehn sekunden drücken ... also solltest du das drücken einer taste lokalisieren, die flanke benutzen, speichern und damit die zeit starten und evtl. eine ausschaltverzögerung, die die gespeicherte meldung "taste_wurde_gedrückt" nach ablauf zurücksetzt. der ganze mechanismus sollte dann gebrückt werden, wenn der motor dreht...
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  8. Folgender Benutzer sagt Danke zu vierlagig für den nützlichen Beitrag:

    MarcusS81 (25.08.2008)

  9. #6
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von baalrok Beitrag anzeigen
    müsste dass nicht ein TONR-Glied sein...???
    und dann? dann kannste du dir die 10s zwar zusammendrücken, aber erfolg hast du damit auch noch nicht ...
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  10. Folgender Benutzer sagt Danke zu vierlagig für den nützlichen Beitrag:

    MarcusS81 (25.08.2008)

  11. #7
    Registriert seit
    25.05.2007
    Beiträge
    47
    Danke
    0
    Erhielt 3 Danke für 3 Beiträge

    Standard

    jetzt weiß ich was du meinst.

    vierlagig hat recht. so wie es jetzt ist funzzt das nicht.

  12. Folgender Benutzer sagt Danke zu baalrok für den nützlichen Beitrag:

    MarcusS81 (25.08.2008)

  13. #8
    MarcusS81 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    21.08.2008
    Beiträge
    21
    Danke
    39
    Erhielt 0 Danke für 0 Beiträge

    Standard

    hm ok aber bis jetzt macht er den timer nichtmal richtig an....!

    zusätzlich kann jetzt auch keine verbindung mehr zwischen pc und cpu 212 hergestellt werden!
    irgendwas scheint schief gelaufen zu sein ,-)!

    gruss
    Geändert von MarcusS81 (25.08.2008 um 14:53 Uhr)

  14. #9
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von MarcusS81 Beitrag anzeigen
    hm ok aber bis jetzt macht er den timer nichtmal richtig an....!
    kann er ja auch nicht, speichere eine flanke von den tastern in einem merker und steuere damit den timer an
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  15. Folgender Benutzer sagt Danke zu vierlagig für den nützlichen Beitrag:

    MarcusS81 (25.08.2008)

  16. #10
    Registriert seit
    25.05.2007
    Beiträge
    47
    Danke
    0
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Grober Aufbau:

    Nimm deine Schalter S0 - S7 und verschalte sie auf ein SR-Glied. Den Ausgang des SR-Glieds auf das TON-Glied.
    An den Rücksetzt-Eingang des SR-Glieds Schaltest du die Schalter S1, S3, S6 auf ein UND-Glied und die Schalter S1, S4, S5 auch auf ein UND-Glied. Die Ausgänge der UND-Glieder auf ein XOR-Glied und dessen Ausgang mit dem Operand des SR-Glied auf ein UND-Glied.

    Den Rest lässt du so. Oder ähnlich und passt es nach belieben an.

  17. Folgender Benutzer sagt Danke zu baalrok für den nützlichen Beitrag:

    MarcusS81 (25.08.2008)

Ähnliche Themen

  1. Antworten: 8
    Letzter Beitrag: 23.06.2010, 05:33
  2. Antworten: 2
    Letzter Beitrag: 07.05.2009, 16:11
  3. Antworten: 2
    Letzter Beitrag: 14.12.2007, 15:09
  4. Antworten: 16
    Letzter Beitrag: 05.07.2005, 09:51
  5. Antworten: 4
    Letzter Beitrag: 27.02.2005, 18:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •