Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 7 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 69

Thema: Merker der gesetzt wird wenn SPS in RUN ist

  1. #1
    Registriert seit
    20.05.2007
    Beiträge
    301
    Danke
    38
    Erhielt 6 Danke für 6 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo.

    Es ist ja eigentlich ganz einfach von der Funktion. Weis aber trotzdem nicht wie ich es anstellen soll. Wenn die SPS in Run ist soll ein Merker auf true gesetzt werden. Wenn Sie auf stop geht soll er rücksetzen.

    Wie mache ich das am besten?

    Vielen Dank schonmal.
    Zitieren Zitieren Merker der gesetzt wird wenn SPS in RUN ist  

  2. #2
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Beitrag

    Hi,
    und wozu soll der Merker gut sein, wenn die SPS je nicht mehr läuft?

    V.
    ______________________________________
    relax, take it easy
    Zitieren Zitieren ???  

  3. #3
    Avatar von Anaconda55
    Anaconda55 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    20.05.2007
    Beiträge
    301
    Danke
    38
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Soll ein Lebensbit für mein Touchpanel sein...
    Also ich hab da eine Anzeige für den Zustand...

  4. #4
    Registriert seit
    04.06.2008
    Beiträge
    45
    Danke
    2
    Erhielt 8 Danke für 8 Beiträge

    Standard

    ich würde das lebensbit lieber takten, also mit einem taktmerker ansteuern.

  5. #5
    Registriert seit
    24.10.2007
    Ort
    USA
    Beiträge
    815
    Danke
    3
    Erhielt 73 Danke für 57 Beiträge

    Standard

    Zitat Zitat von Anaconda55 Beitrag anzeigen
    Hallo.

    Es ist ja eigentlich ganz einfach von der Funktion. Weis aber trotzdem nicht wie ich es anstellen soll. Wenn die SPS in Run ist soll ein Merker auf true gesetzt werden. Wenn Sie auf stop geht soll er rücksetzen.

    Wie mache ich das am besten?

    Vielen Dank schonmal.
    Du kannst deinen Merker beim Complete Restart in OB100 (S7-300) aufrufen
    Code:
    SET
    S Mx.y
    Das mit dem Stopp

    Ein Stopp kann einige Gründe haben: I/O Fehler, Programmierungsfehler...
    Z.B. bei einem Programmierungsfehler ruft das Besy den OB121 auf
    -->

    Code:
    SET
    R Mx.y
    Eine andere Möglichkeit wäre ein Watchdog/ Livebit
    Partys sind krass, am besten ist das Bier aus dem fränkischen Fass ...
    "Programming today is a race between the programmers and software engineers to create better
    and more idiot-proof programs, and the universe, creating bigger and better idiots. So far,
    the universe is winning". - Rich Cook

  6. #6
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Beitrag

    Hi,
    ein Lebensbit blinkt normalerweise, so du kannst ein Taktbit der CPU(aus dem Taktmerkerbyte) dafür verwenden; wenn es nicht mehr blinkt: CPU weg!
    Die Panels melden systemtechnisch aber auch, wenn die Verbindung weg ist, oder?

    V.
    ______________________________________
    relax, take it easy
    Zitieren Zitieren Lebensbit  

  7. #7
    Registriert seit
    04.01.2008
    Ort
    Wien
    Beiträge
    772
    Danke
    136
    Erhielt 39 Danke für 35 Beiträge

    Standard

    ich würde einen Takt verwenden.
    aber:

    set
    M1.0

    ich verstehe nicht was die Schwierigkeit ist. Ich denke ich habe die Aufgabenstellung nicht ganz verstanden.
    irgendetwas ist ja immer...
    ING. Gerald Miedler

  8. #8
    Registriert seit
    24.10.2007
    Ort
    USA
    Beiträge
    815
    Danke
    3
    Erhielt 73 Danke für 57 Beiträge

    Standard

    Zitat Zitat von Anaconda55 Beitrag anzeigen
    Soll ein Lebensbit für mein Touchpanel sein...
    Also ich hab da eine Anzeige für den Zustand...
    Bei einem TP sollst du den Aufgabenplaner einsetzten (Merker rücksetzen in der Visu & in der SPS setzen)---> Falls die SPS in Stop geht hast Du Merker=false
    Partys sind krass, am besten ist das Bier aus dem fränkischen Fass ...
    "Programming today is a race between the programmers and software engineers to create better
    and more idiot-proof programs, and the universe, creating bigger and better idiots. So far,
    the universe is winning". - Rich Cook

  9. #9
    Registriert seit
    24.10.2007
    Ort
    USA
    Beiträge
    815
    Danke
    3
    Erhielt 73 Danke für 57 Beiträge

    Standard

    Zitat Zitat von vladi Beitrag anzeigen
    Hi,
    ein Lebensbit blinkt normalerweise, so du kannst ein Taktbit der CPU(aus dem Taktmerkerbyte) dafür verwenden; wenn es nicht mehr blinkt: CPU weg!
    Die Panels melden systemtechnisch aber auch, wenn die Verbindung weg ist, oder?



    V.
    Wenn die Verbindung weg ist, kriegt das Panel nicht mit--------->
    wie gesagt den Aufgabenplaner einsetzen Sonst bleibt immer dein Merker=true obwohl die SPS Nix mehr taugt
    Partys sind krass, am besten ist das Bier aus dem fränkischen Fass ...
    "Programming today is a race between the programmers and software engineers to create better
    and more idiot-proof programs, and the universe, creating bigger and better idiots. So far,
    the universe is winning". - Rich Cook

  10. #10
    Registriert seit
    14.06.2005
    Beiträge
    223
    Danke
    9
    Erhielt 15 Danke für 15 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wenn du ein integriertes Projekt hast, zeigt die doch das Panel den Status der Verbindung automatisch mit unter den Systemmeldungen an. Verbindung aufgebaut/abgebaut.

    Sollte doch für deine Zwecke reichen.

    Gruß.

  11. Folgender Benutzer sagt Danke zu paula23 für den nützlichen Beitrag:

    vladi (22.09.2008)

Ähnliche Themen

  1. Wann wird ein Merker im SPS Zyklus gesetzt
    Von Olbrich1983 im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 03.04.2014, 11:42
  2. Merker wird nicht gesetzt. Programm?
    Von maninthedark im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 25.07.2011, 22:11
  3. Eingang high wenn Merker gesetzt wird
    Von Stift1802 im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 13.05.2011, 10:51
  4. Antworten: 5
    Letzter Beitrag: 04.08.2008, 11:04
  5. Bild anzeigen wenn Variable gesetzt ist
    Von MarioS007 im Forum HMI
    Antworten: 3
    Letzter Beitrag: 13.06.2007, 19:50

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •