Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: S7 Graph Schritte springen

  1. #1
    Registriert seit
    09.01.2008
    Beiträge
    15
    Danke
    6
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Forum,

    hatte am Wochenende folgendes Problem. Musste an einer Fremdanlage eine Softwareänderung durchführen. Es handelte sich um einen Graph7 Baustein, nur Ablaufänderung keine Strukturänderung ( Instanz DB musste nicht mit übertragen werden). Jetzt gab es am Montag Morgen ein Ablauf Problem in einem anderen Graph 7 Baustein, es ist keine Kettenstörung angezeigt worden, aber die Anlage ist nicht weiter gelaufen. Ich habe darauf im Baustein nachgeschaut, und gesehen,bei einer Parallelverzweigung in beiden Zweigen 4 aufeinanderfolgende Schritte (Linar ohne Srungmarken,Alternativverzweigungen etc.) immer willkürlich "auf und ab" gesprungen sind.Beim letzen Schritt war jeweils die Transiton nicht erfüllt. Dann habe ich festgestellt, das der Baustein Warnungen beim Öffenen anzeigte. Es wurden keine Zuweisungen an genau den Schritten gemacht was zu Warnung geführt hat. Ich habe darauf Schrittmerker zugewiesen, und die Transition zur Weiterschaltbedingung erfüllt, und die Kette ist normal durchgelaufen. Leider ist der Ablauffehler dann den ganzen Tag nicht nochmal aufgetreten. Wie kann das sein das mehrere Schritt willkürlich springen. Hatte schon mal jemand ein ähnliches Problem, oder eine Erklärung?
    Schon mal Danke

    Pefida
    Zitieren Zitieren S7 Graph Schritte springen  

  2. #2
    Registriert seit
    01.11.2007
    Beiträge
    1.237
    Danke
    91
    Erhielt 407 Danke für 368 Beiträge

    Standard

    "Willkürlich" springende Schritte beim Beobachten der Schrittkette kenne ich nur bei Schleifen innerhalb der Kette, wo auf eine Bedingung gewartet wird aber innerhalb der Schleife die Transitionen erfüllt sind, da ist die Statusanzeige einfach zu langsam für.
    Wenn bei dir aber eine Transition gefehlt hat könnte ich mir bestenfalls noch vorstellen, dass die Kette ständig zurückgesetzt und wieder gestartet wird. Ansonsten kann es ja nicht schaden, den I-DB auch zu übertragen.

    Grüße von HaDi

  3. #3
    Registriert seit
    25.08.2008
    Ort
    Rhein-Main
    Beiträge
    9
    Danke
    4
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Ich hatte mal ein ähnliches Problem,

    da waren Schrittmerker gesetzt, obwohl die Schritte definitiv nicht aktiv waren.
    Das ganze ist aufgereten, nachdem das Projekt beim Bausteintauschen abgeschmiert war.

    Geholfen hat Reorganisieren und neu laden, danach hat alles wieder gepasst.

    Die Schrittmerker waren wieder so wie es programmiert war gesetzt, ohne das zwischendurch Programmänderungen durchgeführt wurden.


    Viele Grüße

  4. Folgender Benutzer sagt Danke zu bruce für den nützlichen Beitrag:

    Pefida (01.10.2008)

  5. #4
    Pefida ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.01.2008
    Beiträge
    15
    Danke
    6
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    OK, werde ich beim nächsten Kundenbesuch auf jedem Fall mal ausprobieren. Zur Zeit läuft die Anlage stabil und der Fehler ist halt dummerweise nicht mehr aufgetreten.

    Grüße
    Pefida

Ähnliche Themen

  1. Springen in ST-Programmierung
    Von ToxicSPS im Forum CODESYS und IEC61131
    Antworten: 7
    Letzter Beitrag: 12.08.2011, 00:24
  2. Antworten: 4
    Letzter Beitrag: 04.03.2010, 16:33
  3. In Kurvenfenster springen
    Von Adenauer im Forum HMI
    Antworten: 1
    Letzter Beitrag: 18.05.2009, 10:33
  4. Antworten: 1
    Letzter Beitrag: 28.11.2006, 19:12
  5. Verstecke Schritte in Graph-Kette?
    Von MSB im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 30.03.2006, 11:47

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •