Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 28

Thema: S7-> Verstellbarer Wechseltakt, möglich zu programmieren?

  1. #11
    Registriert seit
    30.08.2003
    Beiträge
    2.196
    Danke
    30
    Erhielt 258 Danke für 229 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    mit einem Timer wird das glaube ich nix. Versuchs mal so:

    Code:
    NW1
          L     S5T#2S
          T     MW   272
          NOP   0
    
    
    NW2
          U(    
          U     E      0.0
          S     M      0.0
          U     E      0.1
          R     M      0.0
          U     M      0.0
          )     
          UN    T     12
          L     MW   272
          SE    T     11
    
    
    NW3
          U     T     11
          L     MW   272
          SE    T     12
    
    
    NW4
          U     T     11
          =     L     20.0
          U     L     20.0
          BLD   102
          =     A      0.0
          U     L     20.0
          NOT   
          =     A      0.1
    evtl musste schaun ob du beide Ausgänge nur mit M0.0 rausgibst

    MfG
    André Räppel
    Zitieren Zitieren Takt  

  2. #12
    Avatar von Nachbar
    Nachbar ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.10.2003
    Beiträge
    157
    Danke
    3
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Läßt sich irgendwie nicht übertragen...
    Irgend ne Fehlermeldung mit "Compiler" .... FC1 Baustein 4

    Was kann das jetzt sein ?

    MW272 ist eigentlich das Poti, also ein Eingang.
    Da kann ich doch nichts hin-transferieren ?

  3. #13
    Registriert seit
    30.08.2003
    Beiträge
    2.196
    Danke
    30
    Erhielt 258 Danke für 229 Beiträge

    Standard

    ja später nicht mehr, aber erstmal kannste doch so mit ner festen Zeit testen. Wie hast dus denn gemacht? 4 Netzwerke angelegt und einzeln die Inhalte reinkopiert? Mach mal im NW4 aus L20.0 -> L0.0 In dem Baustein wie ichs reingetippelt hab gabs Lokaldaten.

    MfG
    André Räppel
    Zitieren Zitieren Poti  

  4. #14
    Avatar von Nachbar
    Nachbar ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.10.2003
    Beiträge
    157
    Danke
    3
    Erhielt 1 Danke für 1 Beitrag

    Standard

    So, versucht -> erfolglos.
    SF-LED geht an.
    Kann es daran liegen das es nur ne CPU 314 ist ?

    Hatte da schon mal sowas.

  5. #15
    Registriert seit
    27.08.2004
    Ort
    Bei Bremen
    Beiträge
    648
    Danke
    11
    Erhielt 12 Danke für 10 Beiträge

    Standard

    Mache mal das dem MW272 ein MW unter 254.

    Die 314 kann nur (glaube ich) 255 Merkerbytes..
    Gruß
    Heinz

  6. #16
    Avatar von Nachbar
    Nachbar ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.10.2003
    Beiträge
    157
    Danke
    3
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Jupp, is mir auch eingefallen...
    Geht soweit schonmal, allerdings bleibt A0.1 auch gesetzt wenn ich die Geschichte rücksetze.

    Habe auch mal S5T#2s gegen PEW272 ersetzt, leider geht dann die S7 in Störung wenn ich am Poti drehe.

    Woran kann das liegen ?


    Danke erstmal für die Geduld die man bisher mit mir hatte.

  7. #17
    Registriert seit
    27.08.2004
    Ort
    Bei Bremen
    Beiträge
    648
    Danke
    11
    Erhielt 12 Danke für 10 Beiträge

    Standard

    Das ist der Level 2 von André

    Das ZEitformat muss angepasst werden. Siehe Handbuch /OH unter Zahlenformate.

    Aus dem Kopf:
    die ersten 12 BIT sind der Zeitwert BCD Codiert und die letzten 4 stellen das Zeitraster dar.

    Ich hoffe das ist richtig.....

    DAher geht das
    Code:
    l PEW xxx
    T MW 200
    nicht.
    Gruß
    Heinz

  8. #18
    Avatar von Nachbar
    Nachbar ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.10.2003
    Beiträge
    157
    Danke
    3
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Aso, heißt jetzt: das PEW272 (mit diesen 5stelligen Zahlenwert) muß ich in Minuten und Sekunden umwandeln, richtig?

    Glaube ich bin zu blöde für sowas..... Habe nur die Hilfe bei Step7 und paar Bücher (dickes Ref-Handbuch-> System- und Standradfunktion und welche über FUP, KOP, AWL und HMI) von 08/2000

    Naja, werd daheim noch bissl knobeln (gleich Feierabend)
    Bin dann morgen ab 6h wieder da.

  9. #19
    Registriert seit
    14.01.2004
    Ort
    Hattorf
    Beiträge
    3.201
    Danke
    297
    Erhielt 311 Danke für 266 Beiträge

    Standard

    hallo,
    versuchs mal so.....
    Netzwerk 1
    L PEW 256
    L 28
    /I
    T MW 10
    NOP 0
    Netzwerk 2
    L MW 10
    ITB
    T MW 2
    NOP 0
    Netzwerk 3
    L 1000
    L MW 10
    -I
    T MW 12
    NOP 0
    Netzwerk 4
    L MW 12
    ITB
    T MW 0
    NOP 0
    Netzwerk 5
    UN T 1
    L MW 0
    SE T 0
    Netzwerk 6
    U T 0
    L MW 2
    SE T 1
    Netzwerk 7
    U T 0
    = A 0.0
    Netzwerk 8
    UN T 0
    = A 0.1

    Das war's... im ersten Netzwerk wird die Gesamttaktzeit eingestellt, 27648 / 28 =987 entspricht 9,87 sec.
    mfg
    dietmar

  10. #20
    Avatar von Nachbar
    Nachbar ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.10.2003
    Beiträge
    157
    Danke
    3
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Klappt so schon mal recht gut.
    Habe nur im NW6 das MW2 gegen MW0 mal getauscht, so sind die Zeiten bei beiden Ausgängen gleich.
    Mit dem Poti muß ich noch bissl ändern.... Zeiteinteilung könnte grober sein (brauch keine 1000stl, etc -Sekunden)

    Naja, probieren, probieren..... experimentieren

    Thx an alle

    Evtl. hat ja jemand noch andere Lösungen........ ?

    Sinnvoll Poti mit 10V zu versorgen bzw. AI über 10V zu steueren?

    Zur Zeit habe ich ein 10KOhm-Poti dran.
    Anderes Poti besser ?

Ähnliche Themen

  1. S5 CPU 942 und DD möglich?
    Von Auge im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 06.11.2009, 19:30
  2. MPI immer möglich
    Von nonguru im Forum HMI
    Antworten: 3
    Letzter Beitrag: 07.02.2009, 19:19
  3. MP 277 mit VNC- Server möglich?
    Von Cliff im Forum HMI
    Antworten: 16
    Letzter Beitrag: 15.01.2009, 16:14
  4. Endlosschleife programmieren?? Wie ist das möglich?
    Von tino2512 im Forum Programmierstrategien
    Antworten: 6
    Letzter Beitrag: 25.08.2006, 14:20
  5. PC-Adapter 5.1 an S7 200 CPU 214 möglich??
    Von Anonymous im Forum PC- und Netzwerktechnik
    Antworten: 4
    Letzter Beitrag: 06.09.2005, 11:40

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •