Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Programmänderung wg. EEprom nicht möglich ???

  1. #1
    alfons Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo leute,
    Wer kann mir helfen?

    Ich bin in der Firma an eine alte SPS geraten ( S5 / CPU 944), an der ich das Prog. ändern möchte.
    Zur zeit ist ein EEProm gesteckt , deswegen kann ich keine Änderungen durchführen.
    Wenn ich ich das EEprom ziehe und das Prog. über Batterie puffere sollte ich eigentlich das Prog. editieren und wieder speichern können.

    Geht aber nicht !

    Beim Befehl " Baustein übernehmen" kommt immer die Meldung " Baustein ist auf EEprom vorhanden" , obwohl EEprom NICHT gesteckt ist.


    Wer hat 'ne Idee ??

    Vielen Dank
    alfons
    Zitieren Zitieren Programmänderung wg. EEprom nicht möglich ???  

  2. #2
    Registriert seit
    06.10.2003
    Beiträge
    3.445
    Danke
    453
    Erhielt 509 Danke für 411 Beiträge

    Standard

    Hallo alfons,

    das ist ja eigenartig. Das EEprom hast du aber bei Netz-Aus gezogen, oder?


    Gruss, Onkel

  3. #3
    Anonymous Gast

    Standard

    Hallo Onkel,

    ja, schon klar.

    Ich habe das Eprom bei Netz-aus gezogen.
    gruss alfons

  4. #4
    Registriert seit
    29.12.2004
    Beiträge
    31
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    hatte gleiches problem auch schon mal

    cpu 944 muß urgelöscht werden

    programm sichen auf pg
    netz aus
    eeprom raus
    am besten pufferbatterie raus
    augenblick warten
    batterie wieder rein
    programm von pg zurückladen

    so hat es jedenfalls bei mir funktioniert

    wenn alles klappt kannste das prog ja wieder auf prom sichern

    gruss mario

  5. #5
    Registriert seit
    06.10.2003
    Beiträge
    3.445
    Danke
    453
    Erhielt 509 Danke für 411 Beiträge

    Standard

    Hallo,

    aah, das hängt dann wohl mit den Einträgen im Bausteinkopf "gültig im Ram" und "gültig im Eprom" zusammen (ab CPU943). Man muss alle Bausteine vom PG und nicht vom Eprom geladen haben, um sie editieren zu können.

    Ich habe einen Fall, da läd die CPU nach Urlöschen nicht vom Eprom. Gibt es dafür etwa eine ähnliche Erklärung? Reicht Urlöschen nicht, muss ich vielleicht die Pufferbatterie entfernen und Netzwiederkehr durchführen? Ich hatte es seit Jahren als CPU-Fehler angesehen.


    Gruss, Onkel

  6. #6
    Registriert seit
    23.11.2004
    Beiträge
    347
    Danke
    2
    Erhielt 28 Danke für 28 Beiträge

    Standard

    Hallo,

    nach einer Veränderung des Speicherausbaus bei AG 115U muß immer urgelöscht werden.
    Das ist auch am Blinken der Betriebsartenanzeige zu sehen.
    Bei intakter CPU muß zum Urlöschen die Batterie nicht entfern werden.

    Gruß
    raika

  7. #7
    Registriert seit
    27.08.2004
    Ort
    Bei Bremen
    Beiträge
    648
    Danke
    11
    Erhielt 12 Danke für 10 Beiträge

    Standard

    Die 115U hängt sich "gerne" mal auf. Ich hatte es schon einige Male, dass Urlöschen zwar die CPU "dumm" gemacht hat, aber nach dem Laden hängt sie sich auf.
    In einem solchen Fall schaue ich mir gerne die "rückseite" der CPU an (Ausbau) und entferne die Batterie. Danach läuft das gleiche Prg wieder....

    Es gibt wie schon gesagt die Möglichkeiten Bausteine (DB's) im Eprom zu hinterlegen. Wenn die S5 die Daten verändern soll, dann muss der Baustein in RAM kopiert werden.
    Gruß
    Heinz

  8. #8
    alfons Gast

    Standard

    Hallo Leute,
    Vielen Dank für die vielen Tipps.
    Inzwischen habe ich auch schon einen Tip von Siemens.

    Der entspricht dem was Onkel Dagobert vorschlägt:

    Die Bausteine sind codiert, d.h. nur funktionsfähig mit gestecktem EPROM.

    Man muss also eine Sicherung auf's PG ziehen, AG urlöschen und dann das Prog. vom PG auf das AG übertragen.
    Danach sollten alle Bausteine editierbar sein.

    p.s.
    Habe das ganze noch nicht ausprobiert ,weil ich beim übertragen Auf PG eine Fehlermeldung hatte ( DB zu gross ) und damit keine 100% Sicherung vorhanden war.
    Ich versuche es nächste Woche nochmal mit einer anderen Software, die auf meinem Uralt-Laptop stabiler läuft als Original-Siemens-S5.

    Vielen dank
    Alfons

  9. #9
    Registriert seit
    06.10.2003
    Beiträge
    3.445
    Danke
    453
    Erhielt 509 Danke für 411 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Alfons,

    der ausschlaggebende Tipp kam von Mario! Ich hatte daraufhin nur Schlußfolgerungen gezogen.

    Zitat Zitat von alfons
    ...Habe das ganze noch nicht ausprobiert ,weil ich beim übertragen Auf PG eine Fehlermeldung hatte ( DB zu gross ) und damit keine 100% Sicherung vorhanden war....
    Es könnte auch sein dass dieser DB vom Programm online erzeugt wird. Dieser trägt dann immer das Attribut "gültig im RAM".


    Gruss, Onkel

Ähnliche Themen

  1. TIA V11 beobachen vom FUB nicht möglich
    Von chriswin im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 20.07.2011, 11:44
  2. HW update nicht möglich???
    Von -Melanie- im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 03.03.2010, 15:25
  3. Zugriff auf CP 343-1 nicht möglich
    Von JandeFun im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 24.06.2008, 09:56
  4. OP5 seriell nicht möglich
    Von klauserl im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 28.08.2007, 00:26
  5. Umwandlung von Awl in Fup nicht möglich
    Von lexx im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 15.11.2005, 22:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •