Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 4 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 34

Thema: Problem die 2te

  1. #1
    Registriert seit
    09.10.2008
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Vorweg, entschuldigung, ich finde meinen alten Beitrag nicht mehr.


    Ich befinde mich derzeit in einer Schulischen Ausbildung zum staatlich geprüften Elektrotechniker und muss im Zuge dieser Ausbildung nun ein Schulisches Projekt aufbauen.

    Wir haben eine Übungstation bekommen von unseren Lehrern um eine PID Regelstrecke zu realisieren. Diese Übungstation wurde von der Firma Kösters gebaut und läuft dort anscheinend unter dem Namen Glühen und Härten.

    Diese Station verfügt über eine Halogen Lampe, vor dieser Halogenlampe ist ein PT100 befestigt der mit Hilfe eines Messumformers eine Spannung von 0-10V heraus gibt. Intern gibt es dann noch einen Dimmbaren Trafo der durch eine Eingangsspannung gesteuert werden kann .. 10V = 100 % an usw.

    Wir benutzen eine CPU 314 IFM die ja bekanntlich 3 Analoge Eingänge und einen Analogen Ausgang besitzt. Die Adressen hierfür sind PEW 128 bzw. PAW 128.

    Wir sind nun folgendermaßen vorgegangen:

    Wir haben das PEW128 durch einen FC105 gejagt und diesen Wert zwischen 0 und 10 Normiert damit eine gescheite Größe hatten die auch nachvollziebar ist.

    Diese Normierung, nennen wir sie einfach MD10 jagen wir auf den FB 41 der im OB 35 mit einer Cyklus Zeit von 100MS aufgerufen wird. Der FB 41 ist natürlich mit einem DB41 verbunden der mittels des PID Parametrieren Tools eingestellt wurde.

    Das alles klappt soweit auch wunderbar, nur jedoch kommt es zum Phänomen was sich keiner von uns wirklich erklären kann.

    Wenn wir NUR den Analogen Istwert des PT100 einlesen und an die SPS anschließen dann können wir wirklich Astrein die aktuelle Spannung einlesen. Heißt, wenn der Messumformer mir in dem Moment 3,5V raus gibt seh ich das auch genau so in der SPS. Schließe ich nun allerdings den geregelten Analogen Ausgang an fängt der Analoge Eingang plötzlich wie wild an zu Schwanken. Hierbei meine ich nun kein Schwanken von +- 0.01 V sondern ein Schwanken von +-3 V was mal eben bei meiner Regelung 30 Grad ausmacht.

    Natürlich lag die Vermutung nahe das wir über diesen Ausgang, sobald wir ihn einstecken irgend eine Störspannung in den Eingang Induzieren und haben dann natürlich mal die Abschiermung der jeweiligen Eingangs und Ausgangsleitung einseitig auf Masse gelegt. Dieses jedoch hat absolut keine Besserung gebracht.

    Komisch ist halt das wir den Eingang alleine wunderbar einlesen können, aber in Verbindung mit dem geregeltem Ausgang, den wir im übrigen direkt auf das PAW 128 schicken, nur Mist raus bekommen.

    Wir sind Ratlos, weiß vielleicht eventuell von euch jemand was genaueres oder hat einen Tip was wir machen können damit das nicht mehr vorkommt ?

    mfg
    Rash
    Zitieren Zitieren Problem die 2te  

  2. #2
    Registriert seit
    12.12.2006
    Ort
    Wehringen
    Beiträge
    1.471
    Danke
    248
    Erhielt 190 Danke für 155 Beiträge

    Standard

    Hallo,

    stell doch mal das Programm und den Schaltplan hier ein.

    So aus der Ferne tippe ich auf einen Verdrahtungsfehler

    Wie ist das:
    die Spannung vom Meßumformer ist konstant (wo gemessen), aber das PEW schwankt?



    MfG

  3. #3
    Rash ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.10.2008
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Was Schaltplan usw. angeht muss ich morgen machen.

    Zu deiner Frage, die Ausgabe Spannung des Messumformers ist IMMER Konstant und Schwankt nicht, steigt halt nur bei erwärmung kontinuierlich an Das PEW verhällt sich genauso wie die Spannung, aber nur wenn ich das PAW nicht anschließe. Sobald das PAW angeschlossen ist bleibt die Spannung konstant, aber in der SPS schwankt der Wert wie Irre.

  4. #4
    Registriert seit
    15.10.2007
    Ort
    St.Pölten
    Beiträge
    875
    Danke
    98
    Erhielt 200 Danke für 188 Beiträge

    Standard

    wo bearbeitest du das PAW128 in deinem Programm??
    Beginne jeden Tag mit einem lächeln,es kann dir nämlich während des Tages sehr schnell vergehen.

  5. #5
    Rash ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.10.2008
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Bearbeiten tue ich das PAW schlussendlich gar nicht. Mittels des FB 41 , regel ich durch den aktuellen istwert und einem sollwert den ich momentan einfach ran schreibe die Leistung der Halogen Lampe. Der Ausgang des FB 41 ist direkt das PAW128 , der FB41 hat ja einen direkten ausgang für die Pheripherie.

  6. #6
    Registriert seit
    15.10.2007
    Ort
    St.Pölten
    Beiträge
    875
    Danke
    98
    Erhielt 200 Danke für 188 Beiträge

    Standard

    hast du ausgänge die du bearbeitest??
    A128.x oder so??
    Beginne jeden Tag mit einem lächeln,es kann dir nämlich während des Tages sehr schnell vergehen.

  7. #7
    Rash ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.10.2008
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich nutze keinerlei Digitalen Ausgänge. Nur das eine Analoge Ausgangswort , PAW 128

  8. #8
    Rash ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.10.2008
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Was das Thema Verdrahtungsfehler angeht, ich wage zu bezweifeln das ich den Analogen Ausgang Falsch verdrahtet habe mit den 2 Strippen, da habe ich ja lediglich M(ana) und die AOu (Spannung) geschichte

  9. #9
    Registriert seit
    15.10.2007
    Ort
    St.Pölten
    Beiträge
    875
    Danke
    98
    Erhielt 200 Danke für 188 Beiträge

    Standard

    Beginne jeden Tag mit einem lächeln,es kann dir nämlich während des Tages sehr schnell vergehen.

  10. #10
    Rash ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.10.2008
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Die frage ist auf was du mich da genau stoßen willst ? Derjenige hatte nicht das Problem das der Istwert extrem schwankt sondern der Ausgangswert bei dem verrückt spielt

Ähnliche Themen

  1. OPC Problem routen problem
    Von kpeter im Forum Hochsprachen - OPC
    Antworten: 1
    Letzter Beitrag: 25.08.2010, 19:54

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •