Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: Zeitlimit im Prozessbetrieb ist ueberschritten

  1. #1
    Registriert seit
    04.01.2008
    Ort
    Wien
    Beiträge
    772
    Danke
    136
    Erhielt 39 Danke für 35 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich bin gerade bei einem Kunden und habe folgendes Problem:

    Ich verwende eine CPU 313 C 2DP und habe ein TP170A ueber MPI angschlossen. Profibusseitige sind ein Gateway (8mb Input\ 8mb output) und zwei Hengstler Profibusencoder angeschlossen. Zum Programmieren verwende ich ein Field PG und haenge an der MPI Schnittstell. MPI ist auf 187,5 eingestellt.

    Nun ist es so dass ich in AWL kaum die Haelfte der Statuswerte angezeigt bekomme. Weiters laesst sich nur ein Fenster beobachten. Bei einer Variablentabelle geht gar nix.

    Ich bekomme folgende Fehlermeldung:
    (DOAA) Zeitlimit im Prozessbetrieb ist ueberschritten (33:5341

    auch der Transfer dauert um einiges laenger als ich es gewohnt bin.

    Hatt jemand so ein Problem schon mal gehabt oder noch besser geloest.
    Von Siemens hab ich dazu nix sinnvolles bekommen aus ein AHA und das man sich wieder meldet. Nur warte ich nun schon einen Tag und morgen solls wieder mit dem Flieger weiter zum naechsten Kunden!
    irgendetwas ist ja immer...
    ING. Gerald Miedler
    Zitieren Zitieren Zeitlimit im Prozessbetrieb ist ueberschritten  

  2. #2
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.718
    Danke
    398
    Erhielt 2.400 Danke für 2.000 Beiträge

    Standard

    Hallo Gerri,
    wieviele Variablen laufen mit welcher Aktualisierungsrate über den MPI zum TP ? Ich könnte mir vorstellen, dass du bei der Aktualisierung zu schnell bist und dadurch für die PG-Funktionen zu wenig übrigbleibt ...

    Gruß
    LL

  3. #3
    Gerri ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    04.01.2008
    Ort
    Wien
    Beiträge
    772
    Danke
    136
    Erhielt 39 Danke für 35 Beiträge

    Standard

    Hi, die Vermutung hatte ich auch. sind wohl an die 600 mit 1s.
    irgendetwas ist ja immer...
    ING. Gerald Miedler

  4. #4
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.718
    Danke
    398
    Erhielt 2.400 Danke für 2.000 Beiträge

    Standard

    Zitat Zitat von Gerri Beitrag anzeigen
    Hi, die Vermutung hatte ich auch. sind wohl an die 600 mit 1s.
    Aber die sind doch nicht alle auf ständiger Aktualisierung oder auf der Seite, die du gerade siehst ...?
    Auf jeden Fall ist das schon eine Menge. Versuch mal die Rate bei den Variablen, die sich nicht so schnell ändern herabzusetzen ...
    Es gibt auch die Möglichkeit, Variablen, die sich gar nicht ändern (Parameter z.B.) nur auf einmalige Aktualisierung zu setzen ...

    ...

  5. #5
    Gerri ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    04.01.2008
    Ort
    Wien
    Beiträge
    772
    Danke
    136
    Erhielt 39 Danke für 35 Beiträge

    Standard

    Zitat Zitat von Gerri Beitrag anzeigen
    Hi, die Vermutung hatte ich auch. sind wohl an die 600 mit 1s.

    ok 250 und jetzt habe ich den erfassungszyklus bei einem drittel auf 10s raufgeschraubt. Leider ohne erfolg
    irgendetwas ist ja immer...
    ING. Gerald Miedler

  6. #6
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.718
    Danke
    398
    Erhielt 2.400 Danke für 2.000 Beiträge

    Standard

    ... ich frage noch einmal ...
    du hast bei einem TP170 auf einer Bildschirmseite 250 Variablen ?
    Was sind das für welche ? Kann man da vielleicht etwas zusammenfassen (viele Bits zu einem Byte oder Word) ?

  7. #7
    Registriert seit
    02.09.2008
    Beiträge
    80
    Danke
    11
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Was Larry meint, ist die Erfassungsoption "Zyklisch bei Verwendung", will sagen die Variable wird im aktuell sichtbaren Bild verwendet, also aktualisiert, bei Nichtverwendung wird sie im Umkehrschluss dann auch ignoriert.

  8. #8
    Gerri ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    04.01.2008
    Ort
    Wien
    Beiträge
    772
    Danke
    136
    Erhielt 39 Danke für 35 Beiträge

    Standard

    Nein, nicht auf einer Seite, auf 7 Bilder verteilt. Die wenigsten sind bits.
    Es sind OB82 und 86 Informationen sowie Daten fuer eine zwei Motoren.
    Betriebsmeldungen (7 Word) und einige andere Kleinigkeiten.
    Zyklisch bei Verwendung ist bei allen eingestellt.
    irgendetwas ist ja immer...
    ING. Gerald Miedler

  9. #9
    Registriert seit
    15.12.2007
    Beiträge
    712
    Danke
    84
    Erhielt 105 Danke für 94 Beiträge

    Standard

    Ich denke eher die CPU ist in der HW-Konfig in den Prozessbetrieb geschaltet worden. Dann kriegt man weniger im Online-Status angezeigt und die übertragung dauert länger. Hab das mal testweise bei einer CPU eingestellt.

    Auf jeden Fall findest du die Einstellung in den CPU-Eigenschaften in der HW-Konfig. Den Reiter etc kann ich dir jetzt ausm Kopf nicht sagen, aber du kannst ja mal danach suchen und hier posten was da eingestellt ist.

  10. Folgender Benutzer sagt Danke zu Astralavista für den nützlichen Beitrag:

    Gerri (10.11.2008)

  11. #10
    Registriert seit
    06.10.2003
    Beiträge
    3.411
    Danke
    451
    Erhielt 504 Danke für 407 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Gerri,

    überprüfe auch mal die eingestellte "Zyklusbelastung durch Kommunikation"! Zu finden unter den CPU-Eigenschaften - Zyklus/Taktmerker, default ist 20%.

    Oder auch die Einstellung "zulässige Zykluszeiterhöhung durch Testfunktionen" unter CPU-Eigenschaften - Schutz.


    Gruß, Onkel
    Geändert von Onkel Dagobert (31.10.2008 um 10:29 Uhr)
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •