Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 28

Thema: Analogbaugruppe

  1. #11
    Registriert seit
    01.11.2007
    Beiträge
    1.239
    Danke
    91
    Erhielt 407 Danke für 368 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Dann hast du evtl. eine andere Baugruppe auf der selben Adresse.
    Läuft die CPU denn ohne Programm an ?
    Im Kapitel 5.8 steht doch die Adressierung mit X2 drin. Versuch mal einen anderen Adressbereich.

    Grüße von HaDi

  2. #12
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    Hallo Lex,

    1. wo willst Du die Baugruppen den stecken? Im Zentralgerät oder im Erweiterungsgerät?
    2. Im welchem Peripheriebereich willst Du sie ansprechen? P- oder Q-Bereich?
    3. Gibt es Erweiterungsgeräte?

    zu 1.: Wenn Du die Baugruppe im ZG einbaust, kannst Du nur P-Bereich adressieren.
    zu 2.: Wenn Du den P-Bereich nutzt, MUSS die Adresse >127 sein. In jedem Fall kannst du die
    Baugruppe nur über PW, PY bzw QW, QB ansprechen. EW oder AW geht nicht, da diese nur bis 127
    adressiert werden können.
    zu 3.: Wenn es EGs gibt und Du die Baugruppe im ZG einbaust, kannst Du die Adresse in den
    EGs nicht mehr nutzen. Egal ob P- oder Q-Bereich!

    Ich hoffe ich konnte Dir ein wenig weiterhelfen.

    Grüße
    Gebs

  3. Folgender Benutzer sagt Danke zu Gebs für den nützlichen Beitrag:

    HaDi (07.11.2008)

  4. #13
    Registriert seit
    01.11.2007
    Beiträge
    1.239
    Danke
    91
    Erhielt 407 Danke für 368 Beiträge

    Standard

    Kapitel 6.1: Auf welchen Steckplätzen darf die Analogbaugruppe betrieben werden ?
    Im Zentralgerät 150U/S ... ist die Analogbaugruppe IP 243 nicht steckbar.
    Grüße von HaDi

    [edit]
    Nachtrag ( aus Kap. 5.8 ):
    Die Adresse muss zwischen 128 und 248 liegen.
    Also ( für Adresse 128 ) : Auf X2 die Brücke 5-14 schließen (alle anderen bleiben offen) und mit L PW/PY 128ff. bzw. T PW/PY 128ff. drauf zugreifen.
    [/edit]
    Geändert von HaDi (07.11.2008 um 18:33 Uhr) Grund: Nachtrag

  5. #14
    Lex_78 ist offline Benutzer
    Themenstarter
    Registriert seit
    20.10.2008
    Beiträge
    99
    Danke
    43
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von HaDi Beitrag anzeigen
    Dann hast du evtl. eine andere Baugruppe auf der selben Adresse.
    Läuft die CPU denn ohne Programm an ?
    Im Kapitel 5.8 steht doch die Adressierung mit X2 drin. Versuch mal einen anderen Adressbereich.

    Grüße von HaDi
    Hallo,

    Sorry hatte gar net mehr bemerkt das noch Beiträge dazugekommen waren!
    Hab schon versucht wie in 5.8 beschrieben, die Ausgänge anzusprechen...es hat leider net funktioniert. Wohl bemerkt möchte ich ja erst einaml Dig. Ausg. ansprechen...demnach kümmer ich mich erst einam l um die Analogen Klemmen net (X29 / X32)--> Sockel sind frei !!
    Ausserdem habe ich die Sockel X19 und D9 ebenfalls frei !!
    Muss eigentlich bei KLemme X2 ADB 7 immer gesetzt sein oder kann ich diese auch offen lassen und einfach ADB 3 ( AW 8 ) ansprechen ??
    P-Bereich --> proportionalbereich !?!
    Q-Bereich kann ich leider nix mit anfangen

    Mfg Lex

  6. #15
    Registriert seit
    01.11.2007
    Beiträge
    1.239
    Danke
    91
    Erhielt 407 Danke für 368 Beiträge

    Standard

    Da die Adresse >=128 sein soll wird es nicht ohne diesen Jumper gehen.
    Hast du denn ein Erweiterungsgerät und die Baugruppe da drin stecken ?

    Zum Thema P- und Q-Bereich (ohne Gewähr):
    Der P-Bereich ist eine Erweiterung des Prozessabbilds um die Adressen 128-255, er muss mit PW/PY direkt angesprochen werden und wird nicht, wie das Prozessabbild, von der CPU eingelesen.
    Der Q-Bereich ist m.W. eine nochmalige Erweiterung des Adressbereichs um 255 Bytes, auch er wird mit speziellen Befehlen gelesen/geschrieben (QB/QW). Um den Q-Bereich zu nutzen, muss m.W. das Erweiterungsgerät modifiziert werden (Brücken auf Rückwandplatine).

    Grüße von HaDi

  7. Folgender Benutzer sagt Danke zu HaDi für den nützlichen Beitrag:

    Lex_78 (10.11.2008)

  8. #16
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    Hallo Lex,

    erst einmal zu den Bereichen. Die Bezeichnungen stammen noch aus der Historie der S5:
    P-Bereich : Peripherie-Bereich (PW 0 - PW 254)
    Als dann größere Anlagen automatisiert wurden, reichte der P-Bereich nicht mehr aus und man erfand den
    Q-Bereich : erweiterter Peripherie-Bereich (QW 0 - QW 254)
    Warum Q ? Ich nehme an weil Q nach P im Alphabet kommt.
    Später kamen dann noch der IM3- und der IM4-Bereich dazu.

    Zu den Klemmen:
    lt. Handbuch Seite 5-11 MUSS die Brücke X2 ADB7 immer eingelegt sein.
    d.h., Deine Adresse ist (bei P-Peripherie) immer >= 128 und Du kannst die
    Ausgänge nur indirekt ansprechen.
    Willst Du den "Ausgang 128.7" ansprechen gehts nur so (oder ähnlich):
    U Bedingung
    = M x.7

    L MW x
    T PW 128

    Grüße
    Gebs

  9. Folgender Benutzer sagt Danke zu Gebs für den nützlichen Beitrag:

    Lex_78 (10.11.2008)

  10. #17
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    Da war HaDi ein wenig schneller
    Zitat Zitat von HaDi Beitrag anzeigen
    Da die Adresse >=128 sein soll wird es nicht ohne diesen Jumper gehen.
    Hast du denn ein Erweiterungsgerät und die Baugruppe da drin stecken ?

    Zum Thema P- und Q-Bereich (ohne Gewähr):
    Der P-Bereich ist eine Erweiterung des Prozessabbilds um die Adressen 128-255, er muss mit PW/PY direkt angesprochen werden und wird nicht, wie das Prozessabbild, von der CPU eingelesen.
    Der Q-Bereich ist m.W. eine nochmalige Erweiterung des Adressbereichs um 255 Bytes, auch er wird mit speziellen Befehlen gelesen/geschrieben (QB/QW). Um den Q-Bereich zu nutzen, muss m.W. das Erweiterungsgerät modifiziert werden (Brücken auf Rückwandplatine).

    Grüße von HaDi
    @HaDi:
    Wenn Du zum koppeln der EGs eine IM314 benutzt, kannst Du den Bereich auf der IM über Schalter einstellen.

    Grüße
    Gebs

  11. Folgender Benutzer sagt Danke zu Gebs für den nützlichen Beitrag:

    Lex_78 (10.11.2008)

  12. #18
    Lex_78 ist offline Benutzer
    Themenstarter
    Registriert seit
    20.10.2008
    Beiträge
    99
    Danke
    43
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Gebs Beitrag anzeigen
    Hallo Lex,

    1. wo willst Du die Baugruppen den stecken? Im Zentralgerät oder im Erweiterungsgerät?
    2. Im welchem Peripheriebereich willst Du sie ansprechen? P- oder Q-Bereich?
    3. Gibt es Erweiterungsgeräte?

    zu 1.: Wenn Du die Baugruppe im ZG einbaust, kannst Du nur P-Bereich adressieren.
    zu 2.: Wenn Du den P-Bereich nutzt, MUSS die Adresse >127 sein. In jedem Fall kannst du die
    Baugruppe nur über PW, PY bzw QW, QB ansprechen. EW oder AW geht nicht, da diese nur bis 127
    adressiert werden können.
    zu 3.: Wenn es EGs gibt und Du die Baugruppe im ZG einbaust, kannst Du die Adresse in den
    EGs nicht mehr nutzen. Egal ob P- oder Q-Bereich!

    Ich hoffe ich konnte Dir ein wenig weiterhelfen.

    Grüße
    Gebs
    Hallo,
    verwende die Baugruppe im *ZG* sie sitzt jetzt auch in einer 135_U ohne zusätzliche *EG´s*...
    lässt sich aber trotzdem net zum laufen bringen...
    Versuche im OB1 über L KH FF / T PW 128 ...die Ausgäange anzusprechen...leider ohne Erfolg.
    Trotzdem danke für die Hilfe.

    Mfg Lex

  13. #19
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    Hast Du die Brücke A-B eingelegt?
    Muss bei Einsatz in einem ZG

  14. Folgender Benutzer sagt Danke zu Gebs für den nützlichen Beitrag:

    Lex_78 (11.11.2008)

  15. #20
    Registriert seit
    01.11.2007
    Beiträge
    1.239
    Danke
    91
    Erhielt 407 Danke für 368 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wenn du 128 als Baugruppenadresse eingestellt hast, solltest du mal T PY133 versuchen, um die Digitalausgänge anzusteuern (Handbuch, Kap. 7.5.2).

    Grüße von HaDi

  16. Folgender Benutzer sagt Danke zu HaDi für den nützlichen Beitrag:

    Lex_78 (11.11.2008)

Ähnliche Themen

  1. Analogbaugruppe 465 7LA13
    Von Bruno im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 02.04.2009, 00:00
  2. Analogbaugruppe
    Von magmaa im Forum Programmierstrategien
    Antworten: 13
    Letzter Beitrag: 10.06.2007, 19:15
  3. Analogbaugruppe
    Von Markus23 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 01.03.2006, 11:38
  4. Analogbaugruppe SM 332
    Von jupiter_jonas im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 10.11.2005, 17:59
  5. Analogbaugruppe in KM PS 316
    Von Dirk69 im Forum Sonstige Steuerungen
    Antworten: 0
    Letzter Beitrag: 20.10.2003, 17:32

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •