Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 20

Thema: Prob. mit meiner Schrittkette

  1. #1
    Registriert seit
    27.05.2008
    Beiträge
    21
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Kann mir jemand mal sagen wo bei meiner Schrittkette das Problem ist?

    Und zwar funktioniert die Zählfunktion (Stückzahl) nicht , er zeigt mir zwar im FB1 an wie oft der Impuls von der Gabellichtschranke kommt aber der Scheibalken geht einfach nicht nach unten und wenn ich während dem Betrieb den BCD Schalter tippe geht die SPS in Stop, wenn ich eine 3 reintippe, bei einer 1 oder 2 nicht ok damit kann ich ja noch leben aber nicht das der schneidbalken nicht runter geht. Die BCD schalter habe ich mit dem Lauflicht auch schon kontolliert und das funktioniert einwandfrei.


    Also ich baue für meine Prüfung einen Einzeladerablängautomaten.
    Auf dem Schaltschrank sind 2 umlenkrollen dann eine V-Schiene dann kommt der Gleichstrommotor mit Treibrad und gegenlaufrolle. Am treibrad ist eine lochscheibe montiert die von einer Lichtschranke abgefragt wird. zum Schluss kommt ein Pneumatikzlyinder der ein Schneidbalken runter drückt und die einzelader ablängt.

    Alle E/A habe ich getestet funktionieren auch soweit.
    Angehängte Dateien Angehängte Dateien
    Zitieren Zitieren Prob. mit meiner Schrittkette  

  2. #2
    Registriert seit
    15.10.2007
    Ort
    St.Pölten
    Beiträge
    875
    Danke
    98
    Erhielt 200 Danke für 188 Beiträge

    Standard

    wenn ich während dem Betrieb den BCD Schalter tippe geht die SPS in Stop
    dein stückzähler ist ein int und du hast einen BCD schalter.geht die cpu in stop wenn du größer 9 bist?
    Beginne jeden Tag mit einem lächeln,es kann dir nämlich während des Tages sehr schnell vergehen.

  3. #3
    Klappi ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.05.2008
    Beiträge
    21
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    die cpu geht nur in stop wenn ich während die cpu auf run ist höher als 3 einstelle.Benutze ein 3stelligen bcd schalter.

    wenn ich im stop die zahlen egal welche eintippe und dann die CPU auf run mache, funzt das wunderbar in der simulation bloß was is das prob das mein schneidbalkennicht runter fährt

  4. #4
    Registriert seit
    15.10.2007
    Ort
    St.Pölten
    Beiträge
    875
    Danke
    98
    Erhielt 200 Danke für 188 Beiträge

    Standard

    länge ist muß größer 10 sein sonst schneidet er nicht,aber wie wird deine länge 10??

    Code:
      U(    
          L     #laenge_ist
          L     10                 
          >=I                   // meinst du hier kleiner 10??
          )     
          U     #Schritt3
          S     #Schritt4
          U(    
          ON    #Stop
          O     #Schritt5
          )     
          R     #Schritt4
    Beginne jeden Tag mit einem lächeln,es kann dir nämlich während des Tages sehr schnell vergehen.

  5. #5
    Klappi ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.05.2008
    Beiträge
    21
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    das wird doch über die flanke der gabellichtschranke am zähler abgerufen.
    hmm is das awl was du da benutzt? damit kenn ich mich gar nicht so gut aus bin leider auch kein experte in Step 7

  6. #6
    Registriert seit
    15.06.2008
    Beiträge
    119
    Danke
    19
    Erhielt 24 Danke für 19 Beiträge

    Standard

    Zitat Zitat von Klappi Beitrag anzeigen
    hmm is das awl was du da benutzt?
    Nein, das ist eine Phantasiedarstellung die der Gerhard vor ein paar Jahren erfunden hat und sich im Forum großer Beliebtheit erfreut. Mit AWL hat es aber wenig zu tun.

    Ein ausführliches Nachschlagewerk ist laut meinen Informationen noch in Arbeit. Gerhard scheint aber auch neben dem Entwickeln neuer Sprachkonstrukte einer anderen Arbeit nach zu gehen.

    Hoffe geholfen zu haben.

  7. Folgender Benutzer sagt Danke zu forendiva für den nützlichen Beitrag:

    zotos (08.11.2008)

  8. #7
    Registriert seit
    15.10.2007
    Ort
    St.Pölten
    Beiträge
    875
    Danke
    98
    Erhielt 200 Danke für 188 Beiträge

    Standard

    du sagst und laenge ist >= 10 und schritt3 setze schritt4.probier mal einen vergleicher <= und dann funktioniert es.zuminderst bei mir wenn ich in plc sim teste zählt er bei mir hoch.und der ausgang A0.6 Prese schließen kommt auch.

    @forendiva
    es lebe dein sarkasmus
    Geändert von Gerhard K (08.11.2008 um 21:16 Uhr)
    Beginne jeden Tag mit einem lächeln,es kann dir nämlich während des Tages sehr schnell vergehen.

  9. #8
    Klappi ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.05.2008
    Beiträge
    21
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    ok werde ich dann montag ausprobieren, habe leider kein plc sim da
    hoffe das daß der Fehler war, weil Montag mein letzter Tag zum Ausprobieren ist.

  10. #9
    Registriert seit
    23.10.2004
    Ort
    zu Hause
    Beiträge
    1.041
    Danke
    370
    Erhielt 406 Danke für 274 Beiträge

    Standard

    Zitat Zitat von forendiva Beitrag anzeigen
    Nein, das ist eine Phantasiedarstellung die der Gerhard vor ein paar Jahren erfunden hat und sich im Forum großer Beliebtheit erfreut. Mit AWL hat es aber wenig zu tun.

    Ein ausführliches Nachschlagewerk ist laut meinen Informationen noch in Arbeit. Gerhard scheint aber auch neben dem Entwickeln neuer Sprachkonstrukte einer anderen Arbeit nach zu gehen.

    Hoffe geholfen zu haben.


    Du blöde Nuß!!!
    Ich weiss, dass hier echte Hilfe gefragt ist, denn ich habe in dem selben Laden meine Abschlussprüfung abgelegt. Wenn man für den ganzen Mist alleine verantwortlich ist (inkl. aller mechanischen und elektrischen Zeichnungen und Dokumentationen), rennt einem die Zeit weg bis zum Abgabetermin. 3 1/2 Jahre billige Arbeitskraft und am Ende eine Prüfung hinlegen, die einer Technikerschule würdig ist...

    Gruß,

    dia
    Diese Signatur enthält Inhalte von WTF und ist in Deinem Land nicht verfügbar!

  11. Folgende 3 Benutzer sagen Danke zu diabolo150973 für den nützlichen Beitrag:

    HDD (08.11.2008),lorenz2512 (08.11.2008),Unimog-HeizeR (08.11.2008)

  12. #10
    Registriert seit
    30.07.2007
    Beiträge
    40
    Danke
    16
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wieso in NW5 <= Vergleichen ? Der Zylinder soll doch bestimmt nach einer gewissen Anzahl von Impulsen ausgefahren werden (in diesem Fall 4),Schritt 4 wird gesetzt und in NW 13 wird #laenge_ist wieder Null gesetzt.
    Würde noch in NW8 #F1_6 als "stat" deklarieren und in NW14 hast du die Negierung für #Stop vergessen.
    Das Einlesen im FC2 funktioniert anscheinend auch nicht so wie es gedacht war.
    Gruß bwink68

  13. Folgender Benutzer sagt Danke zu bwink68 für den nützlichen Beitrag:

    Gerhard K (09.11.2008)

Ähnliche Themen

  1. Wie kommuniziere ich mit meiner 810 T GA2
    Von Matzevr6 im Forum Simatic
    Antworten: 17
    Letzter Beitrag: 13.08.2010, 15:51
  2. AWL Prob
    Von Blanky04 im Forum Simatic
    Antworten: 24
    Letzter Beitrag: 21.07.2010, 22:03
  3. Auflösung meiner SPS-Teile....
    Von rolly009 im Forum Suche - Biete
    Antworten: 5
    Letzter Beitrag: 20.10.2009, 21:39
  4. Prob mit Motor der einfach los fährt.
    Von maxi im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 24.03.2009, 21:33
  5. Simatic 3T-Steuerung mit Eingangs-Prob
    Von Oeffi im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 20.07.2006, 15:49

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •