Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: Symbolik im DB

  1. #1
    Registriert seit
    06.03.2008
    Ort
    Neustadt/Wstr.
    Beiträge
    276
    Danke
    35
    Erhielt 42 Danke für 39 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich musste heut an eine "alte" Anlage die mit einer 400er SPS läuft. Ich habe nur die Symbolik von einem DB verändert (es waren genau 12 Bits) und anschließend konnte ich den DB nicht mehr beobachten (vorher konnte ich das natürlich).

    Woran könnte das liegen, ich dachte immer die SPS kennt keine Symbolik die ist doch nur für mich, oder irre ich mich in diesem Punkt?
    Lebe so als sei jeder Tag dein letzter -
    eines Tages wirst Du recht haben
    Zitieren Zitieren Symbolik im DB  

  2. #2
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.751
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    Der DB in der SPS wird aber mit Zeitstempel und gewissen Prüfsummen abgelegt,
    so dass Step7 erkennt ob es sich noch um den "gleichen" Stand handelt.

    Da hilft wohl nur Neuübertragen, oder falls das nicht geht, über eine Variablentabelle.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  3. #3
    Registriert seit
    08.11.2006
    Ort
    Uckermark
    Beiträge
    903
    Danke
    201
    Erhielt 256 Danke für 208 Beiträge

    Standard

    Die "Brille" ergraut nach jeder Änderung des DB's, auch wenn es nur die Symbolik ist.
    Schließe den Editor einfach und öffne den DB neu, dann sollte sich Dieser auch wieder beobachten lassen (behaupte ich einfach mal).
    Neue Ideen begeistern jene am meisten, die auch mit den alten nichts anzufangen wussten.
    Karl Heinrich Waggerl (1897-1973)

  4. #4
    Full Flavor ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.03.2008
    Ort
    Neustadt/Wstr.
    Beiträge
    276
    Danke
    35
    Erhielt 42 Danke für 39 Beiträge

    Standard

    Zitat Zitat von MSB Beitrag anzeigen
    Der DB in der SPS wird aber mit Zeitstempel und gewissen Prüfsummen abgelegt,
    so dass Step7 erkennt ob es sich noch um den "gleichen" Stand handelt.

    Da hilft wohl nur Neuübertragen, oder falls das nicht geht, über eine Variablentabelle.

    Mfg
    Manuel
    Hätte ich vielleicht sagen sollen, besser spät als nie. Ich habe das schon öfter gemacht da hat alles geklappt!

    Also:

    Symbolik geändert
    speichern
    Brille

    der DB lässt sich öffnen diesmal gings aber nicht.
    Lebe so als sei jeder Tag dein letzter -
    eines Tages wirst Du recht haben

  5. #5
    Full Flavor ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.03.2008
    Ort
    Neustadt/Wstr.
    Beiträge
    276
    Danke
    35
    Erhielt 42 Danke für 39 Beiträge

    Standard

    Zitat Zitat von OHGN Beitrag anzeigen
    Die "Brille" ergraut nach jeder Änderung des DB's, auch wenn es nur die Symbolik ist.
    Schließe den Editor einfach und öffne den DB neu, dann sollte sich Dieser auch wieder beobachten lassen (behaupte ich einfach mal).
    nach dem speichern wird die brille wieder sichtbar
    Lebe so als sei jeder Tag dein letzter -
    eines Tages wirst Du recht haben

  6. #6
    Registriert seit
    01.10.2007
    Ort
    Waiblingen
    Beiträge
    3.317
    Danke
    767
    Erhielt 536 Danke für 419 Beiträge

    Standard

    Zitat Zitat von Full Flavor Beitrag anzeigen
    ...
    der DB lässt sich öffnen diesmal gings aber nicht.
    was ist das Problem? Brille grau? Kommt eine Meldung? ...?

    mit "das Auto läuft nicht" kommen wir nicht weiter. Beschreib doch mal genauer, was passiert! w.z.B.: wenn ich den Zündschlüssel rumdreh, dann ...

  7. #7
    Full Flavor ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.03.2008
    Ort
    Neustadt/Wstr.
    Beiträge
    276
    Danke
    35
    Erhielt 42 Danke für 39 Beiträge

    Standard

    Zitat Zitat von Perfektionist Beitrag anzeigen
    was ist das Problem? Brille grau? Kommt eine Meldung? ...?

    mit "das Auto läuft nicht" kommen wir nicht weiter. Beschreib doch mal genauer, was passiert! w.z.B.: wenn ich den Zündschlüssel rumdreh, dann ...
    Sorry

    Der DB ist nicht identisch mit dem DB in der SPS
    Lebe so als sei jeder Tag dein letzter -
    eines Tages wirst Du recht haben

  8. #8
    Registriert seit
    08.11.2006
    Ort
    Uckermark
    Beiträge
    903
    Danke
    201
    Erhielt 256 Danke für 208 Beiträge

    Standard

    Was sagt denn ein Offline / Online Vergleich?
    Vielleicht hast Du versehentlich einen Datentyp geändert...
    Letzte Möglichkeit: den Online-DB aus dem Onlineordner in den Offlineordner zurückkopieren. Die offline geänderten Symbole sollten dabei ja erhalten bleiben.
    Neue Ideen begeistern jene am meisten, die auch mit den alten nichts anzufangen wussten.
    Karl Heinrich Waggerl (1897-1973)

  9. #9
    Registriert seit
    01.10.2007
    Ort
    Waiblingen
    Beiträge
    3.317
    Danke
    767
    Erhielt 536 Danke für 419 Beiträge

    Standard

    Zitat Zitat von Full Flavor Beitrag anzeigen
    ...
    Der DB ist nicht identisch mit dem DB in der SPS
    Also Meldung 319:1
    Der angezeigte Baustein stimmt nicht mit dem Baustein auf der CPU überein und kann deshalb nicht beobachtet werden.
    Zitat Zitat von Full Flavor Beitrag anzeigen
    ...
    Ich habe das schon öfter gemacht da hat alles geklappt!
    ...
    Bei mir ging es eben nicht - und ich denke, mit Siemens-S7 wird grundsätzlich dieser Zeitstempelkonflikt auftreten.

    Aber die Frage ist prinzipiell berechtigt: warum bekommt der Baustein einen neuen Zeitstempel, wenn denn nur die Symbolik, aber die Struktur nicht geändert wurde.

  10. #10
    Full Flavor ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.03.2008
    Ort
    Neustadt/Wstr.
    Beiträge
    276
    Danke
    35
    Erhielt 42 Danke für 39 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von OHGN Beitrag anzeigen
    Was sagt denn ein Offline / Online Vergleich?
    Vielleicht hast Du versehentlich einen Datentyp geändert...
    Letzte Möglichkeit: den Online-DB aus dem Onlineordner in den Offlineordner zurückkopieren. Die offline geänderten Symbole sollten dabei ja erhalten bleiben.
    Bei den Vergleichen waren nur die werte im DB anders was ja aber normal ist.

    Ich hab auch mit dem DB in der Projektsicherung verglichen außer der Symbolik hab ich nichts geändert. Ich konnte jedoch mit dem DB in der Projektsicherung wieder online gehen.

    Wie gesagt das hat schon ein paar mal funktioniert jetzt wollt ich halt mal fragen was ich falsch gemacht haben könnte
    Lebe so als sei jeder Tag dein letzter -
    eines Tages wirst Du recht haben

Ähnliche Themen

  1. Netzwerktitel aus Symbolik ?
    Von goldi63 im Forum Simatic
    Antworten: 20
    Letzter Beitrag: 07.10.2011, 06:29
  2. SCL Symbolik
    Von bluebird277 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 15.09.2011, 11:43
  3. Automatisierung und symbolik
    Von WIX im Forum Stammtisch
    Antworten: 4
    Letzter Beitrag: 04.05.2009, 09:53
  4. Problem mit Symbolik
    Von Shughart im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 14.08.2008, 16:20
  5. Symbolik auslesen
    Von Jelly im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 06.10.2006, 15:36

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •