Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Datenbaustein und DP/DP Koppler

  1. #1
    Registriert seit
    14.07.2005
    Beiträge
    298
    Danke
    27
    Erhielt 18 Danke für 15 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich muss bei meinem aktuellen Projekt mit der übergeordneten Steuerung über einen DP/DP Koppler kommunizieren.

    Im Prinzip habe ich das schon einmal gemacht um einzelne Bits (Schnittstellen-Signale) auszutauschen.
    Also einfach E/A Bereich in der HW-Konfig festgelegt und direkt im Programm verwendet.

    Eigentlich kinderleicht.

    Aber jetzt muss ich zu den Schnittstellensignalen noch mehrere Strings übertragen.
    Ich habe mich schon mit der Suchfunktion etwas schlau gemacht und denke das ich das auch verstanden habe.

    Mein Problem ist das ich hier keinen Testaufbau machen kann weil ich keine zweite Profibus SPS hier habe und die Maschine eigentlich funktionsfertig zum Kunden geschickt wird und nur im Notfall eine Inbetriebnahme von uns stattfinden wird.
    (Also ich geh schon davon aus das diese Inbetriebnahme gefinitiv stattfinden wird, aber ich will natürlich auch eine funktionsfähige SPS ausliefern).

    Mir wäre es recht wenn ihr mir vielleicht kurz auf die Sprünge helfen könntet:

    Ich stell mir das so vor das ich in der HW-Konfig den E/A Bereich genügend groß festlege und dann in einem FC mit einem BLK MOV die Eingangs-Bytes in einen DB schiebe.
    Diesen DB verwende ich dann in meinem Programm.
    Die Ausgangssignale schiebe ich ebenfalls mit BLK MOV auf die Ausgangs-Bytes des Kopplers.

    Ich denke so müsste es doch funktionieren !?

    Muss ich dabei noch etwas beachten, außer das sich die E/A Bereiche beider DP/DP Koppler Konfigurationen decken müssen?

    Gruß smartie
    Zitieren Zitieren Datenbaustein und DP/DP Koppler  

  2. #2
    Registriert seit
    01.11.2007
    Beiträge
    1.237
    Danke
    91
    Erhielt 407 Danke für 368 Beiträge

    Standard

    Wenn 244 Bytes genügen und du mit
    sich die E/A Bereiche beider DP/DP Koppler Konfigurationen decken müssen
    meinst, dass jeweils zu einen E-Modul auf der Gegenseite das passende A-Modul und umgekehrt gehört, dann denke ich auch, dass das so funktionieren müsste.

    Grüße von HaDi

  3. #3
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    blockmove funktioniert nur im e/a-bereich der im prozessabbild abgebildet werden kann.
    für den peripheriebereich nimmst du sfc14/15
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  4. #4
    smartie ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.07.2005
    Beiträge
    298
    Danke
    27
    Erhielt 18 Danke für 15 Beiträge

    Standard

    Hallo zusammen,

    insgesamt will ich 50 Byte über den DP/DP Koppler übertragen, der E/A Bereich kann im Prozess abgebildet werden (EB 80 / AB 80 aufwärts).

    Muss also funktionieren wenn ich das über BLK MOV mache, und sieht auch so aus wenn ich den ersten Eingang (E80.0) setze ist das entsprechende Bit im DB gesetzt.

    Noch eine kurze Frage:

    Meine SPS meldet einen BF und einen SF, geht aber nicht in Stop.
    Entsprechende OB´s sind keine geladen.

    Ich denke mal das liegt daran das der andere Teilnehmer am DP/DP Koppler fehlt?
    Oder habe ich da was falsch gemacht?

    Gruß smartie

  5. #5
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    wenn der koppler auf der gegenseite nicht korrekt parametriert ist hast du einen bf.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  6. #6
    smartie ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.07.2005
    Beiträge
    298
    Danke
    27
    Erhielt 18 Danke für 15 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ok das habe ich mir schon gedacht, weil ich ja auf der Gegenseite vom DP/DP Koppler nichts hängen habe (am Koppler leuchten ja auch alle LED´s rot).

    Das heisst also das müsste bei der Inbetriebnahme, wenn der Kunde sich ansteckt weggehen.

    Danke

    smartie

Ähnliche Themen

  1. DP DP Koppler...
    Von AndreK im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 25.05.2011, 09:09
  2. Dp-Koppler
    Von PG710 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 19.12.2009, 22:54
  3. DP/DP-Koppler
    Von Elektriker im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 17.10.2009, 09:26
  4. Antworten: 4
    Letzter Beitrag: 23.08.2006, 15:02
  5. DP Koppler
    Von Kojote im Forum HMI
    Antworten: 1
    Letzter Beitrag: 14.04.2005, 14:30

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •