Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 21 bis 30 von 32

Thema: Peripherieausgänge richtig nutzen

  1. #21
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    zur A74 gibt es eine gsd-datei, die du auf jeden fall installieren mußt. hast du das schon gemacht?
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  2. #22
    Maik Eng ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.12.2008
    Beiträge
    15
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    naja, welche meinst du denn. ich arbeite an einem "win-mod"-rechner mit anderen worten. der wurde bereits für den einsatz mit simatic und winmod konfiguriert. wie bekomme ich das denn raus ob sie installiert wurde?
    wie gesagt ne verbindung bei verwendung der ausgänge bis 128 funktioniert ja.

  3. #23
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    die gsd-datei ist für die steuerung, also muß in die S7-hardware eingebunden werden.
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  4. #24
    Maik Eng ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.12.2008
    Beiträge
    15
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    wie bekomme ich das raus ob sie installiert ist oder nicht?

  5. #25
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    du könntest es im hardware-katalog in der HW-konfiguration auswählen.
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  6. #26
    Maik Eng ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.12.2008
    Beiträge
    15
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    also daran liegt es nicht. meine hardware.konfig müsste theoretisch funktionieren da der fehler erst angezeigt wird, nachdem ich den OB1 in die cpu geladen habe. ich erhalte folgende fehlermeldung nach dem laden...

    Diagnosepuffer der Baugruppe CPU 315-2 DP
    Bestell-Nr./ Bezeichn. Komponente Ausgabestand
    6ES7 315-2AG10-0AB0 Hardware 6
    - - - Firmware V 2.6.3
    Boot Loader Firmware-Erweiterung A 0.21.0
    Baugruppenträger: 0
    Steckplatz: 2

    Ereignis 1 von 100: Ereignis-ID 16# 4562
    STOP durch Programmierfehler (OB nicht geladen oder nicht möglich, bzw. kein FRB vorhanden )
    Unterbrechungstelle im Anwenderprogramm: Zyklisches Programm (OB 1)
    Prioritätsklasse: 1
    FC-Nummer: 150
    Bausteinadresse: 18
    Bisheriger Betriebszustand: RUN
    Angeforderter Betriebszustand: STOP (intern)
    interner Fehler, kommendes Ereignis
    15:23:03.237 08.12.2008



    ...ich komme einfach nicht weiter

  7. #27
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    die hardwarekonfig ansich funktioniert so, ja, ABER sie macht nicht, was du willst PUNKT

    1. hast du die gsd-datei gefunden und eingebunden?
    2. was sagt ereignis 2 vonn 100?
    3. was ist im FC150 gemacht?
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  8. Folgender Benutzer sagt Danke zu vierlagig für den nützlichen Beitrag:

    Maik Eng (08.12.2008)

  9. #28
    Maik Eng ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.12.2008
    Beiträge
    15
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    sorry aber ich versteh nicht wie du das meinst mit der gsdf-datei? im hw-katalog sind einige gsd-dateien dabei und wie soll ich die einbinden?
    ich habe die call-befehle im ob schon getauscht, dann erscheint in der fehlermeldung statt fc150>> fc151. und im fc150 steht folgendes...


    NW 1

    O M 1.1
    ON M 1.1
    = M 1.1

    NW 2

    U M 1.1
    = L 0.0
    U L 0.0
    U DB61.DBX 3.5
    = M 712.0
    U L 0.0
    U DB61.DBX 3.6
    = M 712.1
    U L 0.0
    SPBNB _001
    L DB61.DBW 4
    T MW 710
    _001: NOP 0


    NW 3

    U M 1.1
    = L 0.0
    U L 0.0
    U DB61.DBX 12.5
    = M 702.0
    U L 0.0
    U DB61.DBX 12.6
    = M 702.1
    U L 0.0
    U DB61.DBX 12.7
    = M 702.2
    U L 0.0
    U DB61.DBX 13.0
    = M 702.3
    U L 0.0
    SPBNB _002
    L DB61.DBW 16
    T MW 714
    _002: NOP 0

    das NW3 wiederholt sich 7mal nur mit anderen adressen und im letzten NW steht...

    NW 11

    U M 1.1
    = L 0.0
    U L 0.0
    U DB61.DBX 113.1
    = M 712.3
    U L 0.0
    SPBNB _00a
    L DB61.DBD 72
    T MD 730
    _00a: NOP 0
    U L 0.0
    SPBNB _00b
    L DB61.DBD 76
    T MD 734
    _00b: NOP 0
    U L 0.0
    SPBNB _00c
    L DB61.DBD 88
    T MD 738
    _00c: NOP 0


    zu punkt 2...


    Ereignis 2 von 100: Ereignis-ID 16# 2522
    Bereichslängenfehler beim Lesen
    Global -DB ,Bitzugriff, Zugriffsadresse: 3
    Angeforderter OB: Programmierfehler-OB (OB 121)
    OB nicht vorhanden oder gesperrt oder nicht startbar im aktuellen Betriebszustand
    interner Fehler, kommendes Ereignis
    15:23:03.225 08.12.2008

    Ereignis 3 von 100: Ereignis-ID 16# 4302
    Betriebszustandsübergang von ANLAUF nach RUN
    Anlaufinformation:
    - Uhr für Zeitstempel bei letztem NETZ-EIN gepuffert
    - Einprozessorbetrieb
    Aktuelle/letzte durchgeführte Anlaufart:
    - Neustart (Warmstart) über Betriebsartenschalter; letzter NETZ-EIN gepuffert
    Zulässigkeit bestimmter Anlaufarten:
    - manueller Neustart (Warmstart) zulässig
    - automatischer Neustart (Warmstart) zulässig
    Letzte gültige Bedienung oder Einstellung der automatischen Anlaufart bei NETZ-EIN:
    - Neustart (Warmstart) über Betriebsartenschalter; letzter NETZ-EIN gepuffert
    Bisheriger Betriebszustand: ANLAUF (Neustart/Warmstart)
    Angeforderter Betriebszustand: RUN
    kommendes Ereignis
    15:23:03.211 08.12.2008

    Ereignis 4 von 100: Ereignis-ID 16# 1381
    Manuelle Neustart (Warmstart)-Anforderung
    STOP-Ursache: STOP durch Peripheriezugriffsfehler (OB nicht geladen oder nicht möglich, bzw. kein FRB vorhanden)
    Anlaufinformation:
    - Anlauf ohne geänderten Systemausbau
    - keine Soll-/Istdifferenz vorhanden
    - Uhr für Zeitstempel bei letztem NETZ-EIN gepuffert
    - Einprozessorbetrieb
    Aktuelle/letzte durchgeführte Anlaufart:
    - Neustart (Warmstart) über Betriebsartenschalter; letzter NETZ-EIN gepuffert
    Zulässigkeit bestimmter Anlaufarten:
    - manueller Neustart (Warmstart) zulässig
    - automatischer Neustart (Warmstart) zulässig
    Letzte gültige Bedienung oder Einstellung der automatischen Anlaufart bei NETZ-EIN:
    - Neustart (Warmstart) über Betriebsartenschalter; letzter NETZ-EIN gepuffert
    Angeforderter OB: Anlauf-OB (OB 100)
    OB nicht vorhanden oder gesperrt oder nicht startbar im aktuellen Betriebszustand
    kommendes Ereignis
    15:23:03.209 08.12.2008
    Geändert von Maik Eng (08.12.2008 um 15:28 Uhr)

  10. #29
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von Maik Eng Beitrag anzeigen
    sorry aber ich versteh nicht wie du das meinst mit der gsdf-datei? im hw-katalog sind einige gsd-dateien dabei und wie soll ich die einbinden?
    hast du die entsprechende zur winMOD A74-konfiguration gefunden? dann anklicken und auf deinen bus ziehen.
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  11. #30
    Maik Eng ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.12.2008
    Beiträge
    15
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    nein, die kann ich leider nicht finden. ob es dazu nen download gibt. ich weiß auch nicht ob das die ursache dafür ist, da ich wie gesaagt schon volle funktion hatte als ich ausgänge bis 128 verwendet habe.

Ähnliche Themen

  1. SFB's nutzen
    Von Andy_Scheck im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 02.10.2009, 14:12
  2. Uhrzeit des MPs nutzen
    Von Thorben im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 02.03.2009, 15:03
  3. Mehrfachverbindung von LibNoDave nutzen
    Von GvOdin im Forum Hochsprachen - OPC
    Antworten: 4
    Letzter Beitrag: 28.02.2009, 09:37
  4. PC als Bedieneinheit nutzen
    Von BodyKra im Forum HMI
    Antworten: 5
    Letzter Beitrag: 16.08.2007, 16:15
  5. OPC ActivX in Access nutzen
    Von Giraffofant im Forum Hochsprachen - OPC
    Antworten: 1
    Letzter Beitrag: 08.02.2007, 22:12

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •