Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: Belegung des Torque bei MC_MoveToEndPos

  1. #1
    Registriert seit
    06.12.2008
    Beiträge
    15
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    Habe mal wieder eine kleine Frage zu meiner CPU 315T-2DP.

    Ich habe das Technologiepaket V4.1 Installiert und versuche gerade einen 4Achs roboter zu programmieren. Der Greifer des Roboters is in der Technologie Konfiguration als elektrische Achse (Linearachse, Positionierachse, Festanschlagserkennung über Schleppabstand) konfiguriert und mit einem Inkrementgeber ausgestattet. Nun möchte ich mit dem Baustein des Technologiepaketes MC_MoveToEndPos auf Festanschlag fahren. Wie muss ich nun den Eingang Torque dieses Bausteines belegen. soweit ich weiss benötigt man den Torque nur wenn man eine hydraulische Achse hat. wie muss ich diesen aber bei einer elektrischen Achse belegen. Den Motor Steuere ich über eine IM 174 an.

    viele Grüße

    Dani
    Geändert von Daniel_79 (07.12.2008 um 12:56 Uhr)
    Zitieren Zitieren Belegung des Torque bei MC_MoveToEndPos  

  2. #2
    Registriert seit
    21.12.2006
    Beiträge
    61
    Danke
    2
    Erhielt 18 Danke für 16 Beiträge

    Standard

    Hallo,

    beim Fahren auf Festanschlag will mann dies meist nicht mit 100% des zur Verfügung stehenden Momentes tun, deshalb kann man in dem Parameter Torque eine evtl. Reduzierung des Momentes angeben. Ob die Vorgabe in % oder absolut in NM angegeben wird kann man in der Konfiguration eistellen(siehe Hilfe zum Baustein), das gleiche gilt übrigens auch für den MC_TorqueLimit.
    Da du ein IM174 verwendest kannst du das aber eh vergessen, da die Momentenvorgabe an die Antriebe nur über Bus funktioniert(du hast aber die Antriebe analog dran)!
    Sprich im Profidrive Telegram3 der IM ist das auch gar nicht vorgesehen.

    Evtl. kannst du zwar den Baustein verwenden aber halt mit 100% auf Festanschlag fahren.

    Übrigens, bei einer hydraulischen Achse geht die Momentenreduzierung (zumindest so ) nicht.


    Gruß
    Watchdog

  3. Folgender Benutzer sagt Danke zu Watchdog für den nützlichen Beitrag:

    Daniel_79 (07.12.2008)

  4. #3
    Daniel_79 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.12.2008
    Beiträge
    15
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Was würde es bedeuten auf 100 Prozent festanschlag zu fahren?

    Sollte ich lieber versuchen das Teil das ich mit dem Greifer Halten möchte mit geteachten werten anzufahren?

    Gruß
    Dani

  5. #4
    Registriert seit
    21.12.2006
    Beiträge
    61
    Danke
    2
    Erhielt 18 Danke für 16 Beiträge

    Standard

    Nun, es könnte sein das dein zu greifendes Werkstück das bis zu 100% Moment(abhängig von dem eingestellten Schleppabstand, Kv etc.) nicht ab kann.
    Ich würde ganz einfach das Moment im Antrieb soweit fest reduzieren das das Werkstück nicht kaputt geht, noch sicher gegriffen wird und die Achse ausreichend beschleunigen kann.

    Hast du überhaupt schon probiert ob der MoveToEndPos mit der IM174 prinzipiell funktioniert, bin mir nicht sicher ob da nicht ein Fehler kommt.
    Ansonsten würd ich ganz einfach postionieren, Werkstückpos. -1mm(fürs Klemmen).

  6. #5
    Daniel_79 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.12.2008
    Beiträge
    15
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Jo ich würde es gerne versuchen, aber leider fehlen mir noch 3 encoder und 3 servoverstärker. Diese sind gerade erst bestellt worden. Bis jetzt konnte ich nur rein fiktiv mein programm erstellen. Das Werkstück ist einfach nur ein Holzklotz.

    Ich denke ich werde einfach einen MoveAbsolute machen und dann den geteachten wert anfahren, den man per handbetrieb (sofern mein Programm soweit funktioniert) anfahren und übernehmen kann.

    Ich werde aber auf jedenfall ausprobieren ob es mit Festanschlag auch geht und dann wieder meldung machen.

    Bis dahin vielen Dank

    Dani

  7. #6
    Registriert seit
    21.12.2006
    Beiträge
    61
    Danke
    2
    Erhielt 18 Danke für 16 Beiträge

    Standard

    Ein kleiner Tip, wenn du deine Achsen vorübergehend auf virtuell umschaltest kannst du dein Programm und die Verfahrbewegungen schon großteils testen. Die Achsen werden dann intern virtuell gefahren, damit kannst du fast testen wie mit realen Achsen, außer das ich etwas mech. bewegt.

    Die Momentenreduzierung läßt sich aber natürlich nicht virtuell testen.

    Gruß
    Watchdog

  8. #7
    Daniel_79 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.12.2008
    Beiträge
    15
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Da hast du im Prinzip schon recht, nur leider habe ich bausteine verwendet und gleichlaufachsen etc... die funktionieren nur als reelle achsen.

    Gruß
    Dani

  9. #8
    Registriert seit
    19.07.2004
    Beiträge
    414
    Danke
    44
    Erhielt 34 Danke für 20 Beiträge

    Standard

    Dani, das ist nicht so ganz richtig... Du kannst mit den virtuellen Achsen (fast) alles Simulieren, auch Getriebegleichlauf etc...
    Für richtiges Chaos,braucht man sehr schnelle Computer.
    Und wieso einfach... .... wenn es auch Siemens gibt




  10. #9
    Daniel_79 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.12.2008
    Beiträge
    15
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hmm... wenn ihr das alle sagt glaub ich das euch mal. habe zwar in der dokumentation (1000 und noch mehr seiten) gelesen das dies nicht möglich wäre, aber sobald ich mein touchpanel integriert hab werd ich es einfach versuchen.

  11. #10
    Daniel_79 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.12.2008
    Beiträge
    15
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also ich habe an dem Eingang Torque gar nichts eingetragen. Es funktioniert Prima.
    Wenn man den Greifer langsam zu fährt, klemmt es auch gar nicht so fest.

Ähnliche Themen

  1. Torque Antriebe
    Von GFI im Forum Antriebstechnik
    Antworten: 7
    Letzter Beitrag: 07.07.2011, 08:50
  2. Pin Belegung MPI Kabel ??
    Von extra im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 15.08.2008, 20:50
  3. SFC1 - Belegung CDT
    Von Karli im Forum HMI
    Antworten: 7
    Letzter Beitrag: 24.06.2008, 11:52
  4. Belegung PMA TTY Stecker
    Von lorenz2512 im Forum Elektronik
    Antworten: 0
    Letzter Beitrag: 03.01.2007, 20:58
  5. S7-CPU 317 Profibus DP-Belegung
    Von be337 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 05.12.2006, 15:10

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •