Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: S5 CPU wechseln

  1. #1
    Registriert seit
    27.05.2007
    Beiträge
    18
    Danke
    4
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen !
    Ich bin seit langer Zeit mal wieder mit einem Problem da. Ich habe zur Zeit sehr viel mit S5 zu tun. Ich habe eine 115U mit CPU 943B . An der 2. Schnittstelle betreibe ich zur Parametereingabe ein Operator-Paneel (EXOR UniOP 25-ER touch). Nun zeigt mir eine blinkende LED (COM) am Paneel eine Kommunikations-Störung an. Ich habe das Verbindungs-Kabel schon erneuert.
    Nun meine Fragen: Kann die CPU das Problem verursachen. Und wenn ja, kann ich die CPU einfach nach Datensicherung austauschen. Ich habe da etwas im Hinterkopf von eiem Systemdatenbaustein (DB0 oder DB1). Wird diese Baustein mitgesichert oder muß ich den neu erstellen ? Viele Fragen auf einmal, ich hoffe auf einige Antworten von S5-Fachleuten.
    Vilen Dank und MfG
    Zitieren Zitieren S5 CPU wechseln  

  2. #2
    Registriert seit
    03.12.2008
    Beiträge
    654
    Danke
    160
    Erhielt 185 Danke für 113 Beiträge

    Standard

    Hallo Klaus

    Normalerweise solltest du keine Probleme kriegen wenn du einen AG-Abzug machst und diesen dann in die neue CPU überträgst. Vorausgesetzt du hast die gleiche CPU zum Austausch zur Verfügung.

    Der DB1 ist in der S5-Welt soweit ich weiß,vergleichbar mit der Hardware Konfiguration oder den Sytemdaten in S7. Der DB1 muß natürlich mit ausgelesen werden und auch in die neue CPU übertragen werden.

    Aufpassen: Wenn du beim auslesen des AG angibst Übertragen -> Bausteine <B>
    werden OB´s grösser OB30 nicht automatisch mit übertragen.
    (z. B. OB34 für Batteirieausfall) also den AG-Abzug nochmal komplett vergleichen bevor du die CPU ziehst

  3. #3
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.792
    Danke
    398
    Erhielt 2.416 Danke für 2.012 Beiträge

    Standard

    Hallo Klaus,
    einen DB0 oder DB1 in der geschilderten Funktion gibt es meines Wissens in der 115U nicht. Das war nur bei der 90U,95U und eventuell auch in den 100er AG's so.

    Die 2. Schnittstelle der 943B ist eine TTY-Schnittstelle, genau wie die Programmierschnittstelle auch. Möglicherweise ist nicht das Kabel oder die CPU das Problem sondern der RS232->TTY Wandler, den es auch noch geben muss.
    Die Schnittstelle kannst du aber ganz einfach testen. Wenn sie defekt ist, dann kannst du dir keine Status-Info's mit dem PG einlesen (die Schnittstelle kann das meißte der 1. Schnittstelle). Vielleicht das zuerst mal testen ...

    Gruß
    LL

  4. #4
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.261
    Danke
    537
    Erhielt 2.707 Danke für 1.956 Beiträge

    Standard

    Ein Problem gibt es beim AG-Abzug der S5. Sind zugekaufte gesicherte Siemens-Bausteine auf dem AG, werden diese nicht mitgesichert, sondern nur ein Platzhalter davon. Daher braucht man in diesem Falle besser das Originalprojekt oder zumindest die Bibliothek mit den Sonderbausteinen sonst kann es passieren, daß nichts meht geht. Man kann das evtl. auch überprüfen, indem man sich mal die Länge der Sonderbausteine nach dem AG-Abzug ansieht. Ich hatte dieses Problem einmal (schon lang her ), weiß aber nicht, ob das bei allen Bausteinen von Siemens so war.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  5. #5
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Idee

    Hallo,

    Zitat Zitat von Larry Laffer
    einen DB0 oder DB1 in der geschilderten Funktion gibt es meines Wissens in der 115U nicht.
    Um das mal zu klären :

    Einen DB 0 gibt es in jeder S5, aber nur im Arbeitsspeicher des AG. Darin führt das Betriebssystem des AG eine Liste mit den Anfangsadressen aller vorhandenen Bausteine im AG. Ist also so etwas wie der Buchhalter über die Bausteine. Der DB 0 wird beim Transfer AG <--> PG bzw. umgekehrt nicht übertragen. Der DB 0 kann von der STEP5 Programmiersoftware nicht bearbeitet werden.
    Und war trotzdem manipulierbar über LIR und TIR Systembefehle

    Zitat Zitat von Paul
    Der DB1 ist in der S5-Welt soweit ich weiß,vergleichbar mit der Hardware Konfiguration oder den Sytemdaten in S7. Der DB1 muß natürlich mit ausgelesen werden und auch in die neue CPU übertragen werden.
    So ist es, den DB1 gibt es auch bei der hier diskutierten 115U. Eigentlich auch in allen S5'en, ausser 150A/K/S/U, 101U, 130A/K und anderen alten Dingern, aber das kann/sollte man in den jeweiligen Handbüchern nachlesen.

    Gruß

    Question_mark
    ''Ich habe wirklich keine Vorurteile.
    Meine Meinung ist nur die Summe der Erfahrungen" ... (Question_mark)
    Zitieren Zitieren DB0 und DB1  

  6. #6
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Idee

    Hallo,

    Zitat Zitat von Ralle
    Sind zugekaufte gesicherte Siemens-Bausteine auf dem AG, werden diese nicht mitgesichert, sondern nur ein Platzhalter davon.
    Diese Meinung kann ich so nicht teilen, jedenfalls meine Erfahrung ...
    Probleme kann es nur geben, wenn z.B. beim Wechsel auf einen anderen S5 CPU-Typ diese Sonderbausteine wie z.B. "SEND" oder "RECEIVE" auf der neueren CPU plötzlich schon im Systemprogramm als OB vorhanden sind.
    Dann muss man sich selber einen "Platzhalterbaustein" erstellen. Ist zwar die Ausnahme, aber das Problem wurde hier im Forum vor ein paar Wochen schon mal diskutiert.

    Gruß

    Question_mark
    ''Ich habe wirklich keine Vorurteile.
    Meine Meinung ist nur die Summe der Erfahrungen" ... (Question_mark)
    Zitieren Zitieren Einspruch ...  

  7. #7
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.261
    Danke
    537
    Erhielt 2.707 Danke für 1.956 Beiträge

    Standard

    @qm

    Es kann sicher nicht schaden, sich das nach dem AG-Abzug genauer anzusehen, ehe man das AG aus dem Rack nimmt.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  8. #8
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Beitrag

    Hallo,

    Zitat Zitat von Ralle
    Es kann sicher nicht schaden, sich das nach dem AG-Abzug genauer anzusehen, ehe man das AG aus dem Rack nimmt.
    Das kann niemals schaden, ich kann auch nur jedem empfehlen diese Kontrolle vor dem CPU-Tausch durchzuführen.

    Gruß

    Question_mark
    ''Ich habe wirklich keine Vorurteile.
    Meine Meinung ist nur die Summe der Erfahrungen" ... (Question_mark)
    Zitieren Zitieren Vertrauen gut, Kontrolle besser  

  9. #9
    klaus.mengel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.05.2007
    Beiträge
    18
    Danke
    4
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Hallo an alle !
    Zunächst mal schönen Dank für das rege Interesse an meinem Problem. Es ist halt schon so lange her mit den S5en, aber immer wieder spannend ! Ich werde die Problemlösung allerdings erst am Montag angreifen und anschließend über den Erfolg (oder Misserfolg) berichten. Bis dahin nochmal vielen Dank und noch schöne Restweihnachten !
    MfG klaus

  10. #10
    klaus.mengel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.05.2007
    Beiträge
    18
    Danke
    4
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo an alle !
    Leider kann ich meine Problemlösung erst heute hier präsentieren. Weil ich es jedoch angekündigt hatte, werde ich es hiermit machen. Also : Ich habe einfach nach vollständigem AG-Abzug (alle Bausteine) die CPU gewechselt, die neue hat nach der Datenübertragung sofort funktioniert. Die Konfiguration für das UniOP ER25T von EXOR (wird über die 2. Schnittstelle der CPU betrieben) mußte ich allerdings neu einbinden. Nochmals vielen Dank für Euer Interesse.
    Klaus Mengel

Ähnliche Themen

  1. Wechseln zwischen PDI4 und IM174
    Von you im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 05.12.2010, 21:06
  2. Power PG Display wechseln
    Von bluescreen im Forum PC- und Netzwerktechnik
    Antworten: 0
    Letzter Beitrag: 14.05.2010, 12:39
  3. FIELD PG M DVD Laufwerk wechseln
    Von MannLacht im Forum PC- und Netzwerktechnik
    Antworten: 6
    Letzter Beitrag: 08.05.2008, 16:42
  4. Meldungen in Meldeanzeige wechseln
    Von Anatol_r im Forum HMI
    Antworten: 4
    Letzter Beitrag: 18.07.2007, 10:51
  5. Lichtbänder komplett wechseln
    Von lorenz2512 im Forum Stammtisch
    Antworten: 6
    Letzter Beitrag: 08.09.2005, 18:01

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •