Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: Variablenaustausch SPS zwischen TouchPanel TP170A

  1. #21
    NeOder is offline Neuer Benutzer
    Themenstarter
    Join Date
    17.01.2009
    Posts
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    also als erstes danke nochmal für die vielen hilfreichen tipps...
    doch wir sind heute leider trozdem nicht sehrviel weiter gekommen, wir haben eine variblen tabelle genutzt und es wurde uns dann auch symbol und kommentar etc. ausgeben wenn wir sie im FC benutzt haben und im OB erscheinen nach schreiben von 'call fc1' sofort die variablen, denen wir adressen o.ä. zuornden können, jeddoch haben wir immer noch kein 1 signal ausgeben können, ich weiß nicht genau an welcher stelle es liegt und eine diagnose der sps kann ich leider nicht gleichzeit machen während sps und touchpanel verbunden sind, weil wir jedes mal umstecken müssen:
    SPS - TP170A - MPI
    SPS - PC - MPI
    TP170A - PC - seriell
    Ich denke unser problem liegt daran, dass die viele tabellen und verwirren, wir wissen nicht genau an welcher stelle eine 'bool' variable, ein z.b.: 'mw 20' nur ein merker 'M0.1' und wann und wo wir diese variablen auf eingabe oder ausgabe baugruppen der sps geben sollen
    ich werde morgen nochmal versuchen unsere momentane situation bildlich hier einzufügen, so dass ihr euch ein besseres bild machen könnt...
    aber es wäre nett, wenn ihr noch bis morgen etwas hilfreiches posten könntet, so dass wir morgen vorrankommen
    danke

  2. #22
    Join Date
    03.12.2008
    Posts
    928
    Danke
    213
    Erhielt 241 Danke für 150 Beiträge

    Default

    Hallo
    Wenn ihr effektiv arbeiten wollt, müßt ihr mit dem Panel und den Programmiergerät gleichzeitig an die Steurung können, sonst hat das alles keinen Sinn.
    Dazu braucht ihr Busstecker auf die man hinten noch einen zweiten Busstecker draufstecken kann.

    z.B. 2 x Profibusstecker 6ES7 872-0BB50-0XA0 (oder vergleichbare) und ein Stück Profibusleitung.

    Als aller erstes müßt ihr prüfen ob die Verbindung zwischen Panel und Steuerung überhaupt steht, ich habe das Gefühl das ihr da selbst nicht 100%ig sicher seid


    Jetzt kommt ein Zitat von mir selbst:
    Wenn du prüfen willst ob deine Verbindung überhaupt steht gehe so vor:
    Ich würde zuerst nicht mit Buttons usw. rumprobieren, mach dir ein Ausgabefeld, füge eine neue Variable ein (die braucht erstmal gar nicht Symbolik verknüpft werden), und schaue mit der Variablen auf ein unbenutztes Merkerwort (z.B. MW20).

    Wenn du nun im Simatic-Manager über Variablentabelle etwas ins MW20 schreibst, muss sich im Ausgabefeld des TP170 etwas ändern, egal welches Darsellungsformat etc. gewählt ist.
    Bevor das nicht funktioniert steht die Verbindung nicht, und du hast keine Chanche mit Buttons etc.
    Zitat Ende


    mfg
    Paul

  3. #23
    Join Date
    03.12.2008
    Posts
    928
    Danke
    213
    Erhielt 241 Danke für 150 Beiträge

    Default

    wir wissen nicht genau an welcher stelle eine 'bool' variable, ein z.b.: 'mw 20' nur ein merker 'M0.1' und wann und wo wir diese variablen auf eingabe oder ausgabe baugruppen der sps geben sollen
    Auf Eingänge könnt ihr Variablen sowieso nicht legen und Ausgänge sind im Moment auch nicht gefragt, denn das Panel kann ja in die Steuerung "hineinschauen" und direkt auf Merker oder Datenbausteine zugreifen.

    MfG
    Paul

  4. #24
    NeOder is offline Neuer Benutzer
    Themenstarter
    Join Date
    17.01.2009
    Posts
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    hier also die Bilder unseres momentanen versuches eine variable zu übergeben: (5 von 7)
    Attached Images Attached Images

  5. #25
    NeOder is offline Neuer Benutzer
    Themenstarter
    Join Date
    17.01.2009
    Posts
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    und hier bild 6 und 7:
    Attached Images Attached Images

  6. #26
    Join Date
    03.12.2008
    Posts
    928
    Danke
    213
    Erhielt 241 Danke für 150 Beiträge

    Default

    Hast du das in deinem ProTool stehen
    Attached Images Attached Images

  7. #27
    NeOder is offline Neuer Benutzer
    Themenstarter
    Join Date
    17.01.2009
    Posts
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    wir haben bei kommunikationspartner noch etwas auswählen können, aber sonst steht dort alles das selbe drinnen.
    wir haben es heute aber geschafft die verbindung aufzubauen und einen variblen austausch zu ermöglichen
    Unser problem lag wohl eher and der hardware, wir versuchen es mit einen anderen kabel, was uns vorher als nicht dafür geeignet erschien...
    wir nutzen somit einen anderen adapter am touchpanel und die übertragung funktionierte...
    Zum Schluss nochmal danke an alle helfer,denn ohne sicherheit, dass es an der hardware und nicht an der software liegen muss hätten wir es glaube ich nicht demnächst rausbekommen.
    Vielen Dank.

Similar Threads

  1. Replies: 1
    Last Post: 27.02.2018, 11:13
  2. Replies: 7
    Last Post: 04.05.2013, 23:50
  3. Kommunikation zwischen CPX-CEC und Touchpanel funktioniert nicht
    By marcell89 in forum CODESYS und IEC61131
    Replies: 1
    Last Post: 04.03.2013, 21:19
  4. Kommunikation zwischen Touchpanel und CPU
    By patrick_123 in forum Simatic
    Replies: 8
    Last Post: 23.02.2011, 08:16
  5. Ethernetverbindung zwischen Omron SPS und TouchPanel
    By Pavel in forum Sonstige Steuerungen
    Replies: 2
    Last Post: 16.12.2007, 21:22

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •